[PATCH 8/9] gnu: Add node-crx3.

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Marius Bakke
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
Merged with
N
N
Nicolas Graves wrote on 14 Jun 2022 11:49
(address . guix-patches@gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20220614094954.15197-8-ngraves@ngraves.fr
* gnu/packages/node-xyz.scm (node-crx3): New variable.
---
gnu/packages/node-xyz.scm | 40 +++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 8ec014eee8..79594856f1 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -109,6 +109,46 @@ (define-public node-color-name
"This package provides a JSON list with color names and their values.")
(license license:expat)))
+(define-public node-crx3
+ (package
+ (name "node-crx3")
+ (version "1.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ahwayakchih/crx3")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1snqyw8c3s9p2clhqh1172z0rs1was36sfxkk6acgpar32c2rwzw"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'unpack 'replace-mri-by-minimist
+ (lambda _
+ (substitute* "package.json"
+ (("\"mri\": \"\\^1.1.6\",") "\"minimist\": \"^1.2.6\","))
+ (substitute* "lib/configuration.js"
+ (("mri") "minimist"))
+ #t))
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke (string-append (assoc-ref inputs "node") "/bin/npm")
+ "--offline" "--ignore-scripts" "install" "--production")
+ #t)))))
+ (inputs (list node-minimist node-pbf node-yazl))
+ (home-page "https://github.com/ahwayakchih/crx3")
+ (synopsis "Create web extension files for Chromium and all other browsers
+supporting the file format and API")
+ (description "This package creates web extension files (CRXv3) for Chromium
+versions 64.0.3242 and above and all other browsers supporting the file format
+and API.")
+ (license license:bsd-3)))
+
(define-public node-env-variable
(package
(name "node-env-variable")
--
2.36.1
L
L
Liliana Marie Prikler wrote on 15 Jun 2022 11:21
(address . control@debbugs.gnu.org)
c511c7cd5bad5cf933cfee73d92d8253d8b3c9ef.camel@ist.tugraz.at
merge 55958 55959 55960 55961 55962 55963 55964 55965 55966
thanks
M
M
Marius Bakke wrote on 23 Jun 2022 23:17
(name . Nicolas Graves)(address . ngraves@ngraves.fr)
87tu8bqdtx.fsf@gnu.org
Nicolas Graves via Guix-patches via <guix-patches@gnu.org> skriver:

Toggle quote (37 lines)
> * gnu/packages/node-xyz.scm (node-crx3): New variable.
> ---
> gnu/packages/node-xyz.scm | 40 +++++++++++++++++++++++++++++++++++++++
> 1 file changed, 40 insertions(+)
>
> diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
> index 8ec014eee8..79594856f1 100644
> --- a/gnu/packages/node-xyz.scm
> +++ b/gnu/packages/node-xyz.scm
> @@ -109,6 +109,46 @@ (define-public node-color-name
> "This package provides a JSON list with color names and their values.")
> (license license:expat)))
>
> +(define-public node-crx3
> + (package
> + (name "node-crx3")
> + (version "1.1.3")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/ahwayakchih/crx3")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1snqyw8c3s9p2clhqh1172z0rs1was36sfxkk6acgpar32c2rwzw"))))
> + (build-system node-build-system)
> + (arguments
> + '(#:phases
> + (modify-phases %standard-phases
> + (delete 'check)
> + (add-after 'unpack 'replace-mri-by-minimist
> + (lambda _
> + (substitute* "package.json"
> + (("\"mri\": \"\\^1.1.6\",") "\"minimist\": \"^1.2.6\","))

Dots should also be escaped, otherwise they match any character.
Personally I prefer to have the replacement on a second line for
readability but no strong opinion.

Toggle quote (13 lines)
> + (substitute* "lib/configuration.js"
> + (("mri") "minimist"))
> + #t))
> + (replace 'configure
> + (lambda* (#:key inputs #:allow-other-keys)
> + (invoke (string-append (assoc-ref inputs "node") "/bin/npm")
> + "--offline" "--ignore-scripts" "install" "--production")
> + #t)))))
> + (inputs (list node-minimist node-pbf node-yazl))
> + (home-page "https://github.com/ahwayakchih/crx3")
> + (synopsis "Create web extension files for Chromium and all other browsers
> +supporting the file format and API")

Perhaps 'Create CRXv3 browser extensions with JavaScript'?

Also, can you add your copyright at the top of the file?
-----BEGIN PGP SIGNATURE-----

iIUEARYKAC0WIQRNTknu3zbaMQ2ddzTocYulkRQQdwUCYrTYeg8cbWFyaXVzQGdu
dS5vcmcACgkQ6HGLpZEUEHesywEA3EVKBsv7hFVtgVTKOFrSheCfwUyeB3rJXtmm
NLFYC7IBAPdLRFZD46SiQxSwvvSM9EDzLcFYyum16Z8UCaMTe6YF
=KQH3
-----END PGP SIGNATURE-----

N
N
Nicolas Graves wrote on 20 Jul 2022 12:20
[PATCH] gnu: Add node-crx3.
(address . 55965@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20220720102034.16652-1-ngraves@ngraves.fr
* gnu/packages/node-xyz.scm (node-crx3): New variable.
---
gnu/packages/node-xyz.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index ff3bd9084f..7c506afe41 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -108,6 +108,45 @@ (define-public node-color-name
"This package provides a JSON list with color names and their values.")
(license license:expat)))
+(define-public node-crx3
+ (package
+ (name "node-crx3")
+ (version "1.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ahwayakchih/crx3")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1snqyw8c3s9p2clhqh1172z0rs1was36sfxkk6acgpar32c2rwzw"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'replace-mri-by-minimist
+ (lambda _
+ (substitute* "package.json"
+ (("\"mri\": \"\\^1\\.1\\.6\",")
+ "\"minimist\": \"^1.2.6\","))
+ (substitute* "lib/configuration.js"
+ (("mri")
+ "minimist"))))
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke "npm" "--offline"
+ "--ignore-scripts" "install" "--production"))))))
+ (inputs (list node-minimist node-pbf node-yazl))
+ (home-page "https://github.com/ahwayakchih/crx3")
+ (synopsis "Create CRXv3 browser extensions with Javascript")
+ (description "This package creates web extension files (CRXv3) for Chromium
+versions 64.0.3242 and above and all other browsers supporting the file format
+and API.")
+ (license license:bsd-3)))
+
(define-public node-env-variable
(package
(name "node-env-variable")
--
2.37.0
?