[PATCH 4/9] gnu: Add node-resolve-protobuf-schema.

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Marius Bakke
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
Merged with
N
N
Nicolas Graves wrote on 14 Jun 2022 11:49
(address . guix-patches@gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20220614094954.15197-4-ngraves@ngraves.fr
* gnu/packages/node-xyz.scm (node-resolve-protobuf-schema): New variable.
---
gnu/packages/node-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 3f49955e29..8f3288f219 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -263,6 +263,37 @@ (define-public node-protocol-buffers-schema
in Javascript.")
(license license:expat)))
+(define-public node-resolve-protobuf-schema
+ (package
+ (name "node-resolve-protobuf-schema")
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mafintosh/resolve-protobuf-schema")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0zxavr0b2yz9xzp6zlsg5g09i0a6zqb24j12rdvfgph6wd4mzk40"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke (string-append (assoc-ref inputs "node") "/bin/npm")
+ "--offline" "--ignore-scripts" "install" "--production")
+ #t)))))
+ (inputs (list node-protocol-buffers-schema))
+ (home-page "https://github.com/mafintosh/resolve-protobuf-schema")
+ (synopsis "Read a protobuf schema from the disk, parse it and resolve all imports")
+ (description "This package allows to read a protobuf schema from the disk,
+parse it and resolve all imports.")
+ (license license:expat)))
+
(define-public node-stack-trace
;; There have been improvements since the last release.
(let ((commit "4fd379ee78965ce7ce8820b436f1b1b590d5dbcf")
--
2.36.1
L
L
Liliana Marie Prikler wrote on 15 Jun 2022 11:21
(address . control@debbugs.gnu.org)
c511c7cd5bad5cf933cfee73d92d8253d8b3c9ef.camel@ist.tugraz.at
merge 55958 55959 55960 55961 55962 55963 55964 55965 55966
thanks
M
M
Marius Bakke wrote on 23 Jun 2022 22:54
(name . Nicolas Graves)(address . ngraves@ngraves.fr)
875ykrrtgl.fsf@gnu.org
Nicolas Graves via Guix-patches via <guix-patches@gnu.org> skriver:

Toggle quote (38 lines)
> * gnu/packages/node-xyz.scm (node-resolve-protobuf-schema): New variable.
> ---
> gnu/packages/node-xyz.scm | 31 +++++++++++++++++++++++++++++++
> 1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
> index 3f49955e29..8f3288f219 100644
> --- a/gnu/packages/node-xyz.scm
> +++ b/gnu/packages/node-xyz.scm
> @@ -263,6 +263,37 @@ (define-public node-protocol-buffers-schema
> in Javascript.")
> (license license:expat)))
>
> +(define-public node-resolve-protobuf-schema
> + (package
> + (name "node-resolve-protobuf-schema")
> + (version "2.1.0")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/mafintosh/resolve-protobuf-schema")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0zxavr0b2yz9xzp6zlsg5g09i0a6zqb24j12rdvfgph6wd4mzk40"))))
> + (build-system node-build-system)
> + (arguments
> + '(#:phases
> + (modify-phases %standard-phases
> + (delete 'check)
> + (replace 'configure
> + (lambda* (#:key inputs #:allow-other-keys)
> + (invoke (string-append (assoc-ref inputs "node") "/bin/npm")
> + "--offline" "--ignore-scripts" "install" "--production")
> + #t)))))

Same comments as ... you get the drift.

Toggle quote (4 lines)
> + (inputs (list node-protocol-buffers-schema))
> + (home-page "https://github.com/mafintosh/resolve-protobuf-schema")
> + (synopsis "Read a protobuf schema from the disk, parse it and resolve all imports")

Maybe just "Resolve protobuf imports".

Toggle quote (3 lines)
> + (description "This package allows to read a protobuf schema from the disk,
> +parse it and resolve all imports.")

s/allows to/can/
-----BEGIN PGP SIGNATURE-----

iIUEARYKAC0WIQRNTknu3zbaMQ2ddzTocYulkRQQdwUCYrTTGg8cbWFyaXVzQGdu
dS5vcmcACgkQ6HGLpZEUEHc75gEAtKdyKUVPVYZ6q7vVU2vjMEKw1St3GTQUw8I6
r1/6JmQA/ROJnpDQ20zeiMNGmdSKHPg/9ey+Bj3izIvjZUXOAWsB
=Kb7s
-----END PGP SIGNATURE-----

N
N
Nicolas Graves wrote on 20 Jul 2022 11:34
[PATCH] gnu: Add node-resolve-protobuf-schema.
(address . 55959@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20220720093419.13705-1-ngraves@ngraves.fr
* gnu/packages/node-xyz.scm (node-resolve-protobuf-schema): New variable.
---
gnu/packages/node-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 4e28224cdf..8d85ebaa48 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -261,6 +261,36 @@ (define-public node-protocol-buffers-schema
written in Javascript.")
(license license:expat)))
+(define-public node-resolve-protobuf-schema
+ (package
+ (name "node-resolve-protobuf-schema")
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mafintosh/resolve-protobuf-schema")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0zxavr0b2yz9xzp6zlsg5g09i0a6zqb24j12rdvfgph6wd4mzk40"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke "npm" "--offline"
+ "--ignore-scripts" "install" "--production"))))))
+ (inputs (list node-protocol-buffers-schema))
+ (home-page "https://github.com/mafintosh/resolve-protobuf-schema")
+ (synopsis "Resolve protobuf imports")
+ (description "This package can read a protobuf schema from the disk, parse
+it and resolve all imports.")
+ (license license:expat)))
+
(define-public node-stack-trace
;; There have been improvements since the last release.
(let ((commit "4fd379ee78965ce7ce8820b436f1b1b590d5dbcf")
--
2.37.0
?