[PATCH 5/9] gnu: Add node-ieee754.

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Marius Bakke
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
Merged with
N
N
Nicolas Graves wrote on 14 Jun 2022 11:49
(address . guix-patches@gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20220614094954.15197-5-ngraves@ngraves.fr
* gnu/packages/node-xyz.scm (node-ieee754): New variable.
---
gnu/packages/node-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 8f3288f219..3d945871cd 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -458,6 +458,37 @@ (define-public node-once
if desired.")
(license license:isc)))
+(define-public node-ieee754
+ (package
+ (name "node-ieee754")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/feross/ieee754")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19rlg59lavnwsvbblhvrqwinz2wzqlxhddqpwrc3cyqkscjgza7i"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke (string-append (assoc-ref inputs "node") "/bin/npm")
+ "--offline" "--ignore-scripts" "install" "--production")
+ #t)))))
+ (home-page "https://github.com/feross/ieee754")
+ (synopsis "Read/write IEEE754 floating point numbers from/to a Buffer or
+array-like object")
+ (description "This package allows to read/write IEEE754 floating point
+numbers from/to a Buffer or array-like object in Javascript.")
+ (license license:bsd-3)))
+
(define-public node-inherits
(package
(name "node-inherits")
--
2.36.1
L
L
Liliana Marie Prikler wrote on 15 Jun 2022 11:21
(address . control@debbugs.gnu.org)
c511c7cd5bad5cf933cfee73d92d8253d8b3c9ef.camel@ist.tugraz.at
merge 55958 55959 55960 55961 55962 55963 55964 55965 55966
thanks
M
M
Marius Bakke wrote on 23 Jun 2022 23:07
(name . Nicolas Graves)(address . ngraves@ngraves.fr)
8735fvrsvr.fsf@gnu.org
Nicolas Graves via Guix-patches via <guix-patches@gnu.org> skriver:

Toggle quote (38 lines)
> * gnu/packages/node-xyz.scm (node-ieee754): New variable.
> ---
> gnu/packages/node-xyz.scm | 31 +++++++++++++++++++++++++++++++
> 1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
> index 8f3288f219..3d945871cd 100644
> --- a/gnu/packages/node-xyz.scm
> +++ b/gnu/packages/node-xyz.scm
> @@ -458,6 +458,37 @@ (define-public node-once
> if desired.")
> (license license:isc)))
>
> +(define-public node-ieee754
> + (package
> + (name "node-ieee754")
> + (version "1.2.1")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/feross/ieee754")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "19rlg59lavnwsvbblhvrqwinz2wzqlxhddqpwrc3cyqkscjgza7i"))))
> + (build-system node-build-system)
> + (arguments
> + '(#:phases
> + (modify-phases %standard-phases
> + (delete 'check)
> + (replace 'configure
> + (lambda* (#:key inputs #:allow-other-keys)
> + (invoke (string-append (assoc-ref inputs "node") "/bin/npm")
> + "--offline" "--ignore-scripts" "install" "--production")
> + #t)))))

I realize all of these were copy-pasted so I won't repeat any more. ;-)

Toggle quote (6 lines)
> + (synopsis "Read/write IEEE754 floating point numbers from/to a Buffer or
> +array-like object")
> + (description "This package allows to read/write IEEE754 floating point
> +numbers from/to a Buffer or array-like object in Javascript.")

Can you try to either shorten the synopsis or expand on the description
to avoid duplication?

Writing good descriptions is often the most difficult part of writing a
package definition... The upstream documentation is not very helpful in
this case. :-/
-----BEGIN PGP SIGNATURE-----

iIUEARYKAC0WIQRNTknu3zbaMQ2ddzTocYulkRQQdwUCYrTWCA8cbWFyaXVzQGdu
dS5vcmcACgkQ6HGLpZEUEHeKsgEAkhtRtT5gT9TzanP2/UvVmhWbpA47d5uGpxGC
AK9nPJkA/3uFXub/pSsI08vAUmjKA/EG7x2kAMssTjXJKmuo0mEC
=XZvy
-----END PGP SIGNATURE-----

N
N
Nicolas Graves wrote on 20 Jul 2022 12:11
[PATCH] gnu: Add node-ieee754.
(address . 55960@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20220720101102.15070-1-ngraves@ngraves.fr
* gnu/packages/node-xyz.scm (node-ieee754): New variable.
---
gnu/packages/node-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 8d85ebaa48..20325ebbc6 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -455,6 +455,35 @@ (define-public node-once
if desired.")
(license license:isc)))
+(define-public node-ieee754
+ (package
+ (name "node-ieee754")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/feross/ieee754")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19rlg59lavnwsvbblhvrqwinz2wzqlxhddqpwrc3cyqkscjgza7i"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke "npm" "--offline"
+ "--ignore-scripts" "install" "--production"))))))
+ (home-page "https://github.com/feross/ieee754")
+ (synopsis "Read/write IEEE754 floating point numbers in Javascript")
+ (description "This package can read and write IEEE754 floating point
+numbers from/to a Buffer or array-like object in Javascript.")
+ (license license:bsd-3)))
+
(define-public node-inherits
(package
(name "node-inherits")
--
2.37.0
?