(address . guix-patches@gnu.org)
Toggle diff (113 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index cc5131b28d..bd4c8a381a 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -237,7 +237,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "20.2.6")
+ (version "21.1.4")
(source
(origin
(method url-fetch)
@@ -249,9 +249,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
-
"1nw5k2qrlcrp5bljy1lmyybgl525y0h44synkbbirw92qv3a6b7i"))
- (patches
- (search-patches "mesa-skip-tests.patch"))))
+
"02z9g6zpkg1p1sm8f84xdi7v2n7x534x9pn565bvcr411527y5qz"))))
(build-system meson-build-system)
(propagated-inputs
`(;; The following are in the Requires.private field of
gl.pc.
@@ -278,7 +276,9 @@ also known as DXTn or DXTC) for Mesa.")
(_
`()))
("wayland" ,wayland)
- ("wayland-protocols" ,wayland-protocols)))
+ ("wayland-protocols" ,wayland-protocols)
+ ("libglvnd" ,libglvnd) ;required for glvnd
support
+ ("libclc" ,libclc))) ;required for opencl
support
(native-inputs
`(("bison" ,bison)
("flex" ,flex)
@@ -307,15 +307,16 @@ also known as DXTn or DXTC) for Mesa.")
;; omx requires libomxil-bellagio
"-Dplatforms=x11,wayland"
"-Dglx=dri" ;Thread Local Storage, improves
performance
- ;; "-Dopencl=true"
+ "-Dopencl=true"
;; "-Domx=true"
- "-Dosmesa=gallium"
- "-Dgallium-xa=enabled"
+ "-Dosmesa=true"
+ "-Dgallium-xa=true"
+ "-Dglvnd=true"
;; features required by wayland
- "-Dgles2=enabled"
- "-Dgbm=enabled"
- "-Dshared-glapi=enabled"
+ "-Dgles2=true"
+ "-Dgbm=true"
+ "-Dshared-glapi=true"
;; Explicitly enable Vulkan on some architectures.
,@(match (%current-system)
@@ -417,8 +418,8 @@ also known as DXTn or DXTC) for Mesa.")
(let ((out (assoc-ref outputs "out"))
(bin (assoc-ref outputs "bin")))
;; Not all architectures have the Vulkan overlay
control script.
- (mkdir-p (string-append bin "/bin"))
- (call-with-output-file (string-append bin
"/bin/.empty")
+ (mkdir-p (string-append out "/bin"))
+ (call-with-output-file (string-append out
"/bin/.empty")
(const #t))
(copy-recursively (string-append out "/bin")
(string-append bin "/bin"))
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 97fc921436..f7b4e95b9c 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -638,7 +638,7 @@ rasterisation.")
(define-public libdrm
(package
(name "libdrm")
- (version "2.4.104")
+ (version "2.4.106")
(source (origin
(method url-fetch)
(uri (string-append
@@ -646,7 +646,7 @@ rasterisation.")
version ".tar.xz"))
(sha256
(base32
-
"1jqvx9c23hgwhq109zqj6vg3ng40pcvh3r1k2fn1a424qasxhsnn"))))
+
"1m3vwpabjg3az84vmyxi96jyd7rrqm6qkhk1gq41w5wv89aarn4j"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
@@ -663,7 +663,8 @@ rasterisation.")
(replace 'check
(lambda _
(invoke "meson" "test" "--timeout-multiplier"
"5"))))))
- (inputs
+ (propagated-inputs
+ ;; libpciaccess is in Requires.private of libdrm_intel.pc
`(("libpciaccess" ,libpciaccess)))
(native-inputs
`(("pkg-config" ,pkg-config)))