[PATCH] Update mesa to 20.2.2

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • romulasry
Owner
unassigned
Submitted by
romulasry
Severity
normal
R
R
romulasry wrote on 11 Nov 2020 20:55
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
BU4TWcibkHavWkCJOcswpqn-33Zo_OqzjSCiAaYGX7r-wCPqkFzAN__IcEQZSa2fJMCutawY71s2uWKNhJTXxIEaWXXpr1tUGgN31qn4V18=@protonmail.com
Sent with [ProtonMail](https://protonmail.com) Secure Email.
Attachment: file
Toggle diff (50 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index fb33bd7f6d..cb01708f9b 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -233,13 +233,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "20.0.7")
-
- ;; Mesa 20.0.5 through 20.0.7 has problems with some graphic drivers, so
- ;; we need this newer version.
- ;; https://gitlab.freedesktop.org/mesa/mesa/-/issues/2882
- ;; https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4861
- (replacement mesa-20.0.8)
+ (version "20.2.2")
(source
(origin
@@ -252,7 +246,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "0y517qpdg6v6dsdgzb365p03m30511sbyh8pq0mcvhvjwy7javpy"))
+ "1f93eb1090cf71490cd0e204e04f8427a82b6ed534b7f49ca50cea7dcc89b861"))
(patches
(search-patches "mesa-skip-disk-cache-test.patch"))))
(build-system meson-build-system)
@@ -446,21 +440,6 @@ device drivers allows Mesa to be used in many different environments ranging
from software emulation to complete hardware acceleration for modern GPUs.")
(license license:x11)))
-;; Replacement package to fix <https://gitlab.freedesktop.org/mesa/mesa/-/issues/2863>.
-(define mesa-20.0.8
- (package
- (inherit mesa)
- (version "20.0.8")
- (source (origin
- (inherit (package-source mesa))
- (uri (list (string-append "https://mesa.freedesktop.org/archive/"
- "mesa-" version ".tar.xz")
- (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
- "mesa-" version ".tar.xz")))
- (sha256
- (base32
- "0v0bfh3ay07s6msxmklvwfaif0q02kq2yhy65fdhys49vw8c1w3c"))))))
-
(define-public mesa-opencl
(package/inherit mesa
(name "mesa-opencl")
M
M
Maxim Cournoyer wrote on 8 Oct 2021 17:04
control message for bug #44584
(address . control@debbugs.gnu.org)
87v92736db.fsf@gmail.com
close 44584
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44584@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44584
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch