[PATCH core-updates] gnu: libdrm: Update to 2.4.107.

  • Done
  • quality assurance status badge
Details
5 participants
  • Thiago Jung Bauermann
  • John Kehayias
  • Kaelyn Takata
  • Ludovic Courtès
  • Maxime Devos
Owner
unassigned
Submitted by
Kaelyn Takata
Severity
normal
K
K
Kaelyn Takata wrote on 5 Jul 2021 10:43
(address . guix-patches@gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
4s2tn7of6SN9mqU6sdllttaKyg4DEmnQh7R0axEJc@cp3-web-047.plabs.ch
* gnu/packages/xdisorg.scm (libdrm): Update to 2.4.107, and change
libpciaccess to a propagated input as the pkg-config for libdrm_intel now
includes it in the libs.
---
gnu/packages/xdisorg.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index d0da2d28d1..1b38149654 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -638,7 +638,7 @@ rasterisation.")
(define-public libdrm
(package
(name "libdrm")
- (version "2.4.104")
+ (version "2.4.107")
(source (origin
(method url-fetch)
(uri (string-append
@@ -646,7 +646,7 @@ rasterisation.")
version ".tar.xz"))
(sha256
(base32
- "1jqvx9c23hgwhq109zqj6vg3ng40pcvh3r1k2fn1a424qasxhsnn"))))
+ "127qf1rzhaf13vdd75a58v5q34617hvangjlfnlkcdh37gqcwm65"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
@@ -663,7 +663,7 @@ rasterisation.")
(replace 'check
(lambda _
(invoke "meson" "test" "--timeout-multiplier" "5"))))))
- (inputs
+ (propagated-inputs
`(("libpciaccess" ,libpciaccess)))
(native-inputs
`(("pkg-config" ,pkg-config)))
--
2.32.0
M
M
Maxime Devos wrote on 5 Jul 2021 17:15
d8f57dfe176e2537517a1bbb8fd71cac1f5e764f.camel@telenet.be
Kaelyn Takata via Guix-patches via schreef op ma 05-07-2021 om 08:43 [+0000]:
Toggle quote (34 lines)
> * gnu/packages/xdisorg.scm (libdrm): Update to 2.4.107, and change
> libpciaccess to a propagated input as the pkg-config for libdrm_intel now
> includes it in the libs.
> ---
> gnu/packages/xdisorg.scm | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
> index d0da2d28d1..1b38149654 100644
> --- a/gnu/packages/xdisorg.scm
> +++ b/gnu/packages/xdisorg.scm
> @@ -638,7 +638,7 @@ rasterisation.")
> (define-public libdrm
> (package
> (name "libdrm")
> - (version "2.4.104")
> + (version "2.4.107")
> (source (origin
> (method url-fetch)
> (uri (string-append
> @@ -646,7 +646,7 @@ rasterisation.")
> version ".tar.xz"))
> (sha256
> (base32
> - "1jqvx9c23hgwhq109zqj6vg3ng40pcvh3r1k2fn1a424qasxhsnn"))))
> + "127qf1rzhaf13vdd75a58v5q34617hvangjlfnlkcdh37gqcwm65"))))
> (build-system meson-build-system)
> (arguments
> `(#:configure-flags
> @@ -663,7 +663,7 @@ rasterisation.")
> (replace 'check
> (lambda _
> (invoke "meson" "test" "--timeout-multiplier" "5"))))))

If you are updating "libdrm" on core-updates anyway,
can you also make the following change (as a separate patch)?:

(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "meson" "test" "--timeout-multiplier" 5))))

That should allow "guix build SOMETHING --without-tests=libdrm" to work.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYOMiIRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7hhLAP9Bu60iThBM2ikD/zqYH/1tmDk/
XrssWAbI6f/kNYeRDwEA+oYVnWN4fj01EMRZ2a2PLZjlat5K5OXR24wIT44QPAk=
=QQcD
-----END PGP SIGNATURE-----


K
K
Kaelyn wrote on 5 Jul 2021 17:58
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 49412@debbugs.gnu.org)
5Pvsg9OZD8vKwdm4EQxqmpNKGC2KiZuZYe_EUcoTjyP7HJwIh_BR3K7AWrE0B4qvbzJE58sQivIwjMr0qXGzc0NI9dKsvFoiefvgl7qQNdA=@protonmail.com
On Monday, July 5th, 2021 at 11:15 AM, Maxime Devos <maximedevos@telenet.be> wrote:

Toggle quote (81 lines)
> Kaelyn Takata via Guix-patches via schreef op ma 05-07-2021 om 08:43 [+0000]:
>
> > - gnu/packages/xdisorg.scm (libdrm): Update to 2.4.107, and change
> >
> > libpciaccess to a propagated input as the pkg-config for libdrm_intel now
> >
> > includes it in the libs.
> >
> > gnu/packages/xdisorg.scm | 6 +++---
> >
> > 1 file changed, 3 insertions(+), 3 deletions(-)
> >
> > diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
> >
> > index d0da2d28d1..1b38149654 100644
> >
> > --- a/gnu/packages/xdisorg.scm
> >
> > +++ b/gnu/packages/xdisorg.scm
> >
> > @@ -638,7 +638,7 @@ rasterisation.")
> >
> > (define-public libdrm
> >
> > (package
> >
> > (name "libdrm")
> >
> > - (version "2.4.104")
> >
> > - (version "2.4.107")
> >
> > (source (origin
> >
> > (method url-fetch)
> >
> > (uri (string-append
> >
> > @@ -646,7 +646,7 @@ rasterisation.")
> >
> > version ".tar.xz"))
> >
> > (sha256
> >
> > (base32
> >
> > - "1jqvx9c23hgwhq109zqj6vg3ng40pcvh3r1k2fn1a424qasxhsnn"))))
> >
> >
> >
> > - "127qf1rzhaf13vdd75a58v5q34617hvangjlfnlkcdh37gqcwm65"))))
> >
> >
> > (build-system meson-build-system)
> >
> > (arguments
> >
> > `(#:configure-flags
> >
> > @@ -663,7 +663,7 @@ rasterisation.")
> >
> > (replace 'check
> >
> > (lambda _
> >
> > (invoke "meson" "test" "--timeout-multiplier" "5"))))))
>
> If you are updating "libdrm" on core-updates anyway,
>
> can you also make the following change (as a separate patch)?:
>
> (replace 'check
>
> (lambda* (#:key tests? #:allow-other-keys)
>
> (when tests?
>
> (invoke "meson" "test" "--timeout-multiplier" 5))))
>
> That should allow "guix build SOMETHING --without-tests=libdrm" to work.

I'm not familiar with the "--without-tests=" flag and mechanism, but would be happy to add a patch for it. I've only recently started using Guix and this is my first patch submission (it's a precursor patch from my attempt to update mesa to 21.1.x); should I email that patch to 49412@debbugs.gnu.org to make it part of the same issue?

Cheers,
Kaelyn
J
J
John Kehayias wrote on 5 Jul 2021 23:58
[PATCH core-updates] gnu: libdrm: Update to 2.4.107
(name . 49412@debbugs.gnu.org)(address . 49412@debbugs.gnu.org)
QrTifMEQj7NNxMGVSB3sz29sZeuLqUUlFDNq_07vQeyKlKaoXmiohOs_YuwiIbjJ0HQOF7pDsuAlFRXj_8P2khZ480ECUdHw72Hqh5q5Pe4=@protonmail.com
With regards to updating Mesa, please see the issue below for work on that (looks like some packages will have be updated with the new Mesa, too):

M
M
Maxime Devos wrote on 6 Jul 2021 10:24
Re: [bug#49412] [PATCH core-updates] gnu: libdrm: Update to 2.4.107.
(name . Kaelyn)(address . kaelyn.alexi@protonmail.com)(address . 49412@debbugs.gnu.org)
b2412871363393e13715d0474c328cee078b189b.camel@telenet.be
Kaelyn schreef op ma 05-07-2021 om 15:58 [+0000]:
Toggle quote (6 lines)
> [...]
> I'm not familiar with the "--without-tests=" flag and mechanism, but would be happy
> to add a patch for it. I've only recently started using Guix and this is my first
> patch submission (it's a precursor patch from my attempt to update mesa to 21.1.x);
> should I email that patch to 49412@debbugs.gnu.org to make it part of the same issue?

If you mean the 'when tests?' patch, then I'd send it to 49412@debbugs.gnu.org
to keep the libdrm patches together (maybe as a v2 patch series). If you mean
‘updating mesa to 21.1.1x’, then I'd send that patch to guix-patches@gnu.org,
as updating 'mesa' seems much more complicated than only updating 'libdrm'
(see reply by John Kehayias).

There is some documentation in the chapter ‘16 Contributing’ in the manual
on the process (more specifically, the section ‘16.6 Submitting Patches’)
but it doesn't have much advice on when to split patch series ...

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYOQTTxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7mwTAQDqnVoM5NiPbfZtJEkErWrkw0AR
wi5764yHh6/iF+wEHgD/frW2Tff/VNIrzPlBIHiwhcpHSSO/xpVwdDai4GQ4VQQ=
=xfEP
-----END PGP SIGNATURE-----


J
J
John Kehayias wrote on 8 Jul 2021 05:02
Re: [PATCH core-updates] gnu: libdrm: Update to 2.4.107
(name . 49412@debbugs.gnu.org)(address . 49412@debbugs.gnu.org)
dujRiZjoTmEXJ6uYCwo4_yLZAKX43ZPgvrBFiQq6p_57_aWPLtKhk6OBkrN2cOkyogsFP1JeQ7a6dIbwKiNmnH4Paic4GF29WIldR6do0N4=@protonmail.com
Toggle quote (2 lines)
> If you mean the 'when tests?' patch, then I'd send it to 49412@debbugs.gnu.orgto keep the libdrm patches together (maybe as a v2 patch series). If you mean‘updating mesa to 21.1.1x’, then I'd send that patch to guix-patches@gnu.org,as updating 'mesa' seems much more complicated than only updating 'libdrm'(see reply by John Kehayias).

Just to follow up here, I think Mesa can be updated pretty simply too, as the original Mesa patch referenced also enabled libglvnd. I've followed up on both the original patch submission and on guix-devel (to gather feedback on moving things to libglvnd).
J
J
John Kehayias wrote on 8 Jul 2021 17:43
(name . 49412@debbugs.gnu.org)(address . 49412@debbugs.gnu.org)
vXLF11NLkkg8biti0vSz67HcPxXlsp2ilp3rJ0I6s1ao_vCiGEWa8sKdQOC4TabSdKqGxbhRRXdHz3KlKHm4-qcQhUBI5FjD8chKB7YHPnE=@protonmail.com
I've updated the Mesa patch over at https://issues.guix.gnu.org/49339to just do a minimal version bump and not touch libdrm, relying on this patch for that. So it would be great to get this libdrm update merged so we can move ahead with Mesa to 21.1.4.
K
K
Kaelyn Takata wrote on 13 Jul 2021 18:57
[PATCH v2] gnu: libdrm: Update to 2.4.107.
(address . 49412@debbugs.gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
YkoFaylFgRSVEzABW06lFTt0JxyggZcWtn0eailc8@cp4-web-034.plabs.ch
* gnu/packages/xdisorg.scm (libdrm): Update to 2.4.107, and change
libpciaccess to a propagated input as the pkg-config for libdrm_intel now
includes it in the libs.
* gnu/packages/xdisorg.scm (libdrm): Add conditional testing support to the
replacement for the standard check phase.
---
gnu/packages/xdisorg.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index d0da2d28d1..dd30dbf844 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -638,7 +638,7 @@ rasterisation.")
(define-public libdrm
(package
(name "libdrm")
- (version "2.4.104")
+ (version "2.4.107")
(source (origin
(method url-fetch)
(uri (string-append
@@ -646,7 +646,7 @@ rasterisation.")
version ".tar.xz"))
(sha256
(base32
- "1jqvx9c23hgwhq109zqj6vg3ng40pcvh3r1k2fn1a424qasxhsnn"))))
+ "127qf1rzhaf13vdd75a58v5q34617hvangjlfnlkcdh37gqcwm65"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
@@ -661,9 +661,10 @@ rasterisation.")
#:phases (modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "meson" "test" "--timeout-multiplier" "5"))))))
- (inputs
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "meson" "test" "--timeout-multiplier" "5")))))))
+ (propagated-inputs
`(("libpciaccess" ,libpciaccess)))
(native-inputs
`(("pkg-config" ,pkg-config)))
--
2.32.0
T
T
Thiago Jung Bauermann wrote on 26 Jul 2021 16:19
(address . 49412@debbugs.gnu.org)
2276433.h4ixaZ63HY@popigai
Hello,

Em terça-feira, 13 de julho de 2021, às 13:57:48 -03, Kaelyn Takata via
Guix-patches via escreveu:
Toggle quote (9 lines)
> * gnu/packages/xdisorg.scm (libdrm): Update to 2.4.107, and change
> libpciaccess to a propagated input as the pkg-config for libdrm_intel now
> includes it in the libs.
> * gnu/packages/xdisorg.scm (libdrm): Add conditional testing support to
> the replacement for the standard check phase.
> ---
> gnu/packages/xdisorg.scm | 11 ++++++-----
> 1 file changed, 6 insertions(+), 5 deletions(-)

Thank you for this patch. FWIW, I applied it and built libdrm successfully
on x86_64-linux. I also verified that the SHA256 sum matches the one from
the official release announcement¹, and that:

$ ./pre-inst-env guix build --without-tests=libdrm plymouth

skips the libdrm tests.

I wasn’t able to find the OpenPGP key that signed the release tarball, so I
couldn’t check its signature.

--
Thanks,
Thiago

L
L
Ludovic Courtès wrote on 31 Jul 2021 12:03
Re: bug#49412: [PATCH core-updates] gnu: libdrm: Update to 2.4.107.
(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)(address . 49412-done@debbugs.gnu.org)
87fsvuyf3s.fsf_-_@gnu.org
Hi,

Kaelyn Takata <kaelyn.alexi@protonmail.com> skribis:

Toggle quote (6 lines)
> * gnu/packages/xdisorg.scm (libdrm): Update to 2.4.107, and change
> libpciaccess to a propagated input as the pkg-config for libdrm_intel now
> includes it in the libs.
> * gnu/packages/xdisorg.scm (libdrm): Add conditional testing support to the
> replacement for the standard check phase.

I tweaked the commit log and applied it.

Thank you, and thanks Maxime and Thiego for reviewing!

Ludo’.
Closed
?