(address . guix-patches@gnu.org)
* gnu/packages/patches/X: Adjust.
* gnu/packages/gl.scm (mesa): Update to 20.3.4.
[arguments]<#:configure-flags>: Remove deprecated platforms.
---
gnu/packages/gl.scm | 6 +++---
gnu/packages/patches/mesa-skip-tests.patch | 10 +++++-----
2 files changed, 8 insertions(+), 8 deletions(-)
Toggle diff (68 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index e378474147..7eb47db4fc 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -235,7 +235,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "20.2.4")
+ (version "20.3.4")
(source
(origin
(method url-fetch)
@@ -247,7 +247,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "14m09bk7akj0k02lg8fhvvzbdsashlbdsgl2cw7wbqfj2mhdqwh5"))
+ "1120kf280hg4h0a2505vxf6rdw8r2ydl3cg4iwkmpx0zxj3sj8fw"))
(patches
(search-patches "mesa-skip-tests.patch"))))
(build-system meson-build-system)
@@ -301,7 +301,7 @@ also known as DXTn or DXTC) for Mesa.")
'("-Dgallium-drivers=iris,nouveau,r300,r600,radeonsi,svga,swrast,virgl")))
;; Enable various optional features. TODO: opencl requires libclc,
;; omx requires libomxil-bellagio
- "-Dplatforms=x11,drm,surfaceless,wayland"
+ "-Dplatforms=x11,wayland"
"-Dglx=dri" ;Thread Local Storage, improves performance
;; "-Dopencl=true"
;; "-Domx=true"
diff --git a/gnu/packages/patches/mesa-skip-tests.patch b/gnu/packages/patches/mesa-skip-tests.patch
index 2622d5d312..9c0c531189 100644
--- a/gnu/packages/patches/mesa-skip-tests.patch
+++ b/gnu/packages/patches/mesa-skip-tests.patch
@@ -5,7 +5,7 @@ for now.
--- a/src/compiler/glsl/tests/cache_test.c
+++ b/src/compiler/glsl/tests/cache_test.c
-@@ -170,11 +170,6 @@
+@@ -212,11 +212,6 @@ test_disk_cache_create(void)
unsetenv("MESA_GLSL_CACHE_DIR");
unsetenv("XDG_CACHE_HOME");
@@ -14,9 +14,9 @@ for now.
-
- disk_cache_destroy(cache);
-
- /* Test with XDG_CACHE_HOME set */
- setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1);
- cache = disk_cache_create("test", "make_check", 0);
+ #ifdef ANDROID
+ /* Android doesn't try writing to disk (just calls the cache callbacks), so
+ * the directory tests below don't apply.
This test fails on i686-linux. I couldn't come up with a regex that
could be used to disable it just on i686-linux, so we disable it
@@ -28,7 +28,7 @@ diff --git a/src/util/meson.build b/src/util/meson.build
index 0893f64..909b3e0 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
-@@ -289,18 +289,6 @@ if with_tests
+@@ -320,18 +320,6 @@ if with_tests
suite : ['util'],
)
--
2.30.1