[PATCH 39/41] gnu: Add go-github-com-onsi-ginkgo.

(
(address . guix-patches@gnu.org)(name . ()(address . paren@disroot.org)
20220803120439.5108-39-paren@disroot.org
* gnu/packages/golang.scm (go-github-com-onsi-ginkgo): New variable.
---
gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 10fec324b0..0dc43a48fb 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10929,3 +10929,31 @@ (define-public go-github-com-go-task-slim-sprig
Slim-Sprig is a fork of Sprig that removes all external dependencies to make the
library more lightweight.")
(license license:expat))))
+
+(define-public go-github-com-onsi-ginkgo
+ (package
+ (name "go-github-com-onsi-ginkgo")
+ (version "1.16.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/onsi/ginkgo")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hh6n7q92y0ai8k6rj2yzw6wwxikhyiyk4j92zgvf1zad0gmqqmz"))))
+ (build-system go-build-system)
+ (arguments (list #:import-path "github.com/onsi/ginkgo"))
+ (propagated-inputs (list go-golang-org-x-sys
+ go-golang-org-x-tools
+ go-github-com-go-task-slim-sprig
+ go-github-com-nxadm-tail
+ go-github-com-onsi-gomega))
+ (home-page "https://github.com/onsi/ginkgo")
+ (synopsis "BDD-style testing framework for Go")
+ (description
+ "Ginkgo is a Behaviour-Driven Development testing framework for Go. It
+builds on top of Go's builtin @code{testing} library and is complemented by the
+Gomega matcher library.")
+ (license license:expat)))
--
2.37.1
(
(address . control@debbugs.gnu.org)
CLWDYGGQDWDZ.EQ4EERCSNS2U@guix-aspire
merge 55903 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWE95B9PDVA.ZLM2DBCU1L9V@guix-aspire
close 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWEDCUIBCHE.GM9WA0YNQXVR@guix-aspire
unmerge 55903
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWEDQR118FS.2LE0145ASDQR9@guix-aspire
close 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
?