[PATCH 38/41] gnu: Add go-github-com-go-task-slim-sprig.

(
(address . guix-patches@gnu.org)(name . ()(address . paren@disroot.org)
20220803120439.5108-38-paren@disroot.org
* gnu/packages/golang.scm (go-github-com-go-task-slim-sprig): New
variable.
---
gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a7a0ce6391..10fec324b0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10901,3 +10901,31 @@ (define-public go-github-com-nxadm-tail
"@code{tail} provides a Go library for reading from continuously updating
files, like the @command{tail -f} command does.")
(license license:expat)))
+
+(define-public go-github-com-go-task-slim-sprig
+ (let ((commit "afa1e2071829e4db655eb448d6c7c16eb0bc5766")
+ (revision "0"))
+ (package
+ (name "go-github-com-go-task-slim-sprig")
+ (version (git-version "2.20.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-task/slim-sprig")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1185y8qygv8gb3wpghx5d945wq68j4dbaiffq3h0dh453g4h1w7a"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/go-task/slim-sprig"
+ ;; Tests try to access the network.
+ #:tests? #f))
+ (home-page "https://github.com/go-task/slim-sprig")
+ (synopsis "Various useful template functions for Go")
+ (description
+ "Sprig provides over 100 functions that extend the Go template system.
+Slim-Sprig is a fork of Sprig that removes all external dependencies to make the
+library more lightweight.")
+ (license license:expat))))
--
2.37.1
(
(address . control@debbugs.gnu.org)
CLWDYGGQDWDZ.EQ4EERCSNS2U@guix-aspire
merge 55903 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWE95B9PDVA.ZLM2DBCU1L9V@guix-aspire
close 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWEDCUIBCHE.GM9WA0YNQXVR@guix-aspire
unmerge 55903
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWEDQR118FS.2LE0145ASDQR9@guix-aspire
close 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
?