[PATCH 10/41] gnu: Add go-github-com-rivo-uniseg.

(
(address . guix-patches@gnu.org)(name . (unmatched-parenthesis)(address . paren@disroot.org)
20220803120439.5108-10-paren@disroot.org
From: "(unmatched-parenthesis" <paren@disroot.org>

* gnu/packages/golang.scm (go-github-com-rivo-uniseg): New variable.
---
gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 532f0bdf0d..bedd04faef 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10160,3 +10160,28 @@ (define-public go-github-com-lucasb-eyer-go-colorful
colorful stores colors in RGB and provides methods for converting these to
various color spaces.")
(license license:expat)))
+
+(define-public go-github-com-rivo-uniseg
+ (package
+ (name "go-github-com-rivo-uniseg")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rivo/uniseg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0j7h22vfmjj562vr8gpsyrkrwp1pq9ayh5fylv24skxb467g9f0q"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/rivo/uniseg"))
+ (home-page "https://github.com/rivo/uniseg")
+ (synopsis "Unicode text segmentation for Go")
+ (description
+ "The uniseg package provides a tool to iterate over grapheme clusters.
+This may be used to determine the number of user-perceived characters, to
+split strings in their intended places, or to extract individual characters
+which form a unit.")
+ (license license:expat)))
--
2.37.1
(
(address . control@debbugs.gnu.org)
CLWDYGGQDWDZ.EQ4EERCSNS2U@guix-aspire
merge 55903 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWE95B9PDVA.ZLM2DBCU1L9V@guix-aspire
close 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWEDCUIBCHE.GM9WA0YNQXVR@guix-aspire
unmerge 55903
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWEDQR118FS.2LE0145ASDQR9@guix-aspire
close 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
?