[PATCH 07/41] gnu: Add go-github-com-kyoh86-xdg.

(
(address . guix-patches@gnu.org)(name . (unmatched-parenthesis)(address . paren@disroot.org)
20220803120439.5108-7-paren@disroot.org
From: "(unmatched-parenthesis" <paren@disroot.org>

* gnu/packages/golang.scm (go-github-com-kyoh86-xdg): New variable.
---
gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 35670f6557..744095c2c0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10090,3 +10090,27 @@ (define-public go-github-com-miolini-datacounter
(description
"The datacounter package provides counters for Go readers and writers.")
(license license:expat)))
+
+(define-public go-github-com-kyoh86-xdg
+ (package
+ (name "go-github-com-kyoh86-xdg")
+ (version "1.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kyoh86/xdg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0a5nz53fdz1c2qvwlf2dpjdd72nxri95i6q4b07c37kiipgaxncn"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/kyoh86/xdg"))
+ (home-page "https://github.com/kyoh86/xdg")
+ (synopsis "XDG base directories for Go")
+ (description
+ "The xdg package provides lightweight helper functions in Go to get
+config, data and cache directories according to the XDG Base Directory
+Specification.")
+ (license license:expat)))
--
2.37.1
(
(address . control@debbugs.gnu.org)
CLWDYGGQDWDZ.EQ4EERCSNS2U@guix-aspire
merge 55903 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWE95B9PDVA.ZLM2DBCU1L9V@guix-aspire
close 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWEDCUIBCHE.GM9WA0YNQXVR@guix-aspire
unmerge 55903
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWEDQR118FS.2LE0145ASDQR9@guix-aspire
close 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
?