[PATCH 05/41] gnu: Add go-github-com-riywo-loginshell.

(
(address . guix-patches@gnu.org)(name . (unmatched-parenthesis)(address . paren@disroot.org)
20220803120439.5108-5-paren@disroot.org
From: "(unmatched-parenthesis" <paren@disroot.org>

* gnu/packages/golang.scm (go-github-com-riywo-loginshell): New
variable.
---
gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2790bbfdd0..a16efbbc76 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10042,3 +10042,29 @@ (define-public go-github-com-xo-terminfo
(description
"The terminfo package implements terminfo database reading for Go.")
(license license:expat)))
+
+(define-public go-github-com-riywo-loginshell
+ (package
+ (name "go-github-com-riywo-loginshell")
+ (version "0.0.0-20200815045211-7d26008be1ab")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/riywo/loginshell")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "138yvis6lipw9x02jyiz7472bxi20206bcfikcar54i3xsww9q4i"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/riywo/loginshell"
+ ;; Tests try to get the current user's login shell; the build
+ ;; user doesn't have one.
+ #:tests? #f))
+ (home-page "https://github.com/riywo/loginshell")
+ (synopsis "Get the user's login shell in Go")
+ (description
+ "The loginshell package provides a Go library to get the login shell
+of the current user.")
+ (license license:expat)))
--
2.37.1
(
(address . control@debbugs.gnu.org)
CLWDYGGQDWDZ.EQ4EERCSNS2U@guix-aspire
merge 55903 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWE95B9PDVA.ZLM2DBCU1L9V@guix-aspire
close 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWEDCUIBCHE.GM9WA0YNQXVR@guix-aspire
unmerge 55903
thanks

-- (
(
(address . control@debbugs.gnu.org)
CLWEDQR118FS.2LE0145ASDQR9@guix-aspire
close 56909 56914 56910 56911 56912 56913 56915 56916 56917 56918 56919 56920 56921 56922 56923 56924 56925 56926 56927 56928 56934 56930 56929 56931 56933 56936 56935 56932 56941 56938 56939 56937 56942 56940 56943 56944 56945 56946 56947 56948 56949
thanks

-- (
?