[PATCH 5/8] gnu: python-aiofiles: Update to 23.1.0.

  • Open
  • quality assurance status badge
Details
4 participants
  • Ludovic Courtès
  • Christopher Baines
  • Tobias Geerinckx-Rice
  • peter
Owner
unassigned
Submitted by
peter
Severity
normal
Merged with
P
(address . guix-patches@gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
767b3a3102e392bdc5fe655aa22abcda08650759.1688155097.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-aiofiles): Update to 23.1.0.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 411cfe4045..0c5447a500 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29387,14 +29387,14 @@ (define-public python-contextvars
(define-public python-aiofiles
(package
(name "python-aiofiles")
- (version "0.6.0")
+ (version "23.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "aiofiles" version))
(sha256
(base32
- "14m01kjxm2j7zyljjj6xlhlgygcsriymbx730gc5jp9xglaina70"))))
+ "0d8n79slihf1lkbh2m6yw51rlq6n6vssljsdacbdpq0rkbglglpd"))))
(build-system python-build-system)
(home-page "https://github.com/Tinche/aiofiles")
(synopsis "File support for @code{asyncio}")
--
2.40.1
T
T
Tobias Geerinckx-Rice wrote on 1 Jul 2023 23:20
(no subject)
(name . GNU Debbugs)(address . control@debbugs.gnu.org)
87mt0fz5qa.fsf@nckx
merge 64375 64379 64382 64378 64383 64384 64380 64377 64381 64376
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCZKCZPg0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15wCUA/0Jvn38UokZk+c5VYKDawSOPjoErSSo4grXWwd7v
WBtwAP9NGjCoy9CQ1MxoBoSmttspnRmVI5qqNyaiuBT/W1yeBg==
=sPza
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 2 Oct 2023 17:08
Re: bug#64384: [PATCH 5/8] gnu: python-aiofiles: Update to 23.1.0.
(address . peter@polidoro.io)
8734ythxjq.fsf_-_@gnu.org
Hi Peter,

Overall the patch series LGTM, with one nitpick:

peter@polidoro.io skribis:


[...]

Toggle quote (4 lines)
> + (build-system pyproject-build-system)
> + (arguments
> + `(#:tests? #f)) ; FIXME: PermissionError: [Errno 13] Permission denied: '/homeless-shelter'

Consider adding a phase that does (setenv "HOME" (getcwd)) or similar to
address this issue so you can run the test. Shipping an untested
package is something we try to avoid.

Toggle quote (10 lines)
> + (home-page "https://platformio.org")
> + (synopsis
> + "Your Gateway to Embedded Software Development Excellence. Unlock the true potential of embedded software development with PlatformIO's collaborative ecosystem, embracing declarative principles, test-driven methodologies, and modern toolchains for unrivaled success.")
> + (description
> + "Your Gateway to Embedded Software Development Excellence. Unlock the true
> +potential of embedded software development with @code{PlatformIO's}
> +collaborative ecosystem, embracing declarative principles, test-driven
> +methodologies, and modern toolchains for unrivaled success.")
> + (license license:asl2.0)))

Please replace the marketing language with an actual synopsis and a
description, following the guidelines at:


‘guix lint’ may also diagnose obvious issues.

Toggle quote (28 lines)
> - (commit version)))
> + (url "https://github.com/john30/ebusd")
> + (commit version)))
> (file-name (string-append name "-" version "-checkout"))
> (sha256
> (base32
> @@ -1491,14 +1529,14 @@ (define-public ebusd
> ("autoconf" ,autoconf)
> ("config"
> ,(origin
> - (method git-fetch)
> - (uri (git-reference
> - (url "https://github.com/john30/ebusd-configuration")
> - (commit "666c0f6b9c4d7545eff7f43ab28a1c7baeab7913")))
> - (file-name "config-checkout")
> - (sha256
> - (base32
> - "0yxnx8p4lbk614l16854r9s9d8s9c7ixgczfs8mph94xz0wkda7x"))))))
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/john30/ebusd-configuration")
> + (commit "666c0f6b9c4d7545eff7f43ab28a1c7baeab7913")))
> + (file-name "config-checkout")
> + (sha256
> + (base32
> + "0yxnx8p4lbk614l16854r9s9d8s9c7ixgczfs8mph94xz0wkda7x"))))))

Looks like these were unintended changes.

Could you please send an updated patch series?

Thanks,
Ludo’.
P
P
Peter Polidoro wrote on 4 Oct 2023 15:57
(name . Ludovic Courtès)(address . ludo@gnu.org)
87wmw2sczv.fsf@polidoro.io
Thank you.

I am attempting to update the patch series, but now multiple
dependencies are failing to build due to version incompatibilities
or failing tests.

I will try again when I have more time to track down all of these
issues.


Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (88 lines)
> Hi Peter,
>
> Overall the patch series LGTM, with one nitpick:
>
> peter@polidoro.io skribis:
>
>
> [...]
>
>> + (build-system pyproject-build-system)
>> + (arguments
>> + `(#:tests? #f)) ; FIXME: PermissionError: [Errno 13]
>> Permission denied: '/homeless-shelter'
>
> Consider adding a phase that does (setenv "HOME" (getcwd)) or
> similar to
> address this issue so you can run the test. Shipping an
> untested
> package is something we try to avoid.
>
>> + (home-page "https://platformio.org")
>> + (synopsis
>> + "Your Gateway to Embedded Software Development Excellence.
>> Unlock the true
>> potential of embedded software development with PlatformIO's
>> collaborative
>> ecosystem, embracing declarative principles, test-driven
>> methodologies, and
>> modern toolchains for unrivaled success.")
>> + (description
>> + "Your Gateway to Embedded Software Development
>> Excellence. Unlock the true
>> +potential of embedded software development with
>> @code{PlatformIO's}
>> +collaborative ecosystem, embracing declarative principles,
>> test-driven
>> +methodologies, and modern toolchains for unrivaled success.")
>> + (license license:asl2.0)))
>
> Please replace the marketing language with an actual synopsis
> and a
> description, following the guidelines at:
>
> https://guix.gnu.org/manual/devel/en/html_node/Synopses-and-Descriptions.html
>
> ‘guix lint’ may also diagnose obvious issues.
>
>> - (url "https://github.com/john30/ebusd")
>> - (commit version)))
>> + (url "https://github.com/john30/ebusd")
>> + (commit version)))
>> (file-name (string-append name "-" version
>> "-checkout"))
>> (sha256
>> (base32
>> @@ -1491,14 +1529,14 @@ (define-public ebusd
>> ("autoconf" ,autoconf)
>> ("config"
>> ,(origin
>> - (method git-fetch)
>> - (uri (git-reference
>> - (url
>> "https://github.com/john30/ebusd-configuration")
>> - (commit
>> "666c0f6b9c4d7545eff7f43ab28a1c7baeab7913")))
>> - (file-name "config-checkout")
>> - (sha256
>> - (base32
>> -
>> "0yxnx8p4lbk614l16854r9s9d8s9c7ixgczfs8mph94xz0wkda7x"))))))
>> + (method git-fetch)
>> + (uri (git-reference
>> + (url
>> "https://github.com/john30/ebusd-configuration")
>> + (commit
>> "666c0f6b9c4d7545eff7f43ab28a1c7baeab7913")))
>> + (file-name "config-checkout")
>> + (sha256
>> + (base32
>> +
>> "0yxnx8p4lbk614l16854r9s9d8s9c7ixgczfs8mph94xz0wkda7x"))))))
>
> Looks like these were unintended changes.
>
> Could you please send an updated patch series?
>
> Thanks,
> Ludo’.
C
C
Christopher Baines wrote on 17 Oct 2023 11:17
tag 64375 moreinfo
(address . control@debbugs.gnu.org)
87lec1fw02.fsf@cbaines.net
tags 64375 + moreinfo
quit
?