(address . guix-patches@gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
From: Peter Polidoro <peter@polidoro.io>
* gnu/packages/python-xyz.scm (python-platformio): New variable.
---
gnu/packages/python-xyz.scm | 41 +++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)
Toggle diff (54 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7f26e7ac94..9406726d0e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11607,6 +11607,47 @@ (define-public python-plac
function signatures.")
(license license:bsd-3)))
+(define-public python-platformio
+ (package
+ (name "python-platformio")
+ (version "6.1.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "platformio" version))
+ (sha256
+ (base32
+ "1kpzj1hflw6clj3rbksb2js4zn0rafnz3wxyh0757g1nz57vjwly"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:tests? #f)) ; FIXME: PermissionError: [Errno 13] Permission denied: '/homeless-shelter'
+ (propagated-inputs (list python-aiofiles
+ python-ajsonrpc
+ python-bottle
+ python-click
+ python-colorama
+ python-marshmallow
+ python-pyelftools
+ python-pyserial
+ python-requests
+ python-semantic-version
+ python-starlette
+ python-tabulate
+ python-urllib3
+ python-uvicorn
+ python-wsproto))
+ (home-page "https://platformio.org")
+ (synopsis
+ "A professional collaborative platform for embedded development. Cross-platform IDE and Unified Debugger. Static Code Analyzer and Remote Unit Testing. Multi-platform and Multi-architecture Build System. Firmware File Explorer and Memory Inspection. IoT, Arduino, CMSIS, ESP-IDF, FreeRTOS, libOpenCM3, mbedOS, Pulp OS, SPL, STM32Cube, Zephyr RTOS, ARM, AVR, Espressif (ESP8266/ESP32), FPGA, MCS-51 (8051), MSP430, Nordic (nRF51/nRF52), NXP i.MX RT, PIC32, RISC-V, STMicroelectronics (STM8/STM32), Teensy")
+ (description
+ "This package provides a professional collaborative platform for embedded
+development. Cross-platform IDE and Unified Debugger. Static Code Analyzer and
+Remote Unit Testing. Multi-platform and Multi-architecture Build System.
+Firmware File Explorer and Memory Inspection. IoT, Arduino, CMSIS, ESP-IDF,
+FreeRTOS, libOpenCM3, mbedOS, Pulp OS, SPL, STM32Cube, Zephyr RTOS, ARM, AVR,
+Espressif (ESP8266/ESP32), FPGA, MCS-51 (8051), MSP430, Nordic (nRF51/nRF52),
+NXP i.MX RT, PIC32, RISC-V, STMicroelectronics (STM8/STM32), Teensy")
+ (license license:asl2.0)))
+
(define-public python-yte
(package
(name "python-yte")
--
2.40.1