[PATCH 0/8] Add python-platformio plus dependency updates.

  • Open
  • quality assurance status badge
Details
4 participants
  • Ludovic Courtès
  • Christopher Baines
  • Tobias Geerinckx-Rice
  • peter
Owner
unassigned
Submitted by
peter
Severity
normal
Merged with
P
(address . guix-patches@gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
cover.1688155097.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

Adding python-platformio along with dependency updates necessary to get the package to build. I was unable to get all the tests run properly, but all packages appear to build correctly. Further testing might be necessary to make sure packages have indeed built properly and no other packages were affected by the version changes.

Peter Polidoro (8):
gnu: python-pyelftools: Update to 0.29.
gnu: python-sanic: Update to 21.12.2.
gnu: python-uvicorn: Update to 0.22.0.
gnu: python-starlette: Update to 0.26.0.
gnu: python-aiofiles: Update to 23.1.0.
gnu: python-tabulate: Update to 0.9.0.
gnu: python-semantic-version: Update to 2.10.0.
gnu: Add python-platformio.

gnu/packages/python-web.scm | 54 ++++++++-----------------
gnu/packages/python-xyz.scm | 81 ++++++++++++++++++++++++++++---------
2 files changed, 80 insertions(+), 55 deletions(-)

--
2.40.1
T
T
Tobias Geerinckx-Rice wrote on 1 Jul 2023 23:20
(no subject)
(name . GNU Debbugs)(address . control@debbugs.gnu.org)
87mt0fz5qa.fsf@nckx
merge 64375 64379 64382 64378 64383 64384 64380 64377 64381 64376
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCZKCZPg0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15wCUA/0Jvn38UokZk+c5VYKDawSOPjoErSSo4grXWwd7v
WBtwAP9NGjCoy9CQ1MxoBoSmttspnRmVI5qqNyaiuBT/W1yeBg==
=sPza
-----END PGP SIGNATURE-----

P
[PATCH 2/4] gnu: python-sanic: Update to 21.12.2.
(address . 64375@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
debb8e82d871a57b41775aa77aa664360f0471f9.1693317569.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-web.scm (python-sanic): Update to 21.12.2.
---
gnu/packages/python-web.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4c38636af5..5e3f3a0ed2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7017,14 +7017,14 @@ (define-public python-sanic
(package
(name "python-sanic")
;; We provide the latest LTS version of python-sanic.
- (version "21.12.1")
+ (version "21.12.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "sanic" version))
(sha256
(base32
- "0b8mcd1q9qkwcv2qz8nlyaacs0bp7a1l31sdq2m8hhkxykzfq5bg"))))
+ "1qz5dq19dc1aagwapq2cxpgy40kyw6dk488jdl68d139midf29n4"))))
(build-system python-build-system)
(arguments
(list
@@ -7048,7 +7048,8 @@ (define-public python-sanic
;; Unclear why they fail since core-updates merge.
" and not test_missing_sni"
" and not test_no_matching_cert"
- " and not test_wildcards"))))))))
+ " and not test_wildcards"
+ " and not test_json_encoding"))))))))
(propagated-inputs
(list python-aiofiles
python-httptools
--
2.41.0
P
[PATCH 3/4] gnu: python-quart: Update to 0.18.4.
(address . 64375@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
3d1fdabd8d993f187d632b66c103ee3d802a3231.1693317569.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-web.scm (python-quart): Update to 0.18.4.
---
gnu/packages/python-web.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5e3f3a0ed2..ac2f2be3d8 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7976,7 +7976,7 @@ (define-public python-tweepy
(define-public python-quart
(package
(name "python-quart")
- (version "0.17.0")
+ (version "0.18.4")
(source
(origin
(method url-fetch)
@@ -7992,9 +7992,9 @@ (define-public python-quart
python-itsdangerous
python-jinja2
python-markupsafe
- python-toml
+ python-tomli
python-werkzeug))
- (home-page "https://gitlab.com/pgjones/quart/")
+ (home-page "https://github.com/pallets/quart")
(synopsis "Python ASGI web microframework with the same API as Flask")
(description
"This package provides a Python ASGI web microframework with the same API
--
2.41.0
P
[PATCH 1/4] gnu: python-semantic-version: Update to 2.10.0.
(address . 64375@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
0937f3c37f3a629b11391a791e7a220c42ab215c.1693317568.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-semantic-version): Update to 2.10.0.
---
gnu/packages/python-xyz.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 385426671e..caf2c3203b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2549,15 +2549,21 @@ (define-public python-filelock-3.5
(define-public python-semantic-version
(package
(name "python-semantic-version")
- (version "2.8.5")
+ (version "2.10.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "semantic_version" version))
(sha256
(base32
- "0m4avx8zdkzc7qglv5zlr54g8yna5vl098drg5396ql7aph2vjyj"))))
+ "0704smz9k6hdd6i5xh0xf0sk47kannjb77abilvvp34r6v9vdaxx"))))
(build-system python-build-system)
+ (native-inputs (list python-pytest
+ python-setuptools-scm
+ python-django))
+ ;; FIXME: "django.core.exceptions.ImproperlyConfigured: Requested settings, but settings are not configured."
+ (arguments
+ `(#:tests? #f))
(home-page "https://github.com/rbarrois/python-semanticversion")
(synopsis "Semantic versioning module for Python")
(description
--
2.41.0
P
[PATCH 4/4] gnu: Add platformio.
(address . 64375@debbugs.gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
b3551fe1b17622516e115dbe404ab37803c3e877.1693317569.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/embedded.scm (platformio): New variable.
---
gnu/packages/embedded.scm | 58 ++++++++++++++++++++++++++++++++-------
1 file changed, 48 insertions(+), 10 deletions(-)

Toggle diff (99 lines)
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 325013a627..e547e6cbe6 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2023 Peter Polidoro <peter@polidoro.io>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,6 +41,7 @@ (define-module (gnu packages embedded)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system trivial)
#:use-module ((guix build utils) #:select (alist-replace delete-file-recursively))
#:use-module (gnu packages)
@@ -1457,6 +1459,42 @@ (define-public west
debugging them, and more.")
(license license:expat)))
+(define-public platformio
+ (package
+ (name "platformio")
+ (version "6.1.10")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "platformio" version))
+ (sha256
+ (base32
+ "0n7yz19ckyq1x3q7lm3cvj2xsmzx3kvnxkwqzkq9hfkj1yzxash4"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:tests? #f)) ; FIXME: PermissionError: [Errno 13] Permission denied: '/homeless-shelter'
+ (propagated-inputs (list python-ajsonrpc
+ python-bottle
+ python-click
+ python-colorama
+ python-marshmallow
+ python-pyelftools
+ python-pyserial
+ python-requests
+ python-semantic-version
+ python-starlette
+ python-tabulate
+ python-uvicorn
+ python-wsproto))
+ (home-page "https://platformio.org")
+ (synopsis
+ "Your Gateway to Embedded Software Development Excellence. Unlock the true potential of embedded software development with PlatformIO's collaborative ecosystem, embracing declarative principles, test-driven methodologies, and modern toolchains for unrivaled success.")
+ (description
+ "Your Gateway to Embedded Software Development Excellence. Unlock the true
+potential of embedded software development with @code{PlatformIO's}
+collaborative ecosystem, embracing declarative principles, test-driven
+methodologies, and modern toolchains for unrivaled success.")
+ (license license:asl2.0)))
+
(define-public ebusd
(package
(name "ebusd")
@@ -1464,8 +1502,8 @@ (define-public ebusd
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/john30/ebusd")
- (commit version)))
+ (url "https://github.com/john30/ebusd")
+ (commit version)))
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
@@ -1491,14 +1529,14 @@ (define-public ebusd
("autoconf" ,autoconf)
("config"
,(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/john30/ebusd-configuration")
- (commit "666c0f6b9c4d7545eff7f43ab28a1c7baeab7913")))
- (file-name "config-checkout")
- (sha256
- (base32
- "0yxnx8p4lbk614l16854r9s9d8s9c7ixgczfs8mph94xz0wkda7x"))))))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/john30/ebusd-configuration")
+ (commit "666c0f6b9c4d7545eff7f43ab28a1c7baeab7913")))
+ (file-name "config-checkout")
+ (sha256
+ (base32
+ "0yxnx8p4lbk614l16854r9s9d8s9c7ixgczfs8mph94xz0wkda7x"))))))
(synopsis "Daemon for communicating with eBUS devices")
(description "This package provides @command{ebusd}, a daemon for
handling communication with eBUS devices connected to a 2-wire bus system
--
2.41.0
L
L
Ludovic Courtès wrote on 2 Oct 2023 17:08
Re: bug#64384: [PATCH 5/8] gnu: python-aiofiles: Update to 23.1.0.
(address . peter@polidoro.io)
8734ythxjq.fsf_-_@gnu.org
Hi Peter,

Overall the patch series LGTM, with one nitpick:

peter@polidoro.io skribis:


[...]

Toggle quote (4 lines)
> + (build-system pyproject-build-system)
> + (arguments
> + `(#:tests? #f)) ; FIXME: PermissionError: [Errno 13] Permission denied: '/homeless-shelter'

Consider adding a phase that does (setenv "HOME" (getcwd)) or similar to
address this issue so you can run the test. Shipping an untested
package is something we try to avoid.

Toggle quote (10 lines)
> + (home-page "https://platformio.org")
> + (synopsis
> + "Your Gateway to Embedded Software Development Excellence. Unlock the true potential of embedded software development with PlatformIO's collaborative ecosystem, embracing declarative principles, test-driven methodologies, and modern toolchains for unrivaled success.")
> + (description
> + "Your Gateway to Embedded Software Development Excellence. Unlock the true
> +potential of embedded software development with @code{PlatformIO's}
> +collaborative ecosystem, embracing declarative principles, test-driven
> +methodologies, and modern toolchains for unrivaled success.")
> + (license license:asl2.0)))

Please replace the marketing language with an actual synopsis and a
description, following the guidelines at:


‘guix lint’ may also diagnose obvious issues.

Toggle quote (28 lines)
> - (commit version)))
> + (url "https://github.com/john30/ebusd")
> + (commit version)))
> (file-name (string-append name "-" version "-checkout"))
> (sha256
> (base32
> @@ -1491,14 +1529,14 @@ (define-public ebusd
> ("autoconf" ,autoconf)
> ("config"
> ,(origin
> - (method git-fetch)
> - (uri (git-reference
> - (url "https://github.com/john30/ebusd-configuration")
> - (commit "666c0f6b9c4d7545eff7f43ab28a1c7baeab7913")))
> - (file-name "config-checkout")
> - (sha256
> - (base32
> - "0yxnx8p4lbk614l16854r9s9d8s9c7ixgczfs8mph94xz0wkda7x"))))))
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/john30/ebusd-configuration")
> + (commit "666c0f6b9c4d7545eff7f43ab28a1c7baeab7913")))
> + (file-name "config-checkout")
> + (sha256
> + (base32
> + "0yxnx8p4lbk614l16854r9s9d8s9c7ixgczfs8mph94xz0wkda7x"))))))

Looks like these were unintended changes.

Could you please send an updated patch series?

Thanks,
Ludo’.
P
P
Peter Polidoro wrote on 4 Oct 2023 15:57
(name . Ludovic Courtès)(address . ludo@gnu.org)
87wmw2sczv.fsf@polidoro.io
Thank you.

I am attempting to update the patch series, but now multiple
dependencies are failing to build due to version incompatibilities
or failing tests.

I will try again when I have more time to track down all of these
issues.


Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (88 lines)
> Hi Peter,
>
> Overall the patch series LGTM, with one nitpick:
>
> peter@polidoro.io skribis:
>
>
> [...]
>
>> + (build-system pyproject-build-system)
>> + (arguments
>> + `(#:tests? #f)) ; FIXME: PermissionError: [Errno 13]
>> Permission denied: '/homeless-shelter'
>
> Consider adding a phase that does (setenv "HOME" (getcwd)) or
> similar to
> address this issue so you can run the test. Shipping an
> untested
> package is something we try to avoid.
>
>> + (home-page "https://platformio.org")
>> + (synopsis
>> + "Your Gateway to Embedded Software Development Excellence.
>> Unlock the true
>> potential of embedded software development with PlatformIO's
>> collaborative
>> ecosystem, embracing declarative principles, test-driven
>> methodologies, and
>> modern toolchains for unrivaled success.")
>> + (description
>> + "Your Gateway to Embedded Software Development
>> Excellence. Unlock the true
>> +potential of embedded software development with
>> @code{PlatformIO's}
>> +collaborative ecosystem, embracing declarative principles,
>> test-driven
>> +methodologies, and modern toolchains for unrivaled success.")
>> + (license license:asl2.0)))
>
> Please replace the marketing language with an actual synopsis
> and a
> description, following the guidelines at:
>
> https://guix.gnu.org/manual/devel/en/html_node/Synopses-and-Descriptions.html
>
> ‘guix lint’ may also diagnose obvious issues.
>
>> - (url "https://github.com/john30/ebusd")
>> - (commit version)))
>> + (url "https://github.com/john30/ebusd")
>> + (commit version)))
>> (file-name (string-append name "-" version
>> "-checkout"))
>> (sha256
>> (base32
>> @@ -1491,14 +1529,14 @@ (define-public ebusd
>> ("autoconf" ,autoconf)
>> ("config"
>> ,(origin
>> - (method git-fetch)
>> - (uri (git-reference
>> - (url
>> "https://github.com/john30/ebusd-configuration")
>> - (commit
>> "666c0f6b9c4d7545eff7f43ab28a1c7baeab7913")))
>> - (file-name "config-checkout")
>> - (sha256
>> - (base32
>> -
>> "0yxnx8p4lbk614l16854r9s9d8s9c7ixgczfs8mph94xz0wkda7x"))))))
>> + (method git-fetch)
>> + (uri (git-reference
>> + (url
>> "https://github.com/john30/ebusd-configuration")
>> + (commit
>> "666c0f6b9c4d7545eff7f43ab28a1c7baeab7913")))
>> + (file-name "config-checkout")
>> + (sha256
>> + (base32
>> +
>> "0yxnx8p4lbk614l16854r9s9d8s9c7ixgczfs8mph94xz0wkda7x"))))))
>
> Looks like these were unintended changes.
>
> Could you please send an updated patch series?
>
> Thanks,
> Ludo’.
C
C
Christopher Baines wrote on 17 Oct 2023 11:17
tag 64375 moreinfo
(address . control@debbugs.gnu.org)
87lec1fw02.fsf@cbaines.net
tags 64375 + moreinfo
quit
?