[PATCH 3/8] gnu: python-uvicorn: Update to 0.22.0.

  • Done
  • quality assurance status badge
Details
4 participants
  • Christopher Baines
  • Tobias Geerinckx-Rice
  • peter
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
peter
Severity
normal
Merged with
P
(address . guix-patches@gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
62a86f8c77ff10dc7620e19e0e52ac3248abf599.1688155097.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-web.scm (python-uvicorn): Update to 0.22.0.
---
gnu/packages/python-web.scm | 43 ++++++++++---------------------------
1 file changed, 11 insertions(+), 32 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 2df564f8b7..0c14e14665 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5599,46 +5599,25 @@ (define-public python-httptools
(define-public python-uvicorn
(package
(name "python-uvicorn")
- (version "0.17.6")
- (source
- (origin
- ;; PyPI tarball has no tests.
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/encode/uvicorn")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0npwls02nhna2lyw2nksxij16l9agf12c9f42pvxb5yrpi9l16c8"))))
- (build-system python-build-system)
+ (version "0.22.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "uvicorn" version))
+ (sha256
+ (base32
+ "1n4f5i6g4gnsj8z1wvjdyl9admsipc5q6rq5mbcyfz5m7ph7l9vr"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "-o" "asyncio_mode=auto"
- "-k"
- (string-append
- ;; These error or fail due to networking.
- "not test_keepalive "
- "and not test_bind_unix_socket_works_with_"
- "reload_or_workers "))))))))
- (native-inputs
- (list python-httpx-bootstrap
- python-pytest
- python-pytest-asyncio
- python-pytest-mock
- python-requests
- python-trustme
- python-wsproto))
+ `(#:tests? #f)) ; no tests in PyPI and no setup.py in github
(propagated-inputs
(list python-asgiref
python-click
python-dotenv
python-h11
+ python-hatchling
python-httptools
python-pyyaml
+ python-typing-extensions
python-uvloop
python-watchgod
python-websockets))
--
2.40.1
T
T
Tobias Geerinckx-Rice wrote on 1 Jul 2023 23:20
(no subject)
(name . GNU Debbugs)(address . control@debbugs.gnu.org)
87mt0fz5qa.fsf@nckx
merge 64375 64379 64382 64378 64383 64384 64380 64377 64381 64376
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCZKCZPg0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15wCUA/0Jvn38UokZk+c5VYKDawSOPjoErSSo4grXWwd7v
WBtwAP9NGjCoy9CQ1MxoBoSmttspnRmVI5qqNyaiuBT/W1yeBg==
=sPza
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 17 Oct 2023 11:17
tag 64375 moreinfo
(address . control@debbugs.gnu.org)
87lec1fw02.fsf@cbaines.net
tags 64375 + moreinfo
quit
S
S
Sharlatan Hellseher wrote on 26 Nov 16:11 +0100
[PATCH 3/8] gnu: python-uvicorn: Update to 0.22.0.
(address . 64378-done@debbugs.gnu.org)
87r06ym3ms.fsf@gmail.com
Hi,

Thanks for the patch, it was missed out.

Uvicorn was updated 0.23.2->0.32.0 by this commit
72ef08da9d4cd811d59be95bebc0ea8492427587 on master branch.

Closing as not applied.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmdF5RsACgkQdtcnv/Ys
0rVeExAAvIwixW64MfIqvQuV7xvRV6EV4CZgdQQF2yhg6xP2sUJueAHRyPOuCX7u
l8uDxvc1gtovhQ508lfO4FOmakAfTwWxCD8Ws4n2tEtfOcMyR+KjrfSoIuCezT+Q
tVndtcPMHKTn4Kdi+8IO83XDA6OARHNL8N0OzUQDVf7n87+mVUW4srvYBtoFk+9G
joV3nHGC5CwYRbSQO/miZ5oMdOfIhJKesFoPKUYgTiIUCCV/h+fxIcMH/OSFjZgP
yf+2C0o3D7LmyWbUgMbMwenzo+2q3PW2HR5LMwGQjjlIO96Cj+3l1Z0lUkWTwbrj
RHadfYTvxvnfiGy/1AG+srutp0FhynHAIuZVp7gHauIRToIqfjLZUjY4yM32klcD
hZOxL5BTVcG5EzDlnpPpasmWgvgeLsAx6fofjVIivaqCxUHkbF4HuQdkJw/yom9p
KKz9ENRPsLKAzgLOXMai6/vLqgUYGy28xS8GlnkppSixCN23IabD7HUaTq9xrYg8
9SSkFKgF8g9pxJnCnb4die+Zpz51iUbOVbvMOKoZWc2/bmOTuQ0FFaGo0E+J4sy0
E2A34ueozasaW0Y5sEsTCzfpcA5OrRqg85OAqYMdTw3rj07i6kRKP/EPO69oytWI
6ZWbEDebqr+uEAa7GPJghMwnxfpkATURtSYHK11yToL2JXGwi8o=
=587K
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 64378@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64378
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch