[PATCH] Add motif and xnedit

  • Done
  • quality assurance status badge
Details
3 participants
  • Andy Tai
  • Andy Tai
  • zimoun
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
Blocked by
A
A
Andy Tai wrote on 7 Nov 2022 06:12
[PATCH] gnu: Add xnedit
(address . guix-patches@gnu.org)
CAJsg1E9or6WBS-BnwBV_PEqOOpyniZeLVFfuhGoB9V5fa9paKg@mail.gmail.com

From 31c34b0ebdaf6712213646b993b53a47416b9282 Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Sun, 6 Nov 2022 21:09:28 -0800
Subject: [PATCH] gnu: Add xnedit

* gnu/packages/text-editors.scm (xnedit): New variable
---
gnu/packages/text-editors.scm | 36 +++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index a16ce8a117..40a2106e6b 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -72,6 +73,7 @@ (define-module (gnu packages text-editors)
#:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
+ #:use-module (gnu packages lesstif)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages libreoffice)
#:use-module (gnu packages llvm)
@@ -1355,3 +1357,37 @@ (define-public lite-xl
The aim of Lite XL compared to lite is to be more user-friendly, improve the
quality of font rendering, and reduce CPU usage.")
(license license:expat)))
+
+(define-public xnedit
+ (package
+ (name "xnedit")
+ (version "1.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/xnedit/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0fw3li7hr47hckm9pl1njx30lfr6cx2p094ir8zmgr91hyxidgld"))))
+
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list (string-append "PREFIX="
+ (assoc-ref %outputs "out"))
+ (string-append "CC="
+ ,(cc-for-target)))
+ #:tests? #f ; no tests
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "linux" make-flags))))))
+ (inputs (list
+ motif
+ pcre))
+ (native-inputs (list pkg-config))
+ (home-page "https://sourceforge.net/projects/xnedit/")
+ (synopsis "Fast and classic X11 text editor")
+ (description "XNEdit is a fast and classic X11 text editor, based on NEdit,
+with full unicode support and antialiased text rendering.")
+ (license license:gpl2+)))
--
2.38.0
A
A
Andy Tai wrote on 7 Nov 2022 06:33
(address . control@debbugs.gnu.org)
CAJsg1E-tcV45NQ5D7OakBd9HUHvgfZeRsKHzktiEznjHJvAsQQ@mail.gmail.com
block 59093 by 59092
Z
Z
zimoun wrote on 6 Jan 2023 12:50
(name . Andy Tai)(address . atai@atai.org)(address . 59093@debbugs.gnu.org)
871qo7khk4.fsf@gmail.com
Hi,

On Sun, 06 Nov 2022 at 21:12, Andy Tai <atai@atai.org> wrote:

Toggle quote (3 lines)
> + (arguments
> + `(#:make-flags (list (string-append "PREFIX="
> + (assoc-ref %outputs "out"))
--^
this

This pattern is now deprecated, if I understand correctly.


Instead, something like,

(arguments
(list
#:make-flags #~(list (string-append "PREFIX=" #$output)
(string-append "CC=" #$(cc-for-target)))
#:tests? #f ; no tests
#:phases #~(modify-phases %standard-phases
(delete 'configure)
(replace 'build
(lambda* (#:key make-flags #:allow-other-keys)
(apply invoke "make" "linux" make-flags)))))))

seems more compliant with the “new” style.



Toggle quote (4 lines)
> + (inputs (list
> + motif
> + pcre))

Incorrect indentation or just (inputs (list motif pcre))


Cheers,
simon
A
A
Andy Tai wrote on 7 Jan 2023 08:14
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 59093@debbugs.gnu.org)
CAJsg1E-O9efBn8pvtBQOo2i5MTQgtgsE93kUMorsrjncSqunEg@mail.gmail.com
Hi, I guess I will need to update the patch to fit the new style.

On Fri, Jan 6, 2023 at 4:15 PM zimoun <zimon.toutoune@gmail.com> wrote:

Toggle quote (44 lines)
> Hi,
>
> On Sun, 06 Nov 2022 at 21:12, Andy Tai <atai@atai.org> wrote:
>
> > + (arguments
> > + `(#:make-flags (list (string-append "PREFIX="
> > + (assoc-ref %outputs "out"))
> --^
> this
>
> This pattern is now deprecated, if I understand correctly.
>
> https://guix.gnu.org/en/blog/2021/the-big-change/
>
> Instead, something like,
>
> (arguments
> (list
> #:make-flags #~(list (string-append "PREFIX=" #$output)
> (string-append "CC=" #$(cc-for-target)))
> #:tests? #f ; no tests
> #:phases #~(modify-phases %standard-phases
> (delete 'configure)
> (replace 'build
> (lambda* (#:key make-flags #:allow-other-keys)
> (apply invoke "make" "linux"
> make-flags)))))))
>
> seems more compliant with the “new” style.
>
>
>
> > + (inputs (list
> > + motif
> > + pcre))
>
> Incorrect indentation or just (inputs (list motif pcre))
>
>
> Cheers,
> simon
>


--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat:
andytai1010
Year 2023 ??112?
????????????
????????????
Attachment: file
A
A
Andy Tai wrote on 11 Jan 2023 03:44
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 59093@debbugs.gnu.org)
CAJsg1E-xRPCdq-fAP7Bz0Q0W4mtuFpg9TxrXGn-ZRKc4FSAcGQ@mail.gmail.com
I tried to use the new "G-exp" style but that would not build, so I
keep the old style.

Other comment addressed.

Updated patch attached

On Sat, Jan 7, 2023 at 7:14 AM Andy Tai <atai@atai.org> wrote:
Toggle quote (3 lines)
>
> Hi, I guess I will need to update the patch to fit the new style.
>
From 65a07b13cb90101c5fbfefc508da4ec41623684d Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Wed, 11 Jan 2023 02:40:26 +0000
Subject: [PATCH] gnu: Add xnedit

* gnu/packages/text-editors.scm (xnedit): New variable
---
gnu/packages/text-editors.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 9dd5d7793f..1eea322f1c 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -75,6 +76,7 @@ (define-module (gnu packages text-editors)
#:use-module (gnu packages hunspell)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
+ #:use-module (gnu packages lesstif)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages llvm)
#:use-module (gnu packages lua)
@@ -1391,3 +1393,34 @@ (define-public lite-xl
The aim of Lite XL compared to lite is to be more user-friendly, improve the
quality of font rendering, and reduce CPU usage.")
(license license:expat)))
+
+(define-public xnedit
+ (package
+ (name "xnedit")
+ (version "1.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/xnedit/" name "-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0fw3li7hr47hckm9pl1njx30lfr6cx2p094ir8zmgr91hyxidgld"))))
+
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "CC=" ,(cc-for-target)))
+ #:tests? #f ;no tests
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "linux" make-flags))))))
+ (inputs (list motif pcre))
+ (native-inputs (list pkg-config))
+ (home-page "https://sourceforge.net/projects/xnedit/")
+ (synopsis "Fast and classic X11 text editor")
+ (description
+ "XNEdit is a fast and classic X11 text editor, based on NEdit,
+with full unicode support and antialiased text rendering.")
+ (license license:gpl2+)))
--
2.34.1
S
S
Simon Tournier wrote on 11 Jan 2023 15:56
[PATCH v2 2/2] gnu: Add xnedit
(address . 59093@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230111145604.2643141-2-zimon.toutoune@gmail.com
From: Andy Tai <atai@atai.org>

* gnu/packages/text-editors.scm (xnedit): New variable
---
gnu/packages/text-editors.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 9dd5d7793f..3898ab1eb7 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -75,6 +76,7 @@ (define-module (gnu packages text-editors)
#:use-module (gnu packages hunspell)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
+ #:use-module (gnu packages lesstif)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages llvm)
#:use-module (gnu packages lua)
@@ -1391,3 +1393,35 @@ (define-public lite-xl
The aim of Lite XL compared to lite is to be more user-friendly, improve the
quality of font rendering, and reduce CPU usage.")
(license license:expat)))
+
+(define-public xnedit
+ (package
+ (name "xnedit")
+ (version "1.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/xnedit/" name "-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0fw3li7hr47hckm9pl1njx30lfr6cx2p094ir8zmgr91hyxidgld"))))
+
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags #~(list (string-append "PREFIX=" #$output)
+ (string-append "CC=" #$(cc-for-target)))
+ #:tests? #f ;no tests
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "linux" make-flags))))))
+ (inputs (list motif pcre))
+ (native-inputs (list pkg-config))
+ (home-page "https://sourceforge.net/projects/xnedit/")
+ (synopsis "Fast and classic X11 text editor")
+ (description
+ "XNEdit is a fast and classic X11 text editor, based on NEdit,
+with full unicode support and antialiased text rendering.")
+ (license license:gpl2+)))
--
2.38.1
S
S
Simon Tournier wrote on 11 Jan 2023 15:56
[PATCH v2 1/2] gnu: Add motif
(address . 59093@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230111145604.2643141-1-zimon.toutoune@gmail.com
From: Andy Tai <atai@atai.org>

* gnu/packages/lesstif.scm (motif): New variable
---
gnu/packages/lesstif.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/lesstif.scm b/gnu/packages/lesstif.scm
index 8f017f41be..1ab471e4fa 100644
--- a/gnu/packages/lesstif.scm
+++ b/gnu/packages/lesstif.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +22,12 @@ (define-module (gnu packages lesstif)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix git-download)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages c)
+ #:use-module (gnu packages flex)
+ #:use-module (gnu packages fontutils)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages xorg))
@@ -46,3 +53,36 @@ (define-public lesstif
(synopsis "Clone of the Motif toolkit for the X window system")
(description "Clone of the Motif toolkit for the X window system.")
(license license:gpl2+))) ; some files are lgpl2.1+ or x11
+
+(define-public motif
+ ;; This commit is from September 2021 and v2.3.8 from 2017.
+ (let ((commit "59858b0811e8d9dfaeb142f2b5a96f55482be1ed")
+ (revision "0"))
+ (package
+ (name "motif")
+ (version (git-version "2.3.8" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/motif/code")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yycq0vzga9qmgbfzn2d02ilpwxixwdv2j1d8sddl4dripcrg21m"))))
+ (build-system gnu-build-system)
+ (inputs
+ (list libx11 xorgproto))
+ (propagated-inputs
+ (list fontconfig freetype libxext libxft libxpm libxt xbitmaps))
+ (native-inputs
+ (list autoconf automake byacc flex libtool pkg-config))
+ (home-page "https://motif.ics.com/motif")
+ (synopsis "Motif toolkit for the X window system")
+ (description "Motif is a standard graphical user interface, (as
+defined by the IEEE 1295 specification), used on more than 200 hardware and
+software platforms. It provides application developers, end users, and system
+vendors with a widely used environment for standardizing
+application presentation on a wide range of platforms.")
+ (license license:lgpl2.1+))))

base-commit: a8b2decf287498eeb51ef23712c5bd01b60cb18b
--
2.38.1
S
S
Simon Tournier wrote on 11 Jan 2023 16:02
Re: [bug#59093] [PATCH] gnu: Add xnedit
(name . Andy Tai)(address . atai@atai.org)(address . 59093@debbugs.gnu.org)
87k01txgg9.fsf@gmail.com
Hi,

On mer., 11 janv. 2023 at 02:44, Andy Tai <atai@atai.org> wrote:

Toggle quote (3 lines)
> I tried to use the new "G-exp" style but that would not build, so I
> keep the old style.

Done with patch subject [PATCH v2].

Cheers,
simon

PS: Please consider sending as a same patch set related patches. For
instance, this addition of xnedit requires the addition of motif so they
should be part of the same series.

Easing the reviewer’s job eases the merge, IMHO. :-)

For example, it is easier to apply the two patches, then “./pre-inst-env
guix build xnedit“; than dig the bug tracker in order to find, maybe,
the other submission. Moreover, being part of the same submission eases
the QA, again IMHO.

Anyway, thanks for the patches. :-)
S
S
Simon Tournier wrote on 11 Jan 2023 15:52
control message for bug #59093
(address . control@debbugs.gnu.org)
87o7r5xgwg.fsf@gmail.com
retitle 59093 [PATCH] Add motif and xnedit
quit
A
A
Andy Tai wrote on 12 Jan 2023 04:25
Re: [bug#59093] [PATCH] gnu: Add xnedit
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)(address . 59093@debbugs.gnu.org)
CAJsg1E8ZycDbn8TuUmP=014Xmbw_3YWoL7uyEW_LzoG8hE-tUg@mail.gmail.com
Simon, thanks. So what is remaining to be addressed as I see it is
still pending or the issue is still open

On Wed, Jan 11, 2023 at 7:03 AM Simon Tournier <zimon.toutoune@gmail.com> wrote:
Toggle quote (19 lines)
>
> Done with patch subject [PATCH v2].
>
> Cheers,
> simon
>
> PS: Please consider sending as a same patch set related patches. For
> instance, this addition of xnedit requires the addition of motif so they
> should be part of the same series.
>
> Easing the reviewer’s job eases the merge, IMHO. :-)
>
> For example, it is easier to apply the two patches, then “./pre-inst-env
> guix build xnedit“; than dig the bug tracker in order to find, maybe,
> the other submission. Moreover, being part of the same submission eases
> the QA, again IMHO.
>
> Anyway, thanks for the patches. :-)
>
S
S
Simon Tournier wrote on 12 Jan 2023 11:03
(name . Andy Tai)(address . atai@atai.org)(address . 59093@debbugs.gnu.org)
CAJ3okZ3diGESnXEXeFScp9AFpJZ3s0XTJ05ohhnUPDwNUXegnw@mail.gmail.com
Hi,

On Thu, 12 Jan 2023 at 04:26, Andy Tai <atai@atai.org> wrote:

Toggle quote (3 lines)
> Simon, thanks. So what is remaining to be addressed as I see it is
> still pending or the issue is still open

The patch v2 is ready to be merged; all is addressed from my eyes.
But I have not have commit access so I cannot push and close this
submission. :-)

Cheers,
simon
A
A
Andy Tai wrote on 12 Jan 2023 11:08
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)(address . 59093@debbugs.gnu.org)
CAJsg1E9RZ1JDcSTUS8L86GnVZTYT7-cD5jV19PE5rEYpVL441w@mail.gmail.com
Thanks... I cannot tell who has the commit access... I assume you do as you
review patches :-)

On Thu, Jan 12, 2023 at 2:03 AM Simon Tournier <zimon.toutoune@gmail.com>
wrote:

Toggle quote (16 lines)
> Hi,
>
> On Thu, 12 Jan 2023 at 04:26, Andy Tai <atai@atai.org> wrote:
>
> > Simon, thanks. So what is remaining to be addressed as I see it is
> > still pending or the issue is still open
>
> The patch v2 is ready to be merged; all is addressed from my eyes.
> But I have not have commit access so I cannot push and close this
> submission. :-)
>
> Cheers,
> simon
>


--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat:
andytai1010
Year 2023 ??112?
????????????
????????????
Attachment: file
S
S
Simon Tournier wrote on 12 Jan 2023 11:26
(name . Andy Tai)(address . atai@atai.org)(address . 59093@debbugs.gnu.org)
CAJ3okZ3z_uSXvP3wYp4aVN0K4_vdwd+5UXTXc_EwT0d7qEu+1Q@mail.gmail.com
Re,

On Thu, 12 Jan 2023 at 11:08, Andy Tai <atai@atai.org> wrote:
Toggle quote (3 lines)
>
> Thanks... I cannot tell who has the commit access... I assume you do as you review patches :-)


Review is a collective task and comment patches for improving their
quality is not reserved to people with commit access. :-) The number
of people with commit access is limited and so if a first pass of
review is done then it eases and saves them some time. :-)

Cheers,
simon
A
A
Andy Tai wrote on 29 Jan 2023 02:13
[PATCH v3 1/2] gnu: Add motif
(address . 59093@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230129011307.24277-1-atai@atai.org
* gnu/packages/lesstif.scm (motif): New variable
---
gnu/packages/lesstif.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/lesstif.scm b/gnu/packages/lesstif.scm
index 8f017f41be..1ab471e4fa 100644
--- a/gnu/packages/lesstif.scm
+++ b/gnu/packages/lesstif.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +22,12 @@ (define-module (gnu packages lesstif)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix git-download)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages c)
+ #:use-module (gnu packages flex)
+ #:use-module (gnu packages fontutils)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages xorg))
@@ -46,3 +53,36 @@ (define-public lesstif
(synopsis "Clone of the Motif toolkit for the X window system")
(description "Clone of the Motif toolkit for the X window system.")
(license license:gpl2+))) ; some files are lgpl2.1+ or x11
+
+(define-public motif
+ ;; This commit is from September 2021 and v2.3.8 from 2017.
+ (let ((commit "59858b0811e8d9dfaeb142f2b5a96f55482be1ed")
+ (revision "0"))
+ (package
+ (name "motif")
+ (version (git-version "2.3.8" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/motif/code")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yycq0vzga9qmgbfzn2d02ilpwxixwdv2j1d8sddl4dripcrg21m"))))
+ (build-system gnu-build-system)
+ (inputs
+ (list libx11 xorgproto))
+ (propagated-inputs
+ (list fontconfig freetype libxext libxft libxpm libxt xbitmaps))
+ (native-inputs
+ (list autoconf automake byacc flex libtool pkg-config))
+ (home-page "https://motif.ics.com/motif")
+ (synopsis "Motif toolkit for the X window system")
+ (description "Motif is a standard graphical user interface, (as
+defined by the IEEE 1295 specification), used on more than 200 hardware and
+software platforms. It provides application developers, end users, and system
+vendors with a widely used environment for standardizing
+application presentation on a wide range of platforms.")
+ (license license:lgpl2.1+))))

base-commit: c6ec9c7af9814f84f293f62235eab9d0649751a7
--
2.39.1
A
A
Andy Tai wrote on 29 Jan 2023 02:13
[PATCH v3 2/2] gnu: Add xnedit
(address . 59093@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230129011324.24289-1-atai@atai.org
* gnu/packages/text-editors.scm (xnedit): New variable
---
gnu/packages/text-editors.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 9dd5d7793f..3898ab1eb7 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -75,6 +76,7 @@ (define-module (gnu packages text-editors)
#:use-module (gnu packages hunspell)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
+ #:use-module (gnu packages lesstif)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages llvm)
#:use-module (gnu packages lua)
@@ -1391,3 +1393,35 @@ (define-public lite-xl
The aim of Lite XL compared to lite is to be more user-friendly, improve the
quality of font rendering, and reduce CPU usage.")
(license license:expat)))
+
+(define-public xnedit
+ (package
+ (name "xnedit")
+ (version "1.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/xnedit/" name "-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0fw3li7hr47hckm9pl1njx30lfr6cx2p094ir8zmgr91hyxidgld"))))
+
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags #~(list (string-append "PREFIX=" #$output)
+ (string-append "CC=" #$(cc-for-target)))
+ #:tests? #f ;no tests
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "linux" make-flags))))))
+ (inputs (list motif pcre))
+ (native-inputs (list pkg-config))
+ (home-page "https://sourceforge.net/projects/xnedit/")
+ (synopsis "Fast and classic X11 text editor")
+ (description
+ "XNEdit is a fast and classic X11 text editor, based on NEdit,
+with full unicode support and antialiased text rendering.")
+ (license license:gpl2+)))
--
2.39.1
A
A
Andy Tai wrote on 29 Jan 2023 05:16
(address . control@debbugs.gnu.org)
CAJsg1E9pb+vfoFdzxXNnDukX8tgwBBKJwmQwYXfUVqdTWnJMbA@mail.gmail.com
close 59093
S
S
Simon Tournier wrote on 30 Jan 2023 13:44
(name . Andy Tai)(address . lichengtai@gmail.com)
87357skx9d.fsf@gmail.com
Hi,

On sam., 28 janv. 2023 at 20:16, Andy Tai <lichengtai@gmail.com> wrote:

Toggle quote (2 lines)
> close 59093

Why do you close it? And then you open #61134 [1] with the same patch.



Cheers,
simon
A
A
Andy Tai wrote on 30 Jan 2023 16:35
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
CAJsg1E-Q0Fft_JEdEK7uKLARugT9k=suRSf3yUQ=mvwJ1RXYMg@mail.gmail.com
I did it so Guix QA can pick it up to queue it for testing.

Guix QA seemed confused about the old bug, always in a failed state

On Mon, Jan 30, 2023 at 4:47 AM Simon Tournier <zimon.toutoune@gmail.com> wrote:
Toggle quote (14 lines)
>
> Hi,
>
> On sam., 28 janv. 2023 at 20:16, Andy Tai <lichengtai@gmail.com> wrote:
>
> > close 59093
>
> Why do you close it? And then you open #61134 [1] with the same patch.
>
> 1: <http://issues.guix.gnu.org/issue/61134>
>
>
> Cheers,
> simon
S
S
Simon Tournier wrote on 31 Jan 2023 10:56
Re: [bug#59093] [PATCH] Add motif and xnedit
(name . Andy Tai)(address . lichengtai@gmail.com)
86fsbrvxhb.fsf@gmail.com
Hi,

On Mon, 30 Jan 2023 at 07:35, Andy Tai <lichengtai@gmail.com> wrote:

Toggle quote (2 lines)
> Guix QA seemed confused about the old bug, always in a failed state

It appears to me better to point the issues and then maybe fix them
instead of bypassing them. My 2 cents.

Cheers,
simon
A
A
Andy Tai wrote on 31 Jan 2023 18:15
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
CAJsg1E_wKTZcLmZZFgYBHzR34nBYBEcosZrCTcqzzovY4eTnpQ@mail.gmail.com
you meant fixing the issue in Guix QA?

It goes without saying that Guix QA is far from the code in question
of this issue and my question on Guix QA also went unanswered on the
mailing list.



On Tue, Jan 31, 2023 at 3:36 AM Simon Tournier <zimon.toutoune@gmail.com> wrote:
Toggle quote (12 lines)
>
> Hi,
>
> On Mon, 30 Jan 2023 at 07:35, Andy Tai <lichengtai@gmail.com> wrote:
>
> > Guix QA seemed confused about the old bug, always in a failed state
>
> It appears to me better to point the issues and then maybe fix them
> instead of bypassing them. My 2 cents.
>
> Cheers,
> simon
A
A
Andy Tai wrote on 31 Jan 2023 19:12
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
CAJsg1E-kT9Nr626adUzi4OkCuLSvQp0fB+5vnP6FH3-NDPHSWg@mail.gmail.com
To clarify, when I mentioned Guix QA shows failure, Guiox QA was
showing "failure" trying to queue the issue to build, not that Gux QA
was showing some build log with the patch failing to build in some
way.

So I don't know if you are saying people should look at Guix QA
sources and help to fix that. That is possible, of course, but people
contributing to Guix patches may have no background at all at how Guix
QA works.

On Tue, Jan 31, 2023 at 9:15 AM Andy Tai <atai@atai.org> wrote:
Toggle quote (25 lines)
>
> you meant fixing the issue in Guix QA?
>
> It goes without saying that Guix QA is far from the code in question
> of this issue and my question on Guix QA also went unanswered on the
> mailing list.
>
>
>
> On Tue, Jan 31, 2023 at 3:36 AM Simon Tournier <zimon.toutoune@gmail.com> wrote:
> >
> > Hi,
> >
> > On Mon, 30 Jan 2023 at 07:35, Andy Tai <lichengtai@gmail.com> wrote:
> >
> > > Guix QA seemed confused about the old bug, always in a failed state
> >
> > It appears to me better to point the issues and then maybe fix them
> > instead of bypassing them. My 2 cents.
> >
> > Cheers,
> > simon



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2023 ??112?
????????????
????????????
S
S
Simon Tournier wrote on 1 Feb 2023 11:08
Re: [bug#61134] [bug#59093] [PATCH] Add motif and xnedit
(name . Andy Tai)(address . atai@atai.org)
86zg9xu28m.fsf@gmail.com
Hi Andy,

On Tue, 31 Jan 2023 at 10:12, Andy Tai <atai@atai.org> wrote:
Toggle quote (10 lines)
> To clarify, when I mentioned Guix QA shows failure, Guiox QA was
> showing "failure" trying to queue the issue to build, not that Gux QA
> was showing some build log with the patch failing to build in some
> way.
>
> So I don't know if you are saying people should look at Guix QA
> sources and help to fix that. That is possible, of course, but people
> contributing to Guix patches may have no background at all at how Guix
> QA works.

I have understood the first time. :-)

I wrote: «It appears to me better to point the issues and then maybe fix
them instead of bypassing them. My 2 cents.»

I am not saying that you should fix issues with QA, obviously not.
Instead, I am proposing that if you notice something unexpected with QA,
you should report it and not silently bypass it.

“Report it” means for example drop an email to guix-devel or open a bug
or roam on #guix and tell. I do not know what is the best and it does
not mean that the issue about QA will be fixed. It just helps in
improving the tools, IMHO.

Well, for what it is worth, I am trying to say that silently close and
reopen another ticket because QA does not behave as expected is a
short-term hack – and yes it is often necessary to have the task done
now :-) – but by silently closing it does not help for the longer term.

Thanks for your contributions and taking the time to discuss how we
could collectively improve Guix. :-)

Cheers,
simon
?