[PATCH] gnu: Add motif

  • Done
  • quality assurance status badge
Details
4 participants
  • Andy Tai
  • Andy Tai
  • Christopher Baines
  • Simon Tournier
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote on 7 Nov 2022 06:02
(address . guix-patches@gnu.org)
CAJsg1E8bmAj1UGKAEUvVzNWdzszvrMHheZ5azrs5Yr2WQ7UX9A@mail.gmail.com

From fef78fc20a8599e87b8d12f674dedd7d1cfa3eed Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Sun, 6 Nov 2022 20:56:05 -0800
Subject: [PATCH] gnu: Add motif

* gnu/packages/lesstif.scm (motif): New variable
---
gnu/packages/lesstif.scm | 40 +++++++++++++++++++++++++++++++++++++++-
1 file changed, 39 insertions(+), 1 deletion(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/lesstif.scm b/gnu/packages/lesstif.scm
index 8f017f41be..7a53c1a9ee 100644
--- a/gnu/packages/lesstif.scm
+++ b/gnu/packages/lesstif.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,7 +22,15 @@ (define-module (gnu packages lesstif)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
- #:use-module (gnu packages xorg))
+ #:use-module (guix git-download)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages c)
+ #:use-module (gnu packages flex)
+ #:use-module (gnu packages fontutils)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages xorg)
+
+ )
(define-public lesstif
@@ -46,3 +55,32 @@ (define-public lesstif
(synopsis "Clone of the Motif toolkit for the X window system")
(description "Clone of the Motif toolkit for the X window system.")
(license license:gpl2+))) ; some files are lgpl2.1+ or x11
+
+
+(define-public motif
+ (let ((commit "59858b0811e8d9dfaeb142f2b5a96f55482be1ed")
+ (revision "0"))
+ (package
+ (name "motif")
+ (version (git-version "2.3.8" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/motif/code")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yycq0vzga9qmgbfzn2d02ilpwxixwdv2j1d8sddl4dripcrg21m"))))
+ (build-system gnu-build-system)
+ (inputs
+ (list libx11 xorgproto ))
+ (propagated-inputs
+ (list fontconfig freetype libxext libxft libxpm libxt xbitmaps))
+ (native-inputs
+ (list autoconf automake byacc flex libtool pkg-config))
+ (home-page "https://motif.ics.com/motif")
+ (synopsis "Motif toolkit for the X window system")
+ (description "The Motif toolkit for the X window system.")
+ (license license:lgpl2.1+))))
--
2.38.0
A
A
Andy Tai wrote on 7 Nov 2022 06:33
(address . control@debbugs.gnu.org)
CAJsg1E-tcV45NQ5D7OakBd9HUHvgfZeRsKHzktiEznjHJvAsQQ@mail.gmail.com
block 59093 by 59092
C
C
Christopher Baines wrote on 17 Nov 2022 12:35
(name . Andy Tai)(address . atai@atai.org)
87mt8perrb.fsf@cbaines.net
Andy Tai <atai@atai.org> writes:

Subject: [PATCH] gnu: Add motif

Toggle quote (31 lines)
> * gnu/packages/lesstif.scm (motif): New variable
> ---
> gnu/packages/lesstif.scm | 40 +++++++++++++++++++++++++++++++++++++++-
> 1 file changed, 39 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/lesstif.scm b/gnu/packages/lesstif.scm
> index 8f017f41be..7a53c1a9ee 100644
> --- a/gnu/packages/lesstif.scm
> +++ b/gnu/packages/lesstif.scm
> @@ -1,5 +1,6 @@
> ;;; GNU Guix --- Functional package management for GNU
> ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
> +;;; Copyright © 2022 Andy Tai <atai@atai.org>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -21,7 +22,15 @@ (define-module (gnu packages lesstif)
> #:use-module (guix packages)
> #:use-module (guix download)
> #:use-module (guix build-system gnu)
> - #:use-module (gnu packages xorg))
> + #:use-module (guix git-download)
> + #:use-module (gnu packages autotools)
> + #:use-module (gnu packages c)
> + #:use-module (gnu packages flex)
> + #:use-module (gnu packages fontutils)
> + #:use-module (gnu packages pkg-config)
> + #:use-module (gnu packages xorg)
> +
> + )

There's a needless line here.

Toggle quote (27 lines)
> (define-public lesstif
> @@ -46,3 +55,32 @@ (define-public lesstif
> (synopsis "Clone of the Motif toolkit for the X window system")
> (description "Clone of the Motif toolkit for the X window system.")
> (license license:gpl2+))) ; some files are lgpl2.1+ or x11
> +
> +
> +(define-public motif
> + (let ((commit "59858b0811e8d9dfaeb142f2b5a96f55482be1ed")
> + (revision "0"))
> + (package
> + (name "motif")
> + (version (git-version "2.3.8" revision commit))
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://git.code.sf.net/p/motif/code")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0yycq0vzga9qmgbfzn2d02ilpwxixwdv2j1d8sddl4dripcrg21m"))))
> + (build-system gnu-build-system)
> + (inputs
> + (list libx11 xorgproto ))

I'd remove the space after xorgproto.

Toggle quote (8 lines)
> + (propagated-inputs
> + (list fontconfig freetype libxext libxft libxpm libxt xbitmaps))
> + (native-inputs
> + (list autoconf automake byacc flex libtool pkg-config))
> + (home-page "https://motif.ics.com/motif")
> + (synopsis "Motif toolkit for the X window system")
> + (description "The Motif toolkit for the X window system.")

Would you be able to write a different description? It's nice if it
doesn't just repeat the synopsis.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmN2HPhfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfzMw//YVqzbW+gphZ4tCqPeP13q9amfitnFgkd
nQn7UCoAFxyH+wVMxo42S9HAVAlvW0dDlm9GQ8qGeFdYXWvXGlYKbcWl8G1iGFFj
O8WZi7K/mMMbWoGNK3ARmwhYhxovgeYW+Jvp1glx6TdosHvuQCKlcw7WYkikvlpO
r78dZebCwWCa+QDBAQLpx4pB/6SCVaO8BgrrnwbodRYn+q4q98h6cRDdLMdtRsdV
y6nNQT0X5X7QRNnnJ5sVhNTOUsMCRfctQYCcVNCc5BZHpSG2NjLykWSZbbJNi1lL
u6+mMYlMJiJJ78O5OgQimiGBc7no4gKdN3xj03qW+6kr8Q65POPk0OXYNa4TcRsV
MkBT5qd53GscrLrfkHoHHopERQAWIhQyWi1MVCaPDpx/a9wYsGnOz9BU+cXUrlQm
VKje9Zv0ggbSwIWC3pXyjk/mX5gdR6TZd/EkqIiu6Wa5UJDYxbrFfGS+2PTHe46d
TgtfzIfFStkvnf5nOI4bGe0SYxGuBhDOEr8wOg2BAmpsslOgNkzYoPMSZrB5KqwJ
2n9YRk2k4vDyvh2Z18bHi+deuZNB+4vlVYdyY9c/02Jc4hRxQKcoaJNfvRjAPR2L
NGELwU6CoUYSPIrTE6Cs1gqGTFNaHCAUnB8t38ZjUVk4RTNdJbywl0DkmED6pNIi
C2Hp4c0beho=
=DgEe
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 17 Nov 2022 12:37
tag 59092 moreinfo
(address . control@debbugs.gnu.org)
87tu2xizga.fsf@cbaines.net
tags 59092 + moreinfo
quit
A
A
Andy Tai wrote on 23 Dec 2022 07:34
updated patch
(address . 59092@debbugs.gnu.org)
CAJsg1E-1+GcUh_4dmb5Fy+tLrorCWzgHtNNAVMxcczAtzhZJaA@mail.gmail.com
comments addressed
From 0c04d4eb75d7629766fed009d7e2e7d9faf01b1c Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Thu, 22 Dec 2022 22:30:33 -0800
Subject: [PATCH] gnu: Add motif

* gnu/packages/lesstif.scm (motif): New variable
---
gnu/packages/lesstif.scm | 41 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/lesstif.scm b/gnu/packages/lesstif.scm
index 8f017f41be..7aaad411a1 100644
--- a/gnu/packages/lesstif.scm
+++ b/gnu/packages/lesstif.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +22,12 @@ (define-module (gnu packages lesstif)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix git-download)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages c)
+ #:use-module (gnu packages flex)
+ #:use-module (gnu packages fontutils)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages xorg))
@@ -46,3 +53,37 @@ (define-public lesstif
(synopsis "Clone of the Motif toolkit for the X window system")
(description "Clone of the Motif toolkit for the X window system.")
(license license:gpl2+))) ; some files are lgpl2.1+ or x11
+
+
+(define-public motif
+ (let ((commit "59858b0811e8d9dfaeb142f2b5a96f55482be1ed")
+ (revision "0"))
+ (package
+ (name "motif")
+ (version (git-version "2.3.8" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/motif/code")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yycq0vzga9qmgbfzn2d02ilpwxixwdv2j1d8sddl4dripcrg21m"))))
+ (build-system gnu-build-system)
+ (inputs
+ (list libx11 xorgproto))
+ (propagated-inputs
+ (list fontconfig freetype libxext libxft libxpm libxt xbitmaps))
+ (native-inputs
+ (list autoconf automake byacc flex libtool pkg-config))
+ (home-page "https://motif.ics.com/motif")
+ (synopsis "Motif toolkit for the X window system")
+ (description "Motif is the industry standard graphical user interface, (as
+defined by the IEEE 1295 specification), used on more than 200 hardware and
+software platforms. It provides application developers, end users, and system
+vendors with the industry's most widely used environment for standardizing
+application presentation on a wide range of platforms. Motif is the leading
+user interface for the UNIX operating system.")
+ (license license:lgpl2.1+))))
--
2.38.1
A
A
Andy Tai wrote on 24 Dec 2022 06:33
(address . control@debbugs.gnu.org)
CAJsg1E-Hvk9-rLoRHPLAcJKU=y=jCAaHTsJ5DfS8ywHVDzEp5Q@mail.gmail.com
tags 59092 - moreinfo
S
S
Simon Tournier wrote on 9 Jan 2023 13:19
(name . Andy Tai)(address . lichengtai@gmail.com)(address . 59092@debbugs.gnu.org)
87zgaryk7d.fsf_-_@gmail.com
Hi,

The recipe LGTM but

1. I have not tried to build it,
2. I have not given a quick look to the source.

On jeu., 22 déc. 2022 at 22:34, Andy Tai <lichengtai@gmail.com> wrote:
Toggle quote (7 lines)
> +(define-public motif
> + (let ((commit "59858b0811e8d9dfaeb142f2b5a96f55482be1ed")
> + (revision "0"))
> + (package
> + (name "motif")
> + (version (git-version "2.3.8" revision commit))

Maybe it could helpful for later update to mention with a comment why
this commit is required and the release version is not enough.

Toggle quote (17 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://git.code.sf.net/p/motif/code")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0yycq0vzga9qmgbfzn2d02ilpwxixwdv2j1d8sddl4dripcrg21m"))))
> + (build-system gnu-build-system)
> + (inputs
> + (list libx11 xorgproto))
> + (propagated-inputs
> + (list fontconfig freetype libxext libxft libxpm libxt xbitmaps))
> + (native-inputs
> + (list autoconf automake byacc flex libtool pkg-config))
--^
Extra space

Here, an extra space. :-)

Toggle quote (4 lines)
> + (synopsis "Motif toolkit for the X window system")
> + (description "Motif is the industry standard graphical user interface, (as

Usually, we try to avoid such “the industry” and instead only “Motif is
a standard graphical user interface, …”

And the linter [1] complains about «description Validate package
descriptions sentences in description should be followed by two spaces;
possible infractions at 155, 343».


Cheers,
simon
A
A
Andy Tai wrote on 10 Jan 2023 21:35
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)(address . 59092@debbugs.gnu.org)
CAJsg1E_VUB5zjmcQGss0vEkub3DhbixX9SJFnzfqqk1Z4L4kmA@mail.gmail.com
Thanks for the review. The "industry standard" wording was copied
from the upstream description. Unsure of what is Guix's policy of
using upstream wordings as they are or these should be changed per our
opinion. In this case I will follow your suggestion

On Mon, Jan 9, 2023 at 4:20 AM Simon Tournier <zimon.toutoune@gmail.com> wrote:
Toggle quote (9 lines)
>
>
> > + (home-page "https://motif.ics.com/motif")
> > + (synopsis "Motif toolkit for the X window system")
> > + (description "Motif is the industry standard graphical user interface, (as
>
> Usually, we try to avoid such “the industry” and instead only “Motif is
> a standard graphical user interface, …”
>
A
A
Andy Tai wrote on 10 Jan 2023 22:46
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)(address . 59092@debbugs.gnu.org)
CAJsg1E8oi47ChN0E5oCH-g09NJzchcN4imv0_XOMDaDeCZwF5Q@mail.gmail.com
updated patch
From afd23adac9ba2165cc28afcc6b0de088c8b17dc2 Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Tue, 10 Jan 2023 21:42:15 +0000
Subject: [PATCH] gnu: Add motif

* gnu/packages/lesstif.scm (motif): New variable
---
gnu/packages/lesstif.scm | 41 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/lesstif.scm b/gnu/packages/lesstif.scm
index 8f017f41be..584c47a943 100644
--- a/gnu/packages/lesstif.scm
+++ b/gnu/packages/lesstif.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +22,12 @@ (define-module (gnu packages lesstif)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix git-download)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages c)
+ #:use-module (gnu packages flex)
+ #:use-module (gnu packages fontutils)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages xorg))
@@ -46,3 +53,37 @@ (define-public lesstif
(synopsis "Clone of the Motif toolkit for the X window system")
(description "Clone of the Motif toolkit for the X window system.")
(license license:gpl2+))) ; some files are lgpl2.1+ or x11
+
+
+(define-public motif
+ (let ((commit "59858b0811e8d9dfaeb142f2b5a96f55482be1ed")
+ (revision "0"))
+ (package
+ (name "motif")
+ (version (git-version "2.3.8" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/motif/code")
+ (commit commit)))
+ ;; 2.3.8 release plus unreleased bug fixes in master branch
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yycq0vzga9qmgbfzn2d02ilpwxixwdv2j1d8sddl4dripcrg21m"))))
+ (build-system gnu-build-system)
+ (inputs
+ (list libx11 xorgproto))
+ (propagated-inputs
+ (list fontconfig freetype libxext libxft libxpm libxt xbitmaps))
+ (native-inputs
+ (list autoconf automake byacc flex libtool pkg-config))
+ (home-page "https://motif.ics.com/motif")
+ (synopsis "Motif toolkit for the X window system")
+ (description "Motif is a standard graphical user interface, (as
+defined by the IEEE 1295 specification), used on more than 200 hardware and
+software platforms. It provides application developers, end users, and system
+vendors with a widely used environment for standardizing
+application presentation on a wide range of platforms.")
+ (license license:lgpl2.1+))))
--
2.34.1
S
S
Simon Tournier wrote on 11 Jan 2023 15:51
Re: [bug#59092] [PATCH] gnu: Add motif
(name . Andy Tai)(address . atai@atai.org)(address . 59092-done@debbugs.gnu.org)
87pmblxgxo.fsf@gmail.com
Hi,

On mar., 10 janv. 2023 at 21:46, Andy Tai <atai@atai.org> wrote:

Toggle quote (7 lines)
> From afd23adac9ba2165cc28afcc6b0de088c8b17dc2 Mon Sep 17 00:00:00 2001
> From: Andy Tai <atai@atai.org>
> Date: Tue, 10 Jan 2023 21:42:15 +0000
> Subject: [PATCH] gnu: Add motif
>
> * gnu/packages/lesstif.scm (motif): New variable

Close because included with [PATCH v2] of #59093.

Cheers,
simon
Closed
?