[PATCH 3/3] gnu: Add velox.

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • zamfofex
Owner
unassigned
Submitted by
zamfofex
Severity
normal
Merged with
Z
Z
zamfofex wrote on 20 Oct 2022 14:25
(address . guix-patches@gnu.org)(name . zamfofex)(address . zamfofex@twdb.moe)
3daab74b33025e4d8c315589eb5d3b4806650e6c.1666268609.git.zamfofex@twdb.moe
* gnu/packages/wm.scm (velox): New variable.
---
gnu/packages/wm.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index d5c5dc4ed2..8a6f3684de 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -3011,3 +3011,37 @@ (define-public swc
@item Can place borders around windows
@end itemize")
(license license:expat))))
+
+(define-public velox
+ (let ((commit "fcc041265539befd907a64ee3a536cb2489ffb99")
+ (revision "1"))
+ (package
+ (name "velox")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/michaelforney/velox")
+ (commit commit)))
+ (sha256
+ (base32
+ "0d11bmag5zwmas3rf1b7x5hjla7wpxq70nr86dz3x9r7cal04mym"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs (list libinput
+ libxkbcommon
+ wayland
+ wld))
+ (propagated-inputs (list swc))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/michaelforney/velox")
+ (synopsis "A simple window manager based on swc")
+ (description "velox is a simple window manager based on swc. It is inspired by dwm and xmonad.")
+ (license license:expat))))
--
2.38.0
T
T
Tobias Geerinckx-Rice wrote on 20 Oct 2022 14:36
(address . control@debbugs.gnu.org)
02B5C365-24F6-4928-8B98-60584610F9E0@tobias.gr
merge 58654 58655 58656 58657
thanks

Kind regards,

T G-R

Sent on the go. Excuse or enjoy my brevity.
?