[PATCH 2/3] gnu: Add swc.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Tobias Geerinckx-Rice
  • zamfofex
Owner
unassigned
Submitted by
zamfofex
Severity
normal
Merged with
Z
Z
zamfofex wrote on 20 Oct 2022 14:25
(address . guix-patches@gnu.org)(name . zamfofex)(address . zamfofex@twdb.moe)
189e15e5a0cc583fddd0c5ffc094298543af25c9.1666268609.git.zamfofex@twdb.moe
* gnu/packages/wm.scm (swc): New variable.
---
gnu/packages/wm.scm | 45 +++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 94dfd28f4a..d5c5dc4ed2 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2966,3 +2966,48 @@ (define-public wld
(synopsis "A primitive drawing library targeted at Wayland")
(description "wld is a drawing library that targets Wayland.")
(license license:expat))))
+
+(define-public swc
+ (let ((commit "a7b615567f83d9e48d585251015048c441ca0239")
+ (revision "1"))
+ (package
+ (name "swc")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/michaelforney/swc")
+ (commit commit)))
+ (sha256
+ (base32
+ "19rpbwpi81pm92fkhsmbx7pzagpah5m9ih5h5k3m8dy6r8ihdh35"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs (list libdrm
+ libinput
+ libxcb
+ libxkbcommon
+ wayland
+ wayland-protocols
+ wld
+ xcb-util-wm))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/michaelforney/swc")
+ (synopsis "A library for making a simple Wayland compositor")
+ (description "swc is a small Wayland compositor implemented as a library.
+
+It has been designed primarily with tiling window managers in mind. Additionally,
+notable features include:
+@itemize
+@item Easy to follow code base
+@item XWayland support
+@item Can place borders around windows
+@end itemize")
+ (license license:expat))))
--
2.38.0
T
T
Tobias Geerinckx-Rice wrote on 20 Oct 2022 14:36
(address . control@debbugs.gnu.org)
02B5C365-24F6-4928-8B98-60584610F9E0@tobias.gr
merge 58654 58655 58656 58657
thanks

Kind regards,

T G-R

Sent on the go. Excuse or enjoy my brevity.
L
L
Ludovic Courtès wrote on 28 Nov 2022 22:48
(name . zamfofex)(address . zamfofex@twdb.moe)
87wn7e92e0.fsf_-_@gnu.org
Hi,

zamfofex <zamfofex@twdb.moe> skribis:

Toggle quote (2 lines)
> * gnu/packages/wm.scm (swc): New variable.

Finally applied with the changes below to address ‘guix lint’ warnings.

Thanks and apologies for the delay!

Ludo’.
Toggle diff (34 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f873101615..96b3c3a666 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2997,14 +2997,15 @@ (define-public swc
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/michaelforney/swc")
- (commit commit)))
+ (url "https://github.com/michaelforney/swc")
+ (commit commit)))
(sha256
- (base32
- "19rpbwpi81pm92fkhsmbx7pzagpah5m9ih5h5k3m8dy6r8ihdh35"))))
+ (base32
+ "19rpbwpi81pm92fkhsmbx7pzagpah5m9ih5h5k3m8dy6r8ihdh35"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no tests
+ `(#:tests? #f ;no tests
#:make-flags
(list (string-append "CC=" ,(cc-for-target))
(string-append "PREFIX=" %output))
@@ -3021,7 +3022,7 @@ (define-public swc
xcb-util-wm))
(native-inputs (list pkg-config))
(home-page "https://github.com/michaelforney/swc")
- (synopsis "A library for making a simple Wayland compositor")
+ (synopsis "Library for making a simple Wayland compositor")
(description "swc is a small Wayland compositor implemented as a library.
It has been designed primarily with tiling window managers in mind. Additionally,
Closed
?