[PATCH 0/3] add velox

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Tobias Geerinckx-Rice
  • zamfofex
Owner
unassigned
Submitted by
zamfofex
Severity
normal
Merged with
Z
Z
zamfofex wrote on 20 Oct 2022 14:25
(address . guix-patches@gnu.org)(name . zamfofex)(address . zamfofex@twdb.moe)
cover.1666268609.git.zamfofex@twdb.moe
I was planning to add only swc, but it seems velox was easy enough to add too.

zamfofex (3):
gnu: Add wld.
gnu: Add swc.
gnu: Add velox.

gnu/packages/wm.scm | 114 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 114 insertions(+)

--
2.38.0
T
T
Tobias Geerinckx-Rice wrote on 20 Oct 2022 14:36
(address . control@debbugs.gnu.org)
02B5C365-24F6-4928-8B98-60584610F9E0@tobias.gr
merge 58654 58655 58656 58657
thanks

Kind regards,

T G-R

Sent on the go. Excuse or enjoy my brevity.
L
L
Ludovic Courtès wrote on 28 Nov 2022 22:48
(name . zamfofex)(address . zamfofex@twdb.moe)
87wn7e92e0.fsf_-_@gnu.org
Hi,

zamfofex <zamfofex@twdb.moe> skribis:

Toggle quote (2 lines)
> * gnu/packages/wm.scm (swc): New variable.

Finally applied with the changes below to address ‘guix lint’ warnings.

Thanks and apologies for the delay!

Ludo’.
Toggle diff (34 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f873101615..96b3c3a666 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2997,14 +2997,15 @@ (define-public swc
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/michaelforney/swc")
- (commit commit)))
+ (url "https://github.com/michaelforney/swc")
+ (commit commit)))
(sha256
- (base32
- "19rpbwpi81pm92fkhsmbx7pzagpah5m9ih5h5k3m8dy6r8ihdh35"))))
+ (base32
+ "19rpbwpi81pm92fkhsmbx7pzagpah5m9ih5h5k3m8dy6r8ihdh35"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no tests
+ `(#:tests? #f ;no tests
#:make-flags
(list (string-append "CC=" ,(cc-for-target))
(string-append "PREFIX=" %output))
@@ -3021,7 +3022,7 @@ (define-public swc
xcb-util-wm))
(native-inputs (list pkg-config))
(home-page "https://github.com/michaelforney/swc")
- (synopsis "A library for making a simple Wayland compositor")
+ (synopsis "Library for making a simple Wayland compositor")
(description "swc is a small Wayland compositor implemented as a library.
It has been designed primarily with tiling window managers in mind. Additionally,
Closed
?