[PATCH 1/3] gnu: Add wld.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Tobias Geerinckx-Rice
  • zamfofex
Owner
unassigned
Submitted by
zamfofex
Severity
normal
Merged with
Z
Z
zamfofex wrote on 20 Oct 2022 14:25
(address . guix-patches@gnu.org)(name . zamfofex)(address . zamfofex@twdb.moe)
8313537a94bf69cc0b55f240d37cc53a2f499f18.1666268609.git.zamfofex@twdb.moe
* gnu/packages/wm.scm (wld): New variable.
---
gnu/packages/wm.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index af406ed2ed..94dfd28f4a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -58,6 +58,7 @@
;;; Copyright © 2022 Elais Player <elais@fastmail.com>
;;; Copyright © 2022 Trevor Richards <trev@trevdev.ca>
;;; Copyright © 2022 Fredrik Salomonsson <plattfot@posteo.net>
+;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2931,3 +2932,37 @@ (define-public grimshot
an interface over @code{grim}, @code{slurp} and @code{jq}, and supports storing
the screenshot either directly to the clipboard using @code{wl-copy} or to a
file.")))
+
+(define-public wld
+ (let ((commit "6586736176ef50a88025abae835e29a7ca980126")
+ (revision "1"))
+ (package
+ (name "wld")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/michaelforney/wld")
+ (commit commit)))
+ (sha256
+ (base32
+ "0qkd3q8p1s72x688g83fkcarrz2h20904rpd8z44ql6ksgrj9bp3"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs (list fontconfig
+ libdrm
+ pixman
+ wayland))
+ (propagated-inputs (list fontconfig pixman))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/michaelforney/wld")
+ (synopsis "A primitive drawing library targeted at Wayland")
+ (description "wld is a drawing library that targets Wayland.")
+ (license license:expat))))
--
2.38.0
T
T
Tobias Geerinckx-Rice wrote on 20 Oct 2022 14:36
(address . control@debbugs.gnu.org)
02B5C365-24F6-4928-8B98-60584610F9E0@tobias.gr
merge 58654 58655 58656 58657
thanks

Kind regards,

T G-R

Sent on the go. Excuse or enjoy my brevity.
L
L
Ludovic Courtès wrote on 18 Nov 2022 14:51
(name . zamfofex)(address . zamfofex@twdb.moe)(address . 58657-done@debbugs.gnu.org)
87zgcobcbm.fsf_-_@gnu.org
Hi,

zamfofex <zamfofex@twdb.moe> skribis:

Toggle quote (2 lines)
> * gnu/packages/wm.scm (wld): New variable.

I fixed issues reported by ‘guix lint’ and applied it.

Thanks,
Ludo’.
Closed
?