(address . guix-patches@gnu.org)(name . Ellis Kenyo)(address . me@elken.dev)
---
gnu/packages/package-management.scm | 32 +++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
Toggle diff (42 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 98af2187fa..845098aa10 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1479,3 +1479,35 @@ It is mainly meant for programmers who develop portable programs or libraries in
but could potentially work for end-users of those programs. It also has a translator
from R7RS, which allows most R7RS code to run on R6RS implementations.")
(license license:gpl3+)))
+
+(define-public yadm
+ (package
+ (name "yadm")
+ (version "3.0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/TheLocehiliosan/yadm")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "18lqy8hm1y1hkzmjpiwn1i29yk2hg7mrvyi0x5imvfxz3j4jj2qa"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f
+ #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (delete 'build))))
+ (synopsis "Yet Another Dotfile Manager")
+ (home-page "https://yadm.io")
+ (description "When you live in a command line, configurations are a deeply
+personal thing. They are often crafted over years of experience, battles lost,
+lessons learned, advice followed, and ingenuity rewarded. When you are away
+from your own configurations, you are an orphaned refugee in unfamiliar and
+hostile surroundings. You feel clumsy and out of sorts. You are filled with a
+sense of longing to be back in a place you know. A place you built. A place
+where all the short-cuts have been worn bare by your own travels. A place you
+proudly call… $HOME.")
+ (license license:gpl3)))
--
2.30.0