(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
Hi everyone,
I wrote a package to add meshlab but I'm not sure if I did it right:
- It doesn't have tests so I removed the testing.
- It fails to check RUNPATH, but I don't really know why so I disabled
it at the moment. It fails while searching for meshlab core libraries
but the search path is correct (it misses a /meshlab at the end).
Can you please check it and suggest a solution?
It works as it is but the runpath checks should pass...
Thanks!
Ekaitz
---
From d9020d7e64020dc7eea1bd46af184856d568ca7d Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Tue, 7 Apr 2020 18:56:06 +0200
Subject: [PATCH] gnu: Add meshlab
---
gnu/packages/engineering.scm | 39 ++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)
Toggle diff (47 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 5405db762c..85efc01c4c 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2491,3 +2491,42 @@ without any changes. And programmers that are familiar with the magellan API
can continue using it with a free library without the restrictions of the
official SDK.")
(license license:bsd-3)))
+
+(define-public meshlab
+ (let ((commit-ref "Meshlab-2020.04"))
+ (package
+ (name "meshlab")
+ (version commit-ref)
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cnr-isti-vclab/meshlab")
+ (commit commit-ref)
+ (recursive? #t)))
+ (sha256
+ (base32 "1vx9jcsnnxvzi90pcxpp7p72cqg3cm6jiivdmrxkzhr2fiz3pfvr"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("qtbase" ,qtbase)
+ ("qtscript" ,qtscript)
+ ("qtxmlpatterns" ,qtxmlpatterns)
+ ("mesa", mesa)
+ ("glu", glu)))
+ (arguments
+ `(#:tests? #f
+ #:validate-runpath? #f
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'go-to-source-dir
+ (lambda _ (chdir "src") #t)))))
+ (synopsis
+ "The open source system for processing and editing 3D triangular meshes.")
+ (home-page "http://www.meshlab.net/")
+ (description "MeshLab is an open source, portable, and extensible system
+for the processing and editing of unstructured large 3D triangular meshes. It
+is aimed to help the processing of the typical not-so-small unstructured models
+arising in 3D scanning, providing a set of tools for editing, cleaning,
+healing, inspecting, rendering and converting this kind of meshes. These tools
+include MeshLab proper, a versatile program with a graphical user interface,
+and meshlabserver, a program that can perform mesh
+processing tasks in batch mode, without a GUI.")
+ (license license:gpl3+))))
--
2.25.1