[PATCH] gnu: Add lib3ds.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ekaitz Zarraga
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ekaitz Zarraga
Severity
normal
E
E
Ekaitz Zarraga wrote on 15 May 2020 16:12
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
gNbjeEKOwFwMRSHcVk4-ZhNjpJN0HX28-TjO7m3jAGGF8cJR-UeCqBPk1PdWRypivx8zS9bZOX6V2SVRxRvp4CeQLFZCMvWhKgUwtNJxI3o=@elenq.tech
Hi,

Added lib3ds as discussed here:


I think everything is fine in the package but in building there are some messages about ldconfig not being available as we don't have it in guix. I checked that everything was installed correctly and it is but I'm not sure if that's going to have any other effect I didn't consider.

Thanks,
Ekaitz

From d295cb56c8ffa7df6a75ef9e97c6ba364d493405 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Fri, 15 May 2020 16:05:11 +0200
Subject: [PATCH] gnu: Add lib3ds.

* gnu/packages/engineering.scm (lib3ds): New variable.
---
gnu/packages/engineering.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 172f8481eb..5d0fca030a 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2533,3 +2533,26 @@ without any changes. And programmers that are familiar with the magellan API
can continue using it with a free library without the restrictions of the
official SDK.")
(license license:bsd-3)))
+
+(define-public lib3ds
+ (let ((version "1.3.0"))
+ (package
+ (name "lib3ds")
+ (version version)
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://storage.googleapis.com/google-code-archive-downloads"
+ "/v2/code.google.com/lib3ds/lib3ds-" version ".zip"))
+ (sha256
+ (base32 "1qr9arfdkjf7q11xhvxwzmhxqz3nhcjkyb8zzfjpz9jm54q0rc7m"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (home-page "http://lib3ds.sourceforge.net")
+ (synopsis "3DS format file toolkit")
+ (description "Lib3ds is a toolkit for handling the 3DS format for 3D
+model files. Its main goal is to simplify the creation of 3DS import and
+export filters.")
+ (license license:lgpl3+))))
--
2.26.1
L
L
Ludovic Courtès wrote on 16 May 2020 19:31
(name . Ekaitz Zarraga)(address . ekaitz@elenq.tech)(address . 41288-done@debbugs.gnu.org)
87367zrdls.fsf@gnu.org
Hi,

Ekaitz Zarraga <ekaitz@elenq.tech> skribis:

Toggle quote (6 lines)
> Added lib3ds as discussed here:
>
> https://issues.guix.gnu.org/40492
>
> I think everything is fine in the package but in building there are some messages about ldconfig not being available as we don't have it in guix. I checked that everything was installed correctly and it is but I'm not sure if that's going to have any other effect I didn't consider.

The ‘ldconfig’ messages from Libtool can be ignored; Guix doesn’t rely
on ‘ldconfig’.

Toggle quote (7 lines)
>>From d295cb56c8ffa7df6a75ef9e97c6ba364d493405 Mon Sep 17 00:00:00 2001
> From: Ekaitz Zarraga <ekaitz@elenq.tech>
> Date: Fri, 15 May 2020 16:05:11 +0200
> Subject: [PATCH] gnu: Add lib3ds.
>
> * gnu/packages/engineering.scm (lib3ds): New variable.

Applied with the changes below (the license is LGPLv2.1+ according to
source file headers; the home page change addresses a ‘guix lint’
warning).

Thanks,
Ludo’.
Toggle diff (28 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 9c66880e6f..37b42ca3f5 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2597,10 +2597,9 @@ accessible through a simple API")
(home-page "http://openctm.sourceforge.net/"))))
(define-public lib3ds
- (let ((version "1.3.0"))
(package
(name "lib3ds")
- (version version)
+ (version "1.3.0")
(source
(origin
(method url-fetch)
@@ -2612,9 +2611,9 @@ accessible through a simple API")
(build-system gnu-build-system)
(native-inputs
`(("unzip" ,unzip)))
- (home-page "http://lib3ds.sourceforge.net")
+ (home-page "https://code.google.com/archive/p/lib3ds")
(synopsis "3DS format file toolkit")
(description "Lib3ds is a toolkit for handling the 3DS format for 3D
model files. Its main goal is to simplify the creation of 3DS import and
export filters.")
- (license license:lgpl3+))))
+ (license license:lgpl2.1+)))
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 41288@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 41288
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch