[PATCH 0/2] Add s-exp support to Notmuch

  • Open
  • quality assurance status badge
Details
2 participants
  • Fabio Natali
  • Sergio Pastor Pérez
Owner
unassigned
Submitted by
Fabio Natali
Severity
normal
Merged with
F
F
Fabio Natali wrote on 15 Apr 09:19 +0200
(address . guix-patches@gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
cover.1713165432.git.me@fabionatali.com
Dear All,

On 2022-04-25?, support for S-expression-based queries was added to
Notmuch (version 0.36). This is based on a C/C++ library called sfsexp¹.

You can check whether your Notmuch was built with s-exp support with
this command²:

,----
| notmuch config get built_with.sexp_queries
`----

The Notmuch version currently packaged in Guix does not support s-exp
queries.

This patch micro-series is to:

- Add sfsexp¹.
- Update Notmuch to make use of sfsexp and to allow S-expression-based queries.

Thanks, best wishes, Fabio.




Fabio Natali (2):
gnu: Add sfsexp.
gnu: notmuch: Add sfsexp dependency.

gnu/packages/c.scm | 22 ++++++++++++++++++++++
gnu/packages/mail.scm | 4 +++-
2 files changed, 25 insertions(+), 1 deletion(-)


base-commit: e5dda412c2e28fb65a549824f492895e72c33813
--
2.41.0
F
F
Fabio Natali wrote on 15 Apr 09:25 +0200
[PATCH 1/2] gnu: Add sfsexp.
(address . 70390@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
139fa7564dab7c3088632370512fcb0d0896da33.1713165432.git.me@fabionatali.com
* gnu/packages/c.scm (sfsexp): New variable.

Change-Id: Iabfbe10b4ad6134ae886a3d26487f881107b559c
---
gnu/packages/c.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index c004aade73..ef8f9e473b 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -628,6 +628,28 @@ (define-public packcc
any other grammar rules.")
(license license:expat)))
+(define-public sfsexp
+ (package
+ (name "sfsexp")
+ (version "1.4.1")
+ (home-page "https://github.com/mjsottile/sfsexp")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03srnpc7p1j7ygd0wx9gybcxhqm50kjzkybh1xs75nwz97q3y2dq"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake libtool))
+ (synopsis "Symbolic expression library for C and C++")
+ (description
+ "sfsexp is a C/C++ library for the manipulation (read, parse, modify, and create)
+of symbolic expressions.")
+ (license license:lgpl2.1+)))
+
(define-public sparse
(package
(name "sparse")
--
2.41.0
F
F
Fabio Natali wrote on 15 Apr 09:25 +0200
[PATCH 2/2] gnu: notmuch: Add sfsexp dependency.
(address . 70390@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
5460899548ef69b6c0591be8579faa151090834e.1713165432.git.me@fabionatali.com
sfsexp is a C/C++ library for the manipulation (read, parse, modify, and create)
of symbolic expressions. In an environment where sfsexp is available, Notmuch
will compile with support for a S-expression-based query format. This commit is
to add sfsexp as a Notmuch dependency and therefore to add S-exp support.

Change-Id: Ic3b4a30b2672ad690d66b283e9bdc8e2197f97a7
---
gnu/packages/mail.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index e0fbd0a5ff..2b5561f706 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -81,6 +81,7 @@ (define-module (gnu packages mail)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages c)
#:use-module (gnu packages calendar)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -1414,6 +1415,7 @@ (define-public notmuch
(("/bin/sh") sh))))))))
(native-inputs
(list bash-completion
+ git
pkg-config
python
python-docutils
@@ -1427,7 +1429,7 @@ (define-public notmuch
man-db
perl))
(inputs
- (list glib gmime talloc xapian zlib))
+ (list glib gmime sfsexp talloc xapian zlib))
(home-page "https://notmuchmail.org/")
(synopsis "Thread-based email index, search, and tagging")
(description
--
2.41.0
S
S
Sergio Pastor Pérez wrote on 15 Apr 20:55 +0200
Merging bugs 66547 - 70390
(address . control@debbugs.gnu.org)
PAXP251MB034878097D44A26929796FB1F3092@PAXP251MB0348.EURP251.PROD.OUTLOOK.COM
user guix
merge 66547 70390
quit
?