[PATCH python-team 0/4] Use git-minimal/pinned for some Python packages

  • Open
  • quality assurance status badge
Details
2 participants
  • Lars-Dominik Braun
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
C
C
Christopher Baines wrote on 29 Apr 22:38 +0200
(address . guix-patches@gnu.org)
874jbjzyz8.fsf@cbaines.net
This reduces the direct dependencies on git, making it easier to update.

Christopher Baines (4):
gnu: python-gitpython: Use git-minimal/pinned.
gnu: python-gitdb: Use git-minimal/pinned.
gnu: python-pbr: Use git-minimal/pinned.
gnu: python-versioneer: Use git-minimal/pinned.

gnu/packages/python-xyz.scm | 4 ++--
gnu/packages/version-control.scm | 6 +++---
2 files changed, 5 insertions(+), 5 deletions(-)


base-commit: 3bd8d238aba718bf949691d0e37fa310e2cfc12a
--
2.41.0
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmYwBStfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfapQ/+N9NDWzkwnHxlW6w8MrpJpXeNoMxeLZID
ivSISd+bqR6K3VhQxoBjkiPs3zL6yvVAD7AnwHg/YDJQAnOxWcOy+nZe+zcxSCp4
HicMaz7hu+JfMJu1dZ8Q51QFNyhPVnOPDkDxE/s7pcd0CGfjxt0hL2kx52AKjc08
kiG1zb8cfrpKgCLHLFzOLNv6WS6/12r2wVqjVkHT8b162f1cZFHvhAT+1rIj7u/E
9GD6idMo1r/lD88oVpAiCmdDzrgRVu5MQuVUfypFVrv5YUxAKt/D1k0zfrtRl28R
pFZExRQfodHsfeOSQMyY6eFDfsl2jJcv7920Yos4mZlxao/mGHYhLFc0vvAjgFS9
31+qhbVG46xqYfu8bA143H/ArM/T/TsBsUkA72gtlT4XnPghaQtTaZClEFowBnzW
+4r9K6/dL2THSxoPNYA/GsZNXHNore3Pks7yjzV/iG/Y1c7JxW2Jfotxm5brSO5t
lhjWttNNtipkD7NcI6cD925FDMjMBZuMnkxpMWVMaexssmefqBFV+OuvOtwAXCtH
Eu6/4DX0vXDBN5M1y5EhUH6ZlFSAxSq0zfloXj1Pbw0VfIvMf8EFBer+jsogvapL
B8fyOnDbUvS8qXeRyFagFy+BPzYrMD5H1Nsci3CjLEB7frm1Vns17LW3qNtT0SP9
JezKvW1iGa4=
=FnWJ
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 29 Apr 22:40 +0200
[PATCH python-team 2/4] gnu: python-gitdb: Use git-minimal/pinned.
(address . 70656@debbugs.gnu.org)
1e94adf0d02344c5c7247f7b5e71ed0bce25beaa.1714423249.git.mail@cbaines.net
This helps reduce the dependencies on git, as I think it's find to build with
a slightly older git, at least during periods when git-minimal/pinned needs
updating.

* gnu/packages/version-control.scm (python-gitdb)[native-inputs]: Use
git-minimal/pinned.

Change-Id: Ib9e65383d18a234567a36824ad3e08dc21eff200
---
gnu/packages/version-control.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index c340d5fdc8..c2ff4040fb 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1409,7 +1409,7 @@ (define-public python-gitdb
(propagated-inputs
(list python-smmap))
(native-inputs
- (list git python-nose))
+ (list git-minimal/pinned python-nose))
(home-page "https://github.com/gitpython-developers/gitdb")
(synopsis "Python implementation of the Git object database")
(description
--
2.41.0
C
C
Christopher Baines wrote on 29 Apr 22:40 +0200
[PATCH python-team 3/4] gnu: python-pbr: Use git-minimal/pinned.
(address . 70656@debbugs.gnu.org)
6fa03e8699d230e078f4e40c22cd637b3c18f768.1714423249.git.mail@cbaines.net
This helps reduce the dependencies on git, as I think it's find to build with
a slightly older git, at least during periods when git-minimal/pinned needs
updating.

* gnu/packages/version-control.scm (python-pbr)[propagated-inputs]: Use
git-minimal/pinned.

Change-Id: Ib90056a1a603e06a99b5c601f9fcba7375dc24ac
---
gnu/packages/python-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f22b891ba5..16b47d0aa7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5128,7 +5128,7 @@ (define-public python-pbr
(arguments
`(#:tests? #f)) ;; Most tests seem to use the Internet.
(propagated-inputs
- (list git)) ;; pbr actually uses the "git" binary.
+ (list git-minimal/pinned)) ;; pbr actually uses the "git" binary.
(native-inputs
`(("python-fixtures" ,python-fixtures-bootstrap)
;; discover, coverage, hacking, subunit
--
2.41.0
C
C
Christopher Baines wrote on 29 Apr 22:40 +0200
[PATCH python-team 4/4] gnu: python-versioneer: Use git-minimal/pinned.
(address . 70656@debbugs.gnu.org)
96befd0df7df11d0e5750bd3408e58db13e6c10e.1714423249.git.mail@cbaines.net
This helps reduce the dependencies on git, as I think it's find to build with
a slightly older git, at least during periods when git-minimal/pinned needs
updating.

* gnu/packages/version-control.scm (python-versioneer)[propagated-inputs]: Use
git-minimal/pinned.

Change-Id: Id537baa8228afeb3b84161ecb5fea0d131b45442
---
gnu/packages/python-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 16b47d0aa7..b5a2197a0a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31915,7 +31915,7 @@ (define-public python-versioneer
(invoke "pycodestyle" "--max-line-length=88"
"git_version.py" "versioneer.py")))))))
(native-inputs
- (list git python-flake8 python-pycodestyle python-pyflakes))
+ (list git-minimal/pinned python-flake8 python-pycodestyle python-pyflakes))
(propagated-inputs
(list python-tomli))
(home-page "https://github.com/python-versioneer/python-versioneer")
--
2.41.0
C
C
Christopher Baines wrote on 29 Apr 22:40 +0200
[PATCH python-team 1/4] gnu: python-gitpython: Use git-minimal/pinned.
(address . 70656@debbugs.gnu.org)
a548240971d5fcb99df6d78438c6ba46bb644677.1714423249.git.mail@cbaines.net
This helps reduce the dependencies on git, as I think it's find to build with
a slightly older git, at least during periods when git-minimal/pinned needs
updating.

* gnu/packages/version-control.scm (python-gitpython)[arguments,inputs]: Use
git-minimal/pinned.

Change-Id: Id4325fe58a62bafce58b74828fa5823621166c55
---
gnu/packages/version-control.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 0c7c496c82..c340d5fdc8 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1438,10 +1438,10 @@ (define-public python-gitpython
(substitute* "git/cmd.py"
(("git_exec_name = \"git\"")
(string-append "git_exec_name = \""
- (assoc-ref inputs "git")
+ (assoc-ref inputs "git-minimal")
"/bin/git\""))))))))
(inputs
- (list git))
+ (list git-minimal/pinned))
(propagated-inputs
(list python-gitdb python-typing-extensions))
(native-inputs

base-commit: 3bd8d238aba718bf949691d0e37fa310e2cfc12a
--
2.41.0
L
L
Lars-Dominik Braun wrote on 4 May 10:12 +0200
Re: [bug#70656] [PATCH python-team 3/4] gnu: python-pbr: Use git-minimal/pinned.
(name . Christopher Baines)(address . mail@cbaines.net)
ZjXt9fEFOjnlRgBP@noor.fritz.box
Hi,

Toggle quote (4 lines)
> This helps reduce the dependencies on git, as I think it's find to build with
> a slightly older git, at least during periods when git-minimal/pinned needs
> updating.

this one is used on the repository cloned during build. As far as I see
we use git-minimal for cloning. Do we know whether the on-disk structures
of git are stable, i.e. can a clone of git version A be read by a git
version B with B < A?

Lars
?