[PATCH 0/2] Update `notmuch' package to support sexp queries

  • Open
  • quality assurance status badge
Details
2 participants
  • Sergio Pastor Pérez
  • Wicki Gabriel (wicg)
Owner
unassigned
Submitted by
Sergio Pastor Pérez
Severity
normal
Merged with
S
S
Sergio Pastor Pérez wrote on 14 Oct 2023 21:19
(address . guix-patches@gnu.org)(name . Sergio Pastor Pérez)(address . sergio.pastorperez@outlook.es)
DU2P193MB2132BEC7B617017B6DD7FC2CF3D1A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
This opens a patch series containing the `sfsexp' package required by
`notmuch' to compile with support for sexp queries. The other patch modifies
the `notmuch' package to include the `sfsexp' library as a native input so its
path is picked up by the build system.

Sergio Pastor Pérez (2):
gnu: Add sfsexp.
gnu: notmuch: Update to support sexp queries.

gnu/packages/c.scm | 23 +++++++++++++++++++++++
gnu/packages/mail.scm | 5 ++++-
2 files changed, 27 insertions(+), 1 deletion(-)


base-commit: 3d0cdf963820da665d71987c15cae6e503efc701
--
2.41.0
S
S
Sergio Pastor Pérez wrote on 14 Oct 2023 21:28
[PATCH 1/2] gnu: Add sfsexp.
(address . 66547@debbugs.gnu.org)(name . Sergio Pastor Pérez)(address . sergio.pastorperez@outlook.es)
DU2P193MB2132717D8F22956768A4A155F3D1A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
* gnu/packages/c.scm (sfsexp): New variable.
---
gnu/packages/c.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index ea58c68262..0a63b81188 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -571,6 +571,29 @@ (define-public libwuya
;; clarified (see: https://github.com/WuBingzheng/libwuya/issues/2).
(license license:gpl2+))))
+(define-public sfsexp
+ (package
+ (name "sfsexp")
+ (version "1.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mjsottile/sfsexp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03srnpc7p1j7ygd0wx9gybcxhqm50kjzkybh1xs75nwz97q3y2dq"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake libtool))
+ (home-page "https://github.com/mjsottile/sfsexp")
+ (synopsis "Small Fast S-Expression Library")
+ (description
+ "Sfsexp provides an interface to manipulate (read, parse, modify, and
+create) symbolic expressions from C or C++ programs. A symbolic expression,
+or s-expression, is essentially a LISP-like expression such as (a (b c)).")
+ (license license:gpl2)))
+
(define-public packcc
(package
(name "packcc")
--
2.41.0
S
S
Sergio Pastor Pérez wrote on 14 Oct 2023 21:28
[PATCH 2/2] gnu: notmuch: Update to support sexp queries.
(address . 66547@debbugs.gnu.org)(name . Sergio Pastor Pérez)(address . sergio.pastorperez@outlook.es)
DU2P193MB2132471F4137BA1813230727F3D1A@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
* gnu/packages/mail.scm (notmuch): Update to support sexp queries.
---
gnu/packages/mail.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index be458a2d92..f330b1d8a2 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -80,6 +80,7 @@ (define-module (gnu packages mail)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages c)
#:use-module (gnu packages calendar)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -1403,13 +1404,15 @@ (define-public notmuch
python-docutils
python-sphinx
texinfo
+ sfsexp ; required to support sexp queries
;; The following are required for tests only.
emacs-no-x ; -minimal lacks libxml, needed for some tests
which
dtach
gnupg
man-db
- perl))
+ perl
+ git)) ; required by the sexp query tests
(inputs
(list glib gmime talloc xapian zlib))
(home-page "https://notmuchmail.org/")
--
2.41.0
W
W
Wicki Gabriel (wicg) wrote on 8 Dec 2023 12:10
Review
(name . 66547@debbugs.gnu.org)(address . 66547@debbugs.gnu.org)
ZR0P278MB02687579D86DFF3614EE9DF1C18AA@ZR0P278MB0268.CHEP278.PROD.OUTLOOK.COM
Thanks for your patches! They look good to me, except for the fact that you state "GPL 2" as the license even though in the repo they say LGPL2.1 (or is it LGPL2.1+).

Please send us a corrected version of your patches.
Attachment: file
S
S
Sergio Pastor Pérez wrote on 8 Dec 2023 16:50
[PATCH v2] gnu: Add sfsexp.
(address . 66547@debbugs.gnu.org)(name . Sergio Pastor Pérez)(address . sergio.pastorperez@outlook.es)
DU2P193MB21329E76F387C9D40AE2F969F38AA@DU2P193MB2132.EURP193.PROD.OUTLOOK.COM
* gnu/packages/c.scm (sfsexp): New variable.
---
Corrected license.

gnu/packages/c.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index ac83336ba5..29b89c5cb1 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -572,6 +572,29 @@ (define-public libwuya
;; clarified (see: https://github.com/WuBingzheng/libwuya/issues/2).
(license license:gpl2+))))
+(define-public sfsexp
+ (package
+ (name "sfsexp")
+ (version "1.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mjsottile/sfsexp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03srnpc7p1j7ygd0wx9gybcxhqm50kjzkybh1xs75nwz97q3y2dq"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake libtool))
+ (home-page "https://github.com/mjsottile/sfsexp")
+ (synopsis "Small Fast S-Expression Library")
+ (description
+ "Sfsexp provides an interface to manipulate (read, parse, modify, and
+create) symbolic expressions from C or C++ programs. A symbolic expression,
+or s-expression, is essentially a LISP-like expression such as (a (b c)).")
+ (license license:lgpl2)))
+
(define-public packcc
(package
(name "packcc")

base-commit: 06f25a9a85be1bbe7a709e58ce41c1a834e5f1ae
--
2.41.0
S
S
Sergio Pastor Pérez wrote on 15 Apr 20:55 +0200
Merging bugs 66547 - 70390
(address . control@debbugs.gnu.org)
PAXP251MB034878097D44A26929796FB1F3092@PAXP251MB0348.EURP251.PROD.OUTLOOK.COM
user guix
merge 66547 70390
quit
?