[PATCH] gnu: Add go-github-com-gregjones-httpcache.

  • Done
  • quality assurance status badge
Details
2 participants
  • Artyom V. Poptsov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 1 years ago
(address . guix-patches@gnu.org)
87zfx5t21j.fsf@gmail.com
Hello,

this patch adds "go-github-com-gregjones-httpcache".
From 1f9c6c060e528df83b0f0dc2e816828da130d3af Mon Sep 17 00:00:00 2001
Message-ID: <1f9c6c060e528df83b0f0dc2e816828da130d3af.1705439507.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Wed, 17 Jan 2024 00:07:42 +0300
Subject: [PATCH] gnu: Add go-github-com-gregjones-httpcache.

* gnu/packages/golang-web.scm (go-github-com-gregjones-httpcache): New
variable.

Change-Id: I2ba0196fd1de63f26a814dc96ff64a6fb5379043
---
gnu/packages/golang-web.scm | 30 +++++++++++++++++++++++++++++-
1 file changed, 29 insertions(+), 1 deletion(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 3e60bfaf33..fd9384d060 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -21,7 +21,7 @@
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
-;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -868,6 +868,34 @@ (define-public go-github-com-gorilla-websocket
protocol.")
(license license:bsd-2)))
+(define-public go-github-com-gregjones-httpcache
+ (let ((commit "901d90724c7919163f472a9812253fb26761123d")
+ (revision "0"))
+ (package
+ (name "go-github-com-gregjones-httpcache")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gregjones/httpcache")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05r0xq51vfb55di11m7iv19341d73f7in33vq1ihcqs1nffdwiq0"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/gregjones/httpcache"))
+ (synopsis "Transport for @code{http.Client} that will cache responses")
+ (description
+ "Package @code{httpcache} provides a @code{http.RoundTripper}
+implementation that works as a mostly @url{https://tools.ietf.org/html/rfc7234, RFC
+7234} compliant cache for HTTP responses. It is only suitable for use as a
+\"private\" cache (i.e. for a web-browser or an API-client and not for a shared
+proxy).")
+ (home-page "https://github.com/gregjones/httpcache")
+ (license license:expat))))
+
(define-public go-github-com-hjson-hjson-go
(package
(name "go-github-com-hjson-hjson-go")

base-commit: 171ac4fa4f5e5dd2f2e110487de5d41b5b79a564
--
2.41.0
- avp

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQJNBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmWm8WgZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFfsRtD/0VM2eJnIgvgQHBXBdLCQlN
ToLEBCOjzwBE8G/e4rSzXSwSY5W5JSDatsipdSQa3/jtM+JfP7xk68K8EBH5Hc7T
3pO4jpd7qtu38vz6riC+xGLFK13yI0550vxwdJDShcw7R5W1CQ/oINSwrKbHmCwQ
nSwbPSbRmhw3FXih3yTqvXitDeaAQFs91gz1o815Y6Sg6nwpqeakKpFEfys19K0b
Hbzg3JA2juwrkwaCgT6zaSo9Vol8+CBsrXNMt83aaWz0O7peXPlQJY19QPeQfeh2
lKdle06Fabi699iqW4lE0nBKiJnZGLoXPcjFx71gvcUqBGIqt4dPGT+svF4G27QJ
fFoRpUNVmh5oQiphFS7jCoHVyCk0+kWoP6hZhssiV0QuyGN7agmZpW+98t/LTcsh
zLP++HF05s93T0ylivjEdXd/5ut7sl1AXrpmopZze+1oEnEZuOH+xvILx+8iFw7u
AlWYvsOn41jGnqHZYd98PS6yjBtT657QbTePkOKwbU3i/Mx6UqrOpXzQRH3U/K38
aj++1DVdLIAiL3r9M+jlJjhl0qMkv5+0Yj5H14CrtuOjSCGycg6vZ41AKHZt2QtR
1rzUARSfUOh4Glu1V36rTXJbJexMXAqaOUwfy5qraz6KX+spEdJuQheYNCZ0keac
izkuKJPsN9yktLIs6TVRkQ==
=virP
-----END PGP SIGNATURE-----

Sharlatan Hellseher wrote 1 years ago
(address . 68518@debbugs.gnu.org)
CAO+9K5p7xKOEe5MHm72yNKxwrjp_TNsLcWj8=GBsmGS_Gb0gmw@mail.gmail.com
Hi,

This project is archived and read-only on GitGub. Is it required for
some other package to be updated?

Thanks,
Oleg
Attachment: file
Artyom V. Poptsov wrote 1 years ago
(address . guix-patches@gnu.org)
87zfwkge3s.fsf@gmail.com
Hello,

I have some troubles with receiving some emails on my Gmail account from
debbugs recently, but I've got response on the patch from Sharlatan
Hellseher:

Toggle quote (8 lines)
> Hi,
>
> This project is archived and read-only on GitGub. Is it required for
> some other package to be updated?
>
> Thanks,
> Oleg

Thanks for reviewing my patch! Yes, the project is archived by its
author, but in the "README" you can read[1] the following statement:

Toggle snippet (7 lines)
This project isn't actively maintained; it works for what I, and
seemingly others, want to do with it, and I consider it "done". That
said, if you find any issues, please open a Pull Request and I will try
to review it. Any changes now that change the public API won't be
considered.

The graph[2] of the dependents for "httpcache" is quite big; it lists
some popular packages including[3] "Chezmoi" package.

So in my opinion it is worthwhile to package "httpcache" as it will help
to package/update the future packages.

Thanks,
- avp

References:

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQJNBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmW79ZcZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFftHQEACC+eXmBHItEV/E/z5kQIoR
F2Ozbot3dLexCk8KrpUvgVHcRaTS6PX1vBseCcZOjBL+86Ww9FI1iDE9aDjLFgxQ
4BC+D8/W+NOZ2DEoNXgrzyqTRH2WHJLUltNpbFzdbQdGfrspI04YzeRGOlhSt4hL
P7uWC3PLjCo3mlIhneKnvJ7FmnNvarzz5HhpI/lA8xVror2xLSnLY5a84DXAFxtD
ZhCZo0WcMbyWnPuG4G09FUWUkcp83llKoXJA5sqqjB4cXhGR8MDlUKdvRoThSTt2
rCDz4lNAFOGBJjYW045Wyj5iu0htQ22AtoJRAIbrMyDtbVx1KMmCxJ6DSkO7pP5c
ArVGJ4D5FHQfCWPOVzrFyWQcmpkHynjyodhh//Bc4DSRbAa7keXB34gwD4oRmLLp
8UQlpXAReed6gWte5Eh7uGF4scMtCh5mUbEcNgf8ifvnTQ4RDizuDAY9MGBP4pAF
6SA6vG3TPdoSJjmR1RTeWmEffrWTB4IYI756lI0j8RzyB7onSjDqG7XKgTQy0HJb
MRZ0NuEAdyNuEq2qoTEVxPn/RNpJCbJ/mdAzC3pAOb++eOFZBiKoDtCifj1REmCE
krnZVjtHR7WAolay9/UIaP7o7lLfh2zG96aalYH4xz60U8wSCel7y7dr9VvzTkcM
p3G5uOSQQo8Rwd9L3by4oA==
=ug/9
-----END PGP SIGNATURE-----

Sharlatan Hellseher wrote 1 years ago
[PATCH] gnu: Add go-github-com-gregjones-httpcache.
(address . 68518-done@debbugs.gnu.org)
87o7cy94wc.fsf@gmail.com
Hi,

The Chezmoi package is broken for a long time thank you for attempt to
update and fix it!

Placing some findings related to Chezmoi issue which are still not
touched.

- https://issues.guix.gnu.org/50037Aug 2021 [PATCH 1/2] gnu:
go-github-com-zalando-go-keyring: Update to 0.1.1.
- https://issues.guix.gnu.org/50035Aug 2021 [PATCH 1/3] gnu:
go-github-com-godbus-dbus: Update to 5.0.4.

Pushed as 34e8a40dadc1169d4810fa5111a9eaaadedeb66f to master.

Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmW9H/QACgkQdtcnv/Ys
0rWNuw/8DXc0jIXzo8WCFLyniUEhCXGnhfL6zZhl4BFIM377NbJM5FUhD+v2KeBe
E7oVuzA/R0VX3ZqdZrRdqc+ZkdTOrE2aqZEJNHWDIENb0SLc7ZN4Jel4upnELYTh
Dip7wdkyA9v2gnFopgi/BmBC7E0ofv+qmKo6BRLoGUIHqWNMynQ+WvAcW18Qxb4A
kXEZ8wdjsY4hJpzJBToxWyK84st0TEjg0M7n0crJarGtOVf2NdtlVKdJ7BuBkKm6
nI+kRqJqD958CQ44YaiEoU8z8LFlXArBdfXNzER7tdCDOhjvGDVx6ft/0Hq6EjKd
9cDRHYgPG0+IlJfE/MCG2Xaq9dgeZctNQT1WR8PTrG8BOndcEaScPmghpw/DwiNu
nxJqvRO5479M44HgMLMiB5+PQEEKdlpZBbtQnr8Q6dstZ/5q90Ijm4G5tY+8dDmd
cStG1u84Dd1KmEs0NiZY8KBMhoQHbAIvSpUNDCfcse2Y+n0IVVRnR9YjgbH5E9G/
I5DI/eey3PkIZnNeDlXD6XU8mdQyIgfJGg1WKtxb1VbJBBJysHX2lpIrz6y0TJkB
00nJw7uwncaYlf9HAyH7Q1f/Xbp3Q1X3WVRQ19ve6iX0zVadfXEPwBq2DcMff8GU
RGEIQv8loODt9sA3rJz8UFYxYjIdIrBk5v0bJYAybV5DwjKbFko=
=Mfyh
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 68518@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 68518
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help