[PATCH 1/2] gnu: go-github-com-zalando-go-keyring: Update to 0.1.1.

  • Open
  • quality assurance status badge
Details
One participant
  • Sarah Morgensen
Owner
unassigned
Submitted by
Sarah Morgensen
Severity
normal
S
S
Sarah Morgensen wrote on 13 Aug 2021 05:48
(address . guix-patches@gnu.org)
24ab383829c10cf04feb1eac68c428316ad8b88b.1628826367.git.iskarian@mgsn.dev
The import path for godbus-dbus-v5 changed, so update it with the
corresponding update for its only dependent. (Chezmoi only depends on
godbus-dbus-v5 through this package.)

* gnu/packages/golang.scm (go-github-com-zalando-go-keyring): Update to
0.1.1.
(go-github-com-godbus-dbus-v5)[arguments]: Use correct import-path.
---
This depends on the go-github-com-godbus-dbus -> go-github-com-godbus-dbus-v5
rename in #50035. I didn't want to hide this update in the patchset, though.
I've also propagated an input that should have been.

--
Sarah
gnu/packages/golang.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 28ead635f2..3722e48552 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7445,7 +7445,7 @@ and @code{ioutil} packages that is easy to test.")
"0znax8kskb5gmp5fj75w56bc9p7b22wrdswzlh4d04sprlc471yi"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/godbus/dbus"
+ `(#:import-path "github.com/godbus/dbus/v5"
#:phases
(modify-phases %standard-phases
(replace 'check
@@ -7463,7 +7463,7 @@ bindings for the D-Bus message bus system.")
(define-public go-github-com-zalando-go-keyring
(package
(name "go-github-com-zalando-go-keyring")
- (version "0.1.0")
+ (version "0.1.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7472,7 +7472,7 @@ bindings for the D-Bus message bus system.")
(file-name (git-file-name name version))
(sha256
(base32
- "0kj54nkiyccy6m9iy9a53f6412a54xk96j88jaiq35yzdgfa4z3p"))))
+ "1wqv6d5b3bc7ymkarp761ivbq71q5a6cc9a27dk3gf772k9in0jf"))))
(build-system go-build-system)
(arguments
`(#:tests? #f ;XXX: Fix dbus tests

base-commit: d87d6d68128c53a95fe09c3a4381575646c0f368
prerequisite-patch-id: 1f54f3d65c26fb7f2f39078e074b863fa65cc6cb
prerequisite-patch-id: ea7dd7cdb43fc04fa7b2962cd3b4687b67c2ae6d
prerequisite-patch-id: d30707c981be14dacef30da2b4994ce64e174ac6
--
2.31.1
S
S
Sarah Morgensen wrote on 13 Aug 2021 06:01
[PATCH 2/2] gnu: go-github-com-zalando-go-keyring: Fix inputs.
(address . 50037@debbugs.gnu.org)
29e8a41b121d1067a4a7eee7f746dd45f5a8cd91.1628826367.git.iskarian@mgsn.dev
Go source inputs should be propagated in non-end-user packages.

* gnu/packages/golang.scm (go-github-com-zalando-go-keyring)
[native-inputs]: Move go-github-com-godbus-dbus-v5 to...
[propagated-inputs]: ...here.
* gnu/packages/configuration-management.scm (chezmoi)[native-inputs]:
Remove unnecessary go-github-com-godbus-dbus-v5.
---
gnu/packages/configuration-management.scm | 1 -
gnu/packages/golang.scm | 5 +++--
2 files changed, 3 insertions(+), 3 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/configuration-management.scm b/gnu/packages/configuration-management.scm
index 8b4ba2b71e..742bc3505d 100644
--- a/gnu/packages/configuration-management.scm
+++ b/gnu/packages/configuration-management.scm
@@ -91,7 +91,6 @@
("go-github-com-twpayne-go-xdg" ,go-github-com-twpayne-go-xdg)
("go-github-com-yuin-goldmark" ,go-github-com-yuin-goldmark)
("go-github-com-zalando-go-keyring" ,go-github-com-zalando-go-keyring)
- ("go-github-com-godbus-dbus-v5" ,go-github-com-godbus-dbus-v5)
("go-etcd-io-bbolt" ,go-etcd-io-bbolt)
("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
("go-golang-org-x-net" ,go-golang-org-x-net)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3722e48552..f8060ccacf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7477,9 +7477,10 @@ bindings for the D-Bus message bus system.")
(arguments
`(#:tests? #f ;XXX: Fix dbus tests
#:import-path "github.com/zalando/go-keyring"))
+ (propagated-inputs
+ `(("go-github-com-godbus-dbus-v5" ,go-github-com-godbus-dbus-v5)))
(native-inputs
- `(("go-github-com-godbus-dbus-v5" ,go-github-com-godbus-dbus-v5)
- ("dbus" ,dbus)))
+ `(("dbus" ,dbus)))
(home-page "https://github.com/zalando/go-keyring/")
(synopsis "Library for working with system keyring")
(description "@code{go-keyring} is a library for setting, getting and
--
2.31.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 50037@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50037
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch