[PATCH] gnu: Add r-metacell.

  • Done
  • quality assurance status badge
Details
2 participants
  • Afkhami, Navid
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Afkhami, Navid
Severity
normal
Merged with

Debbugs page

Afkhami, Navid wrote 1 years ago
(address . guix-patches@gnu.org)(name . Afkhami, Navid)(address . Navid.Afkhami@mdc-berlin.de)
5cf244a75edf748f180e87b4607a67126260115f.1697213683.git.Navid.Afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-metacell): New variable.
---
gnu/packages/bioinformatics.scm | 60 +++++++++++++++++++++++++++++++++
1 file changed, 60 insertions(+)

Toggle diff (80 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index cb0bdf766e..45afde699d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10285,6 +10285,66 @@ (define-public r-markdownreports
discovered.")
(license license:gpl3))))
+(define-public r-metacell
+ (let ((commit "d6a6926d103ee0cb34a611c753572429c94a53d9")
+ (revision "1"))
+ (package
+ (name "r-metacell")
+ (version (git-version "0.3.41" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tanaylab/metacell/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zrsckr3y35x37mj3ibm6scyqx925s84wzrz1i42fnm9n3msc265"))))
+ (properties `((upstream-name . "metacell")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-cluster
+ r-cowplot
+ r-data-table
+ r-dbscan
+ r-domc
+ r-dplyr
+ r-entropy
+ r-ggplot2
+ r-graph
+ r-igraph
+ r-kernsmooth
+ r-magrittr
+ r-matrix
+ r-matrixstats
+ r-pdist
+ r-pheatmap
+ r-plyr
+ r-rcolorbrewer
+ r-rcurl
+ r-rgraphviz
+ r-slam
+ r-singlecellexperiment
+ r-svglite
+ r-tgconfig
+ r-tgstat
+ r-tgutil
+ r-tidyr
+ r-umap
+ r-umap
+ r-zoo))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/tanaylab/metacell/")
+ (synopsis "Meta cell analysis for single cell RNA-seq data")
+ (description
+ "This package facilitates the analysis of single-cell RNA-seq UMI matrices.
+It does this by computing partitions of a cell similarity graph into
+small homogeneous groups of cells, which are defined as metacells (MCs).
+The derived MCs are then used for building different representations of
+the data, allowing matrix or 2D graph visualization forming a basis for
+analysis of cell types, subtypes, transcriptional gradients,cell-cycle
+variation, gene modules and their regulatory models and more.")
+ (license license:expat))))
+
(define-public r-snapatac
(package
(name "r-snapatac")

base-commit: dcfd4d9c4827ca6bfebeec46fe6bb8373c425a1c
prerequisite-patch-id: 8b3f1b30e7ca1f6ddb21bf801faad91cce276dfd
prerequisite-patch-id: 86f04eb38885c80e1fa302cec734581778e62c26
prerequisite-patch-id: d5cebe9646097c611915c8b796a94ff0d1831343
prerequisite-patch-id: 675ed63512dcf5b145a929d0097b1bb7e7f1c389
prerequisite-patch-id: 8a7046dfe2c6c18892fed37a877f66be5be7f96e
--
2.34.1
Ricardo Wurmus wrote 1 years ago
(address . control@debbugs.gnu.org)
87r0ltjuqb.fsf@elephly.net
merge 66524 66526 66527 66528 66529 66530

--
Ricardo
Ricardo Wurmus wrote 1 years ago
(address . 66530-done@debbugs.gnu.org)
87mswhjumh.fsf@elephly.net
Thanks for the patches. I applied them after some massaging.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66530@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66530
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help