[PATCH] gnu: r-tgconfig: Update to (git-version 0.1.2 revision commit).

  • Done
  • quality assurance status badge
Details
2 participants
  • Afkhami, Navid
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Afkhami, Navid
Severity
normal
Merged with

Debbugs page

Afkhami, Navid wrote 1 years ago
(address . guix-patches@gnu.org)(name . Afkhami, Navid)(address . Navid.Afkhami@mdc-berlin.de)
eb791415d7e47ac044cdb9cb9afc88beed635c71.1697212310.git.Navid.Afkhami@mdc-berlin.de
* gnu/packages/statistics.scm (r-tgconfig): Update to (git-version 0.1.2 revision commit).
---
gnu/packages/statistics.scm | 35 ++++++++++++++++++++---------------
1 file changed, 20 insertions(+), 15 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index dc7d3c7923..a21b47a9d3 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -6561,30 +6561,35 @@ (define-public r-tgstat
(license license:gpl2))))
(define-public r-tgconfig
- (let ((changeset "1e02c7614713bd0866c46f0c679a058f8c6d627e")
+ (let ((commit "15cf199436ae0b2ac0006b2ca7f0aeeb5c9d4445")
(revision "1"))
(package
(name "r-tgconfig")
- (version (string-append "0.0.0.9000-" revision "." (string-take changeset 7)))
+ (version (git-version "0.1.2" revision commit))
(source
(origin
- (method hg-fetch)
- (uri (hg-reference
- (url "https://bitbucket.org/tanaylab/tgconfig")
- (changeset changeset)))
- (file-name (string-append name "-" version "-checkout"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tanaylab/tgconfig")
+ (commit commit)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0xy6c7s7mn1yx191154bwbv1bl424bnvc80syqpl1vdl28ba46rj"))))
+ (base32 "159m8hhbk9ip2fdy6zsa96v0173q1awcrzdz2rr2796awfaxjgx1"))))
+ (properties `((upstream-name . "tgconfig")))
(build-system r-build-system)
- (propagated-inputs
- (list r-yaml))
- (home-page "https://bitbucket.org/tanaylab/tgconfig/")
+ (propagated-inputs (list r-yaml))
+ (home-page "https://github.com/tanaylab/tgconfig")
(synopsis "Infrastructure for managing package parameters")
(description
- "The goal of tgconfig is to provide infrastructure for managing package
-parameters.")
- (license license:gpl3))))
+ "This is a package to provide infrastructure for managing package parameters.
+Parameters are easy to get in relevant functions within a package,
+and rrror is thrown if a parameter is missing. Developers are able
+to register parameters and set their default value in a config file
+that is part of the package in YAML format, and users are able to
+override parameters using their own YAML. Users get an exception
+when trying to override a parameter that was not registered, and
+can load multiple parameters to the current environment.")
+ (license license:gpl3+))))
(define-public r-catterplots
(let ((commit "ae17cd5e49ddda4ecfe0eba8a4c21df8c88e72c4")

base-commit: 21b44bbc7c7b36eaaf19eb2f92ce654a44b70302
prerequisite-patch-id: 8b3f1b30e7ca1f6ddb21bf801faad91cce276dfd
--
2.34.1
Ricardo Wurmus wrote 1 years ago
(address . control@debbugs.gnu.org)
87r0ltjuqb.fsf@elephly.net
merge 66524 66526 66527 66528 66529 66530

--
Ricardo
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66526@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66526
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help