[PATCH] gnu: Add r-tgutil.

  • Done
  • quality assurance status badge
Details
2 participants
  • Afkhami, Navid
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Afkhami, Navid
Severity
normal
Merged with

Debbugs page

Afkhami, Navid wrote 1 years ago
(address . guix-patches@gnu.org)(name . Afkhami, Navid)(address . Navid.Afkhami@mdc-berlin.de)
3bae0cbdbc255c3e8157fe0557b13d8d5492d589.1697213063.git.Navid.Afkhami@mdc-berlin.de
* gnu/packages/statistics.scm (r-tgutil): New variable.
---
gnu/packages/statistics.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 7d6ec71e6f..7bdcc00cac 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -6556,6 +6556,43 @@ (define-public r-tgconfig
can load multiple parameters to the current environment.")
(license license:gpl3+))))
+(define-public r-tgutil
+ (let ((commit "0e4a2e84e5cf1f74bc66df0a3d8eac89633fd7b1")
+ (revision "1"))
+ (package
+ (name "r-tgutil")
+ (version (git-version "0.1.15" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tanaylab/tgutil")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pmacpzhrigprlpl8b5j4xz7l110ifw98017xwk569dghbf8zrq1"))))
+ (properties `((upstream-name . "tgutil")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-broom
+ r-cowplot
+ r-data-table
+ r-dplyr
+ r-ggplot2
+ r-glue
+ r-magrittr
+ r-matrix
+ r-matrixstats
+ r-qlcmatrix
+ r-readr
+ r-rlang
+ r-scales
+ r-tibble
+ r-tidyr))
+ (home-page "https://github.com/tanaylab/tgutil")
+ (synopsis "Simple utility functions for Tanay lab code")
+ (description "Shared utility functions for multiple Tanay lab packages.")
+ (license license:gpl3))))
+
(define-public r-catterplots
(let ((commit "ae17cd5e49ddda4ecfe0eba8a4c21df8c88e72c4")
(revision "3"))

base-commit: dcfd4d9c4827ca6bfebeec46fe6bb8373c425a1c
prerequisite-patch-id: 8b3f1b30e7ca1f6ddb21bf801faad91cce276dfd
prerequisite-patch-id: 86f04eb38885c80e1fa302cec734581778e62c26
prerequisite-patch-id: d5cebe9646097c611915c8b796a94ff0d1831343
prerequisite-patch-id: 675ed63512dcf5b145a929d0097b1bb7e7f1c389
--
2.34.1
Ricardo Wurmus wrote 1 years ago
(address . control@debbugs.gnu.org)
87r0ltjuqb.fsf@elephly.net
merge 66524 66526 66527 66528 66529 66530

--
Ricardo
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66529@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66529
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help