* gnu/packaging/messaging.scm (senpai): New variable.
Signed-off-by: Nguy?n Gia Phong <mcsinyx@disroot.org>
---
gnu/packages/messaging.scm | 52 ++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)
Toggle diff (63 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 3629d9a6d544..4fa04e5a1842 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3496,4 +3496,56 @@ (define-public pn
a text snippet), using @code{libphonenumber}.")
(license license:asl2.0)))
+(define-public senpai
+ (package
+ (name "senpai")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://git.sr.ht/~taiite/senpai")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qw955i5f3jr42h4afr23v7wq616bcsyq68if75qdw8j1yibnpmb"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "git.sr.ht/~taiite/senpai/cmd/senpai"
+ #:unpack-path "git.sr.ht/~taiite/senpai"
+ #:install-source? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'build 'build-doc
+ (lambda* (#:key unpack-path #:allow-other-keys)
+ (invoke "make" "doc/senpai.1" "doc/senpai.5"
+ "-C" (string-append "src/" unpack-path))))
+ (add-after 'install 'install-doc
+ (lambda* (#:key unpack-path #:allow-other-keys)
+ (let ((man1 (string-append #$output "/share/man/man1"))
+ (man5 (string-append #$output "/share/man/man5")))
+ (mkdir-p man1)
+ (mkdir-p man5)
+ (install-file
+ (string-append "src/" unpack-path "/doc/senpai.1")
+ man1)
+ (install-file
+ (string-append "src/" unpack-path "/doc/senpai.5")
+ man5)))))))
+ (native-inputs (list go-git-sr-ht-emersion-go-scfg
+ go-github-com-delthas-go-libnp
+ go-github-com-delthas-go-localeinfo
+ go-github-com-gdamore-tcell-v2
+ go-github-com-mattn-go-runewidth
+ go-golang-org-x-net
+ go-golang-org-x-term
+ go-golang-org-x-time
+ go-mvdan-cc-xurls
+ scdoc))
+ (home-page "https://sr.ht/~taiite/senpai")
+ (synopsis "Modern terminal IRC client")
+ (description "@code{senpai} is an IRC client that works best with bouncers")
+ (license license:isc)))
+
;;; messaging.scm ends here
--
2.40.1