[PATCH 0/4] Add senpai IRC client

  • Done
  • quality assurance status badge
Details
3 participants
  • John Kehayias
  • Ludovic Courtès
  • Nguy?n Gia Phong
Owner
unassigned
Submitted by
Nguy?n Gia Phong
Severity
normal
N
N
Nguy?n Gia Phong wrote on 22 Jun 2023 12:52
(address . guix-patches@gnu.org)(name . Nguy?n Gia Phong)(address . mcsinyx@disroot.org)
cover.1687431060.git.mcsinyx@disroot.org
Nguy?n Gia Phong (4):
gnu: go-github-com-godbus-dbus: Update to 5.1.0
gnu: Add go-github-com-delthas-go-libnp
gnu: Add go-github-com-delthas-go-localeinfo
gnu: Add senpai.

gnu/packages/golang.scm | 48 +++++++++++++++++++++++++++++++++--
gnu/packages/messaging.scm | 52 ++++++++++++++++++++++++++++++++++++++
2 files changed, 98 insertions(+), 2 deletions(-)


base-commit: 7f3c6d3b3ba86a8051e394e4ec9a6f6089753cb1
--
2.40.1
N
N
Nguy?n Gia Phong wrote on 22 Jun 2023 12:54
[PATCH 1/4] gnu: go-github-com-godbus-dbus: Update to 5.1.0
(address . 64222@debbugs.gnu.org)(name . Nguy?n Gia Phong)(address . mcsinyx@disroot.org)
9e1afd5da13e7b74161410bd910733604754c8a8.1687431267.git.mcsinyx@disroot.org
gnu/packages/golang.scm (go-github-com-godbus-dbus): Update to 5.1.0.

Signed-off-by: Nguy?n Gia Phong <mcsinyx@disroot.org>
---
gnu/packages/golang.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e4c4cb299b48..a392c10cd7fe 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9909,7 +9909,7 @@ (define-public go-github-com-xdg-go-scram
(define-public go-github-com-godbus-dbus
(package
(name "go-github-com-godbus-dbus")
- (version "5.0.3")
+ (version "5.1.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -9918,7 +9918,7 @@ (define-public go-github-com-godbus-dbus
(file-name (git-file-name name version))
(sha256
(base32
- "1bkc904073k807yxg6mvqaxrr6ammmhginr9p54jfb55mz3hfw3s"))))
+ "1kayd4x7idrhi06ahh5kqkgwzgh9icvv71mjar2d0jl486dfs8r5"))))
(build-system go-build-system)
(arguments
`(#:tests? #f ;no /var/run/dbus/system_bus_socket

base-commit: 7f3c6d3b3ba86a8051e394e4ec9a6f6089753cb1
--
2.40.1
N
N
Nguy?n Gia Phong wrote on 22 Jun 2023 12:54
[PATCH 2/4] gnu: Add go-github-com-delthas-go-libnp
(address . 64222@debbugs.gnu.org)(name . Nguy?n Gia Phong)(address . mcsinyx@disroot.org)
e6eec6e2dc020d5c2c8870c8587a03a45e9e2b98.1687431267.git.mcsinyx@disroot.org
gnu/packages/golang.scm (go-github-com-delthas-go-libnp): New variable.

Signed-off-by: Nguy?n Gia Phong <mcsinyx@disroot.org>
---
gnu/packages/golang.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a392c10cd7fe..9ffe8b3e7cbf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9931,6 +9931,28 @@ (define-public go-github-com-godbus-dbus
bindings for the D-Bus message bus system.")
(license license:bsd-2)))
+(define-public go-github-com-delthas-go-libnp
+ (let ((commit "0e45ece1f878f202fee2c74801e287804668f677"))
+ (package
+ (name "go-github-com-delthas-go-libnp")
+ (version (git-version "0.0.0" "0" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/delthas/go-libnp")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hylpvwz3kb8wr00knba6mggjacak2vmqafwysansj0ns038lp8w"))))
+ (build-system go-build-system)
+ (arguments `(#:import-path "github.com/delthas/go-libnp"))
+ (propagated-inputs (list go-github-com-godbus-dbus))
+ (home-page "https://github.com/delthas/go-libnp")
+ (synopsis "Tiny library providing information about now-playing media")
+ (description "@code{go-libnp} is a tiny cross-platform library for extracting information about the music/image/video that is Now Playing on the system.")
+ (license license:expat))))
+
(define-public go-github-com-prometheus-common
(package
(name "go-github-com-prometheus-common")
--
2.40.1
N
N
Nguy?n Gia Phong wrote on 22 Jun 2023 12:54
[PATCH 3/4] gnu: Add go-github-com-delthas-go-localeinfo
(address . 64222@debbugs.gnu.org)(name . Nguy?n Gia Phong)(address . mcsinyx@disroot.org)
c616164119d09428df20cbf6ad5cc421a3e3fc8d.1687431267.git.mcsinyx@disroot.org
gnu/packages/golang.scm (go-github-com-delthas-go-localeinfo): New variable.

Signed-off-by: Nguy?n Gia Phong <mcsinyx@disroot.org>
---
gnu/packages/golang.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9ffe8b3e7cbf..d2d7f855871d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9953,6 +9953,28 @@ (define-public go-github-com-delthas-go-libnp
(description "@code{go-libnp} is a tiny cross-platform library for extracting information about the music/image/video that is Now Playing on the system.")
(license license:expat))))
+(define-public go-github-com-delthas-go-localeinfo
+ (let ((commit "686a1e18511819b2f1625f00437f6e1246c04a5d"))
+ (package
+ (name "go-github-com-delthas-go-localeinfo")
+ (version (git-version "0.0.0" "0" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/delthas/go-localeinfo")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0r0v42ggvyss8327nggwinxl42pj4l0dwz96g9wk1w8h8vmfrh0z"))))
+ (build-system go-build-system)
+ (arguments `(#:tests? #f ; FIXME: tests assume certain locale
+ #:import-path "github.com/delthas/go-localeinfo"))
+ (home-page "https://github.com/delthas/go-localeinfo")
+ (synopsis "Library for extracting locale information")
+ (description "@code{go-localeinfo} extracts monetary/numeric/time formatting information, rather than the current locale name.")
+ (license license:expat))))
+
(define-public go-github-com-prometheus-common
(package
(name "go-github-com-prometheus-common")
--
2.40.1
N
N
Nguy?n Gia Phong wrote on 22 Jun 2023 12:54
[PATCH 4/4] gnu: Add senpai.
(address . 64222@debbugs.gnu.org)(name . Nguy?n Gia Phong)(address . mcsinyx@disroot.org)
77d4e608cd53072a45f751adddf6eef0ab71d5d0.1687431267.git.mcsinyx@disroot.org
* gnu/packaging/messaging.scm (senpai): New variable.

Signed-off-by: Nguy?n Gia Phong <mcsinyx@disroot.org>
---
gnu/packages/messaging.scm | 52 ++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 3629d9a6d544..4fa04e5a1842 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3496,4 +3496,56 @@ (define-public pn
a text snippet), using @code{libphonenumber}.")
(license license:asl2.0)))
+(define-public senpai
+ (package
+ (name "senpai")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://git.sr.ht/~taiite/senpai")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qw955i5f3jr42h4afr23v7wq616bcsyq68if75qdw8j1yibnpmb"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "git.sr.ht/~taiite/senpai/cmd/senpai"
+ #:unpack-path "git.sr.ht/~taiite/senpai"
+ #:install-source? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'build 'build-doc
+ (lambda* (#:key unpack-path #:allow-other-keys)
+ (invoke "make" "doc/senpai.1" "doc/senpai.5"
+ "-C" (string-append "src/" unpack-path))))
+ (add-after 'install 'install-doc
+ (lambda* (#:key unpack-path #:allow-other-keys)
+ (let ((man1 (string-append #$output "/share/man/man1"))
+ (man5 (string-append #$output "/share/man/man5")))
+ (mkdir-p man1)
+ (mkdir-p man5)
+ (install-file
+ (string-append "src/" unpack-path "/doc/senpai.1")
+ man1)
+ (install-file
+ (string-append "src/" unpack-path "/doc/senpai.5")
+ man5)))))))
+ (native-inputs (list go-git-sr-ht-emersion-go-scfg
+ go-github-com-delthas-go-libnp
+ go-github-com-delthas-go-localeinfo
+ go-github-com-gdamore-tcell-v2
+ go-github-com-mattn-go-runewidth
+ go-golang-org-x-net
+ go-golang-org-x-term
+ go-golang-org-x-time
+ go-mvdan-cc-xurls
+ scdoc))
+ (home-page "https://sr.ht/~taiite/senpai")
+ (synopsis "Modern terminal IRC client")
+ (description "@code{senpai} is an IRC client that works best with bouncers")
+ (license license:isc)))
+
;;; messaging.scm ends here
--
2.40.1
L
L
Ludovic Courtès wrote on 12 Oct 2023 17:12
Re: [bug#64222] [PATCH 0/4] Add senpai IRC client
(name . Nguy?n Gia Phong)(address . mcsinyx@disroot.org)(address . 64222-done@debbugs.gnu.org)
877cnrlvrh.fsf@gnu.org
Hi!

Nguy?n Gia Phong <mcsinyx@disroot.org> skribis:

Toggle quote (5 lines)
> gnu: go-github-com-godbus-dbus: Update to 5.1.0
> gnu: Add go-github-com-delthas-go-libnp
> gnu: Add go-github-com-delthas-go-localeinfo
> gnu: Add senpai.

https://qa.guix.gnu.org/issue/64222 was inconclusive (for some reason
it had not built all the dependents) so I checked locally and the
go-github-com-godbus-dbus upgrade does not introduce new breakage.

I wrapped the long ‘description’ lines, removed ‘Signed-off-by’ tags
from the logs (they’re for committers), and committed.

Thank you and apologies for the delay!

Ludo’.
Closed
N
N
Nguy?n Gia Phong wrote on 12 Oct 2023 18:16
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 64222-done@debbugs.gnu.org)
CW6LG7J7BIZF.SL2VK0F8HAQI@nix
On 2023-10-12 at 17:12+02:00, Ludovic Courtès wrote:
Toggle quote (3 lines)
> (for some reason it had not built all the dependents)

qa.guix.gnu.org was briefly broken at the time IIRC,
happened to other adjacent patchsets.

On 2023-10-12 at 17:12+02:00, Ludovic Courtès wrote:
Toggle quote (6 lines)
> so I checked locally and the go-github-com-godbus-dbus upgrade
> does not introduce new breakage.
>
> I wrapped the long ‘description’ lines, removed ‘Signed-off-by’ tags
> from the logs (they’re for committers), and committed.

Thanks a lot!
Closed
J
J
John Kehayias wrote on 12 Oct 2023 19:53
Re: bug#64222: [PATCH 0/4] Add senpai IRC client
(name . Nguy?n Gia Phong)(address . mcsinyx@disroot.org)
87ttqv7mnb.fsf_-_@protonmail.com
Hi Ludo’ and Nguy?n (and cc'ing Sarah from earlier patches),

On Fri, Oct 13, 2023 at 01:16 AM, Nguy?n Gia Phong wrote:

Toggle quote (12 lines)
> On 2023-10-12 at 17:12+02:00, Ludovic Courtès wrote:
>> <https://qa.guix.gnu.org/issue/64222> was inconclusive
>> (for some reason it had not built all the dependents)
>
> qa.guix.gnu.org was briefly broken at the time IIRC,
> happened to other adjacent patchsets.
>
> On 2023-10-12 at 17:12+02:00, Ludovic Courtès wrote:
>> so I checked locally and the go-github-com-godbus-dbus upgrade
>> does not introduce new breakage.
>>

I haven't checked but this might need some fixing as based on an earlier
patch for updating godbus (I can't help but read this as "god bus") the
import name has changed. Though as an example chezmoi seems to have been
broken for some time anyway. Maybe the import-name doesn't need the v5?

See


and


The earlier patch also has fixes for the tests which would be good to
include now.

My apologies to Sarah as my original replies way back when only went to
the bug number (we should document this, easy beginner mistake!) and
once I became a committer this was on my list to update and push but I
didn't get around to it.

Nguy?n and/or Sarah would you like to submit a patch to change the
import path if needed, enable tests, and make any other changes? I could
also take a look if no one gets to it quickly.

Toggle quote (5 lines)
>> I wrapped the long ‘description’ lines, removed ‘Signed-off-by’ tags
>> from the logs (they’re for committers), and committed.
>
> Thanks a lot!

Thanks to all on this updates!

John

PS: Looks like one extra signed-off-by tag made it through on a commit.
Oh well, glad I'm not the only one who's not perfect at these things!
N
N
Nguy?n Gia Phong wrote on 13 Oct 2023 06:52
Re: gnu: go-github-com-godbus-dbus-v5
(name . John Kehayias)(address . john.kehayias@protonmail.com)
CW71HXE2UCHX.1SU4O7MG8PD9E@guix
On 2023-10-12 at 17:53+00:00, John Kehayias wrote:
Toggle quote (4 lines)
> [godbus's] import name has changed. Though as an example
> chezmoi seems to have been broken for some time anyway.
> Maybe the import-name doesn't need the v5?

IIUC go-github-com-godbus-dbus is just a name for human consumption,
on the other hand I don't understand how it works without
the import-path matching the one in the go.mod file:

On 2021-08-13 at 20:49-07:00, Sarah Morgensen wrote in patchset 50037:
Toggle quote (3 lines)
> - `(#:import-path "github.com/godbus/dbus"
> + `(#:import-path "github.com/godbus/dbus/v5"

On 2023-10-12 at 17:53+00:00, John Kehayias wrote:
Toggle quote (4 lines)
> Nguy?n and/or Sarah would you like to submit a patch to change the
> import path if needed, enable tests, and make any other changes? I could
> also take a look if no one gets to it quickly.

As stated above, I don't quite understand how go packages work
(when they don't seem to be supposed to), so you two please go ahead.
(BTW you can call me by my given name Phong.)

On 2023-10-12 at 17:53+00:00, John Kehayias wrote:
Toggle quote (2 lines)
> I can't help but read this as "god bus"

Yea DBus is short for Dieu Bus anyway.
?