Updating wagtail to 3.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Lars-Dominik Braun
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
Merged with
N
N
Nicolas Graves wrote on 10 Aug 2022 00:37
(address . guix-patches@gnu.org)
871qtpgi0u.fsf@ngraves.fr
Small series to update wagtail. This series need the v2 series in 55474
to be applied.

--
Best regards,
Nicolas Graves
N
N
Nicolas Graves wrote on 10 Aug 2022 00:43
[PATCH 1/9] gnu: python-django-modelcluster: Update to 6.0.
(address . 57094@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20220809224333.28437-1-ngraves@ngraves.fr
* gnu/packages/django.scm (python-django-modelcluster): Update to 6.0.
---
gnu/packages/django.scm | 15 ++++++++-------
1 file changed, 8 insertions(+), 7 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index cd88e1fac3..2f95056c78 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -893,16 +893,17 @@ (define-public python-django-contrib-comments
(define-public python-django-modelcluster
(package
(name "python-django-modelcluster")
- (version "5.3")
+ (version "6.0")
+ ;; tests are not packaged in pypi
(source
(origin
- (method url-fetch)
- (uri
- (string-append
- "https://github.com/wagtail/django-modelcluster"
- "/archive/refs/tags/v" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wagtail/django-modelcluster")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0xlhlnsr8gingbrsgbzhx79z9ds9i9rfii3gp38xnid01xjwlqln"))))
+ (base32 "19xskhh2wvl696jmji54b1p70kjbcxzwmw3v5ic54ifn8cx6za57"))))
(build-system python-build-system)
(arguments
'(#:phases
--
2.37.1
N
N
Nicolas Graves wrote on 10 Aug 2022 00:43
[PATCH 2/9] gnu: Add python-django-permissionedforms.
(address . 57094@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20220809224333.28437-2-ngraves@ngraves.fr
* gnu/packages/django.scm (python-django-permissionedforms): New variable.
---
gnu/packages/django.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 2f95056c78..4b2c255ee7 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -785,6 +785,40 @@ (define-public python-dj-database-url
conn_max_age argument to easily enable Django’s connection pool.")
(license license:bsd-2)))
+(define-public python-django-permissionedforms
+ (package
+ (name "python-django-permissionedforms")
+ (version "0.1")
+ ;; tests are not packaged in pypi
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wagtail/django-permissionedforms")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0dscl238yi4xyd4nz2cxr5kikyalqj5drmk935llal3rd0dcy30d"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+ (if tests?
+ (invoke "python" "runtests.py")
+ (format #t "test suite not run~%")))))))
+ (propagated-inputs (list python-django))
+ (native-inputs (list python-django-modelcluster))
+ (home-page "https://github.com/wagtail/django-permissionedforms")
+ (synopsis
+ "Create forms that vary according to user permissions in Django")
+ (description
+ "This package provides a Django extension for creating forms that vary
+according to user permissions.")
+ (license license:bsd-3)))
+
(define-public python-django-picklefield
(package
(name "python-django-picklefield")
--
2.37.1
N
N
Nicolas Graves wrote on 10 Aug 2022 00:43
[PATCH 3/9] gnu: Add python-curlylint.
(address . 57094@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20220809224333.28437-3-ngraves@ngraves.fr
* gnu/packages/python-web.scm (python-curlylint): New variable.
---
gnu/packages/python-web.scm | 38 +++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7c5e5651c8..0c02c4f889 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -550,6 +550,44 @@ (define-public python-css-html-js-minify
;; looks like the user can choose a license.
(license (list license:gpl3+ license:lgpl3+ license:expat))))
+(define-public python-curlylint
+ (package
+ (name "python-curlylint")
+ (version "0.13.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "curlylint" version))
+ (sha256
+ (base32
+ "0li72vig9ibrdfazvaprfawrq84ylg00byrfq554081r1wb9v2q0"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'sanity-check)
+ (replace 'check
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+ (if tests?
+ (lambda _
+ (substitute* "setup.py"
+ (("parsy==1.1.0") "parsy>=1.1.0"))
+ (invoke "pytest" "-vv"))
+ (format #t "test suite not run~%")))))))
+ (propagated-inputs (list python-attrs
+ python-click
+ python-dataclasses
+ python-parsy
+ python-pathspec
+ python-toml))
+ (home-page "https://github.com/thibaudcolas/curlylint")
+ (synopsis
+ "Experimental HTML templates linting")
+ (description
+ "This package provides experimental HTML templates linting for Jinja,
+Nunjucks, Django templates, Twig and Liquid.")
+ (license license:expat)))
+
(define-public python-aws-sam-translator
(package
(name "python-aws-sam-translator")
--
2.37.1
N
N
Nicolas Graves wrote on 10 Aug 2022 00:43
[PATCH 4/9] gnu: Add python-flake8-assertive.
(address . 57094@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20220809224333.28437-4-ngraves@ngraves.fr
* gnu/packages/python-xyz.scm (python-flake8-assertive): New variable.
---
gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 90b3c6686f..c6415c06d0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10713,6 +10713,31 @@ (define-public python-flake8-3.8
(list python-pycodestyle-2.6 python-entrypoints python-pyflakes-2.2
python-mccabe))))
+(define-public python-flake8-assertive
+ (package
+ (name "python-flake8-assertive")
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jparise/flake8-assertive")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "139cda03jgwasz6gqx41gnyvk28iz8w68liqcbn46h2zjg20c6ck"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-flake8))
+ (home-page "https://github.com/jparise/flake8-assertive")
+ (synopsis "Assert method checker for flake8 unit-testing.")
+ (description "\
+This package provides @code{flake8-assertive}, a Flake8 extension that
+encourages using richer, more specific unittest assertions beyond just the
+typical @code{assertEqual(a, b)} and @code{assertTrue(x)} methods. The
+suggested methods perform more precise checks and provide better failure
+messages than the generic methods.")
+ (license license:expat)))
+
(define-public python-flake8-blind-except
(package
(name "python-flake8-blind-except")
--
2.37.1
N
N
Nicolas Graves wrote on 10 Aug 2022 00:43
[PATCH 5/9] gnu: Add python-flake8-comprehensions.
(address . 57094@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20220809224333.28437-5-ngraves@ngraves.fr
* gnu/packages/python-xyz.scm (python-flake8-comprehensions): New variable.
---
gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c6415c06d0..81bc12bbba 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10792,6 +10792,26 @@ (define-public python-flake8-bugbear
in pyflakes and pycodestyle.")
(license license:expat)))
+(define-public python-flake8-comprehensions
+ (package
+ (name "python-flake8-comprehensions")
+ (version "3.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8-comprehensions" version))
+ (sha256
+ (base32 "0n2hj32cjvhzw5nfb317f7pavii8xxy03riq18xac9mawzvmh48q"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-flake8 python-importlib-metadata))
+ (home-page "https://github.com/adamchainz/flake8-comprehensions")
+ (synopsis
+ "Write better list/set/dict comprehensions for flake8")
+ (description
+ "This package provides a flake8 plugin helping to write better
+list/set/dict comprehensions.")
+ (license license:expat)))
+
(define-public python-flake8-continuation
(package
(name "python-flake8-continuation")
--
2.37.1
N
N
Nicolas Graves wrote on 10 Aug 2022 00:43
[PATCH 6/9] gnu: Add python-django-pattern-library.
(address . 57094@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20220809224333.28437-6-ngraves@ngraves.fr
* gnu/packages/django.scm (python-django-pattern-library): New variable.
---
gnu/packages/django.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 4b2c255ee7..4315f40cc5 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -785,6 +785,39 @@ (define-public python-dj-database-url
conn_max_age argument to easily enable Django’s connection pool.")
(license license:bsd-2)))
+(define-public python-django-pattern-library
+ (package
+ (name "python-django-pattern-library")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "django-pattern-library" version))
+ (sha256
+ (base32 "1s2s1sgrdrrizf2zmgijjxhv5q4pislggb34v2v4c27nd9ha981x"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+ (if tests?
+ (lambda _
+ (setenv "PYTHONPATH"
+ (string-append ".:" (getenv "GUIX_PYTHONPATH")))
+ (setenv "DJANGO_SETTINGS_MODULE" "treebeard.tests.settings")
+ (substitute* "setup.py" ((".*pythonpath.*") ""))
+ (invoke "pytest" "-vv"))
+ (format #t "test suite not run~%")))))))
+ (propagated-inputs (list python-django python-markdown python-pyyaml))
+ (home-page "https://github.com/torchbox/django-pattern-library")
+ (synopsis
+ "Build pattern libraries for your Django projects")
+ (description
+ "This package provides a module for Django that allows to build pattern libraries
+for your projects.")
+ (license license:bsd-3)))
+
(define-public python-django-permissionedforms
(package
(name "python-django-permissionedforms")
--
2.37.1
N
N
Nicolas Graves wrote on 10 Aug 2022 00:43
[PATCH 7/9] gnu: Add python-nox.
(address . 57094@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20220809224333.28437-7-ngraves@ngraves.fr
* gnu/packages/python-check.scm (python-nox): New variable.
---
gnu/packages/python-check.scm | 51 +++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index af0e5be28b..20ab26facf 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -107,6 +107,57 @@ (define-public python-beartype
written in pure Python.")
(license license:expat)))
+(define-public python-nox
+ (package
+ (name "python-nox")
+ (version "2022.1.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "nox" version))
+ (sha256
+ (base32
+ "0zkxv7y5952kizri6bnac3gq1kah3b7d1f3lmcpxzfdhxf626xdk"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-argcomplete
+ python-colorlog
+ python-importlib-metadata
+ python-packaging
+ python-py
+ python-typing-extensions
+ python-virtualenv))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: PEP 517 manual build/install procedures copied from
+ ;; python-isort.
+ (replace 'build
+ (lambda _
+ ;; ZIP does not support timestamps before 1980.
+ (setenv "SOURCE_DATE_EPOCH" "315532800")
+ (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((whl (car (find-files "dist" "\\.whl$"))))
+ (invoke "pip" "--no-cache-dir" "--no-input"
+ "install" "--no-deps" "--prefix" #$output whl))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "tests")))))))
+ (native-inputs
+ (list python-pypa-build
+ python-pytest
+ python-jinja2
+ python-tox))
+ (home-page "https://nox.thea.codes")
+ (synopsis "Flexible python test automation")
+ (description
+ "This package provides @code{nox}, a command-line tool that automates
+testing in multiple Python environments, similar to @code{tox}. Unlike
+@code{tox}, @code{nox} uses a standard Python file for configuration.")
+ (license license:asl2.0)))
+
(define-public python-pytest-click
(package
(name "python-pytest-click")
--
2.37.1
N
N
Nicolas Graves wrote on 10 Aug 2022 00:43
[PATCH 8/9] gnu: Add python-djhtml.
(address . 57094@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20220809224333.28437-8-ngraves@ngraves.fr
* gnu/packages/python-web.scm (python-djhtml): New variable.
---
gnu/packages/python-web.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0c02c4f889..d8ebca876f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1885,6 +1885,33 @@ (define-public python-databricks-cli
Databricks REST APIs.")
(license license:asl2.0)))
+(define-public python-djhtml
+ (package
+ (name "python-djhtml")
+ (version "1.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "djhtml" version))
+ (sha256
+ (base32 "1csyq47rpfdgigxd4kpil90vl6jrmq42agr04mhsbqj5kh70dffk"))))
+ (build-system python-build-system)
+ (native-inputs (list python-black python-flake8 python-isort python-nox
+ python-pre-commit))
+ (home-page "https://github.com/rtts/djhtml")
+ (synopsis "Django/Jinja template indenter")
+ (description
+"This package provides a fully automatic template indenter that works with
+mixed HTML/CSS/Javascript templates that contain Django or Jinja template
+tags. It works similar to other code-formatting tools such as
+@code{python-black} and interoperates nicely with @code{pre-commit}.
+
+DjHTML is an indenter and not a formatter: it will only add/remove whitespace
+at the beginning of lines. It will not insert newlines or other
+characters. The goal is to correctly indent already well-structured templates,
+not to fix broken ones.")
+ (license license:gpl3)))
+
(define-public python-openid-cla
(package
(name "python-openid-cla")
--
2.37.1
N
N
Nicolas Graves wrote on 10 Aug 2022 00:43
[PATCH 9/9] gnu: python-wagtail: Update to 3.0.1.
(address . 57094@debbugs.gnu.org)(address . ngraves@ngraves.fr)
20220809224333.28437-9-ngraves@ngraves.fr
* gnu/packages/django.scm (python-wagtail): Update to 3.0.1.
---
gnu/packages/django.scm | 18 +++++++++++-------
1 file changed, 11 insertions(+), 7 deletions(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 4315f40cc5..0995c255d5 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -1586,13 +1586,13 @@ (define-public python-telepath
(define-public python-wagtail
(package
(name "python-wagtail")
- (version "2.16.2")
+ (version "3.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "wagtail" version))
(sha256
- (base32 "1alxxj7aiwj1ymaharzxv7sq7kyv555jg5fc1b98aiwxlcdxq8zf"))))
+ (base32 "1j3v4iknamwsd3mb981bk1q66cg409z60g9jxd5p6i46xby96wwi"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1601,9 +1601,9 @@ (define-public python-wagtail
(lambda* (#:key tests? inputs #:allow-other-keys)
(if tests?
(lambda _
- (setenv "DJANGO_SETTINGS_MODULE" "wagtail.tests.settings")
(invoke "django-admin"
"test" "--pythonpath=."
+ "--settings=wagtail.tests.settings"
;; disabling failing tests
"-k" "not test_azure_cdn_get_client"
"-k" "not test_azure_cdn_purge"
@@ -1616,6 +1616,7 @@ (define-public python-wagtail
python-django-filter
python-django-modelcluster
python-django-taggit
+ python-django-permissionedforms
python-django-treebeard
python-django-rest-framework
python-draftjs-exporter
@@ -1630,23 +1631,26 @@ (define-public python-wagtail
(native-inputs
(list ;; python-azure-mgmt-cdn ;failing tests
;; python-azure-mgmt-frontdoor ;failing tests
+ python-black
python-boto3
python-coverage
+ python-curlylint
python-dateutil
+ python-django-pattern-library
+ python-djhtml
python-doc8
- python-docutils
python-elasticsearch
python-flake8
+ python-flake8-assertive
+ python-flake8-comprehensions
python-flake8-blind-except
python-flake8-print
python-freezegun
python-isort
python-jinja2
- python-jinjalint
python-openpyxl
python-polib
- python-pytz
- python-unidecode))
+ python-pytz))
(home-page "https://wagtail.org/")
(synopsis "A Content Management System (CMS)")
(description "This package provides a Content Management System based on
--
2.37.1
L
L
Lars-Dominik Braun wrote on 5 Jan 2023 08:48
Re: [bug#55474] [PATCH v2 17/17] gnu: Add python-wagtail-localize.
(address . control@debbugs.gnu.org)
Y7aA1dEHv4TqYx6s@noor.fritz.box
merge 55474 57094
thanks
N
N
Nicolas Graves wrote on 5 Sep 2023 16:46
close 55474
(address . control@debbugs.gnu.org)
877cp4n0er.fsf@ngraves.fr
close 55474

I'll submit a new patch series instead, so that it's properly evaluated
by Guix QA.

--
Best regards,
Nicolas Graves
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57094@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57094
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch