[PATCH 03/18] gnu: Add python-django-modelcluster.

  • Done
  • quality assurance status badge
Details
3 participants
  • Hartmut Goebel
  • Lars-Dominik Braun
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
Merged with
N
N
Nicolas Graves wrote on 17 May 2022 09:54
(address . guix-patches@gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20220517075448.32638-3-ngraves@ngraves.fr
* gnu/packages/django.scm (python-django-modelcluster): New variable.
---
gnu/packages/django.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index ea8ed040f8..fee4278708 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -780,6 +780,35 @@ (define-public python-django-contrib-comments
entries, photos, book chapters, or anything else.")
(license license:bsd-3)))
+(define-public python-django-modelcluster
+ (package
+ (name "python-django-modelcluster")
+ (version "5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri "https://github.com/wagtail/django-modelcluster/archive/refs/tags/v5.3.tar.gz")
+ (sha256
+ (base32 "0xlhlnsr8gingbrsgbzhx79z9ds9i9rfii3gp38xnid01xjwlqln"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+ (if tests?
+ (invoke "python" "runtests.py")
+ (format #t "test suite not run~%")))))))
+ (propagated-inputs (list python-django python-pytz))
+ (native-inputs (list python-django-taggit))
+ (home-page "https://github.com/wagtail/django-modelcluster")
+ (synopsis
+ "Django extension to allow working with 'clusters' of models as a single unit")
+ (description
+ "This package provides a Django extension to allow working with
+'clusters' of models as a single unit, independently of the database")
+ (license license:bsd-3)))
+
(define-public python-django-pipeline
(package
(name "python-django-pipeline")
--
2.36.0
H
H
Hartmut Goebel wrote on 22 Jun 2022 19:01
control message for bug #55476
(address . control@debbugs.gnu.org)
87tu8cy6mf.fsf@lenashee.goebel-consult.de
merge 55476 55475 55474 55473
quit
L
L
Lars-Dominik Braun wrote on 5 Jan 2023 08:48
Re: [bug#55474] [PATCH v2 17/17] gnu: Add python-wagtail-localize.
(address . control@debbugs.gnu.org)
Y7aA1dEHv4TqYx6s@noor.fritz.box
merge 55474 57094
thanks
N
N
Nicolas Graves wrote on 5 Sep 2023 16:46
close 55474
(address . control@debbugs.gnu.org)
877cp4n0er.fsf@ngraves.fr
close 55474

I'll submit a new patch series instead, so that it's properly evaluated
by Guix QA.

--
Best regards,
Nicolas Graves
?