(address . guix-patches@gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
* gnu/packages/python-xyz.scm (python-jinjalint): New variable.
---
gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
Toggle diff (44 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 29b42ea3a0..5d6a60c771 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4272,6 +4272,37 @@ (define-public python-jinja2-time
templates. A format string can be provided to control the output.")
(license license:expat)))
+(define-public python-jinjalint
+ (package
+ (name "python-jinjalint")
+ (version "0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jinjalint" version))
+ (sha256
+ (base32 "09qqqi6iggr64zms9j9sgfq9v5samvsqyyqk0s1y4gfjy6lf9424"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'lift-requirements
+ (lambda _
+ (substitute* "requirements.txt"
+ (("parsy==1.1.0.*") "parsy\n")
+ (("attrs==17.2.*") "attrs\n")
+ (("docopt==0.6.2.*") "docopt\n"))))
+ (replace 'check
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+ (if tests?
+ (invoke "python3" "-m" "jinjalint" "jinjalint/test.py")
+ (format #t "test suite not run~%")))))))
+ (propagated-inputs (list python-attrs python-docopt python-parsy))
+ (home-page "https://github.com/motet-a/jinjalint")
+ (synopsis "A linter for Jinja-like templates")
+ (description "This package provides a linter for Jinja-like templates.")
+ (license license:expat)))
+
(define-public python-pystache
(package
(name "python-pystache")
--
2.36.0