[PATCH 05/18] gnu: Add python-jinjalint.

  • Done
  • quality assurance status badge
Details
3 participants
  • Hartmut Goebel
  • Lars-Dominik Braun
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
Merged with
N
N
Nicolas Graves wrote on 17 May 2022 09:54
(address . guix-patches@gnu.org)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
20220517075448.32638-5-ngraves@ngraves.fr
* gnu/packages/python-xyz.scm (python-jinjalint): New variable.
---
gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 29b42ea3a0..5d6a60c771 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4272,6 +4272,37 @@ (define-public python-jinja2-time
templates. A format string can be provided to control the output.")
(license license:expat)))
+(define-public python-jinjalint
+ (package
+ (name "python-jinjalint")
+ (version "0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jinjalint" version))
+ (sha256
+ (base32 "09qqqi6iggr64zms9j9sgfq9v5samvsqyyqk0s1y4gfjy6lf9424"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'lift-requirements
+ (lambda _
+ (substitute* "requirements.txt"
+ (("parsy==1.1.0.*") "parsy\n")
+ (("attrs==17.2.*") "attrs\n")
+ (("docopt==0.6.2.*") "docopt\n"))))
+ (replace 'check
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+ (if tests?
+ (invoke "python3" "-m" "jinjalint" "jinjalint/test.py")
+ (format #t "test suite not run~%")))))))
+ (propagated-inputs (list python-attrs python-docopt python-parsy))
+ (home-page "https://github.com/motet-a/jinjalint")
+ (synopsis "A linter for Jinja-like templates")
+ (description "This package provides a linter for Jinja-like templates.")
+ (license license:expat)))
+
(define-public python-pystache
(package
(name "python-pystache")
--
2.36.0
H
H
Hartmut Goebel wrote on 22 Jun 2022 19:01
control message for bug #55476
(address . control@debbugs.gnu.org)
87tu8cy6mf.fsf@lenashee.goebel-consult.de
merge 55476 55475 55474 55473
quit
L
L
Lars-Dominik Braun wrote on 5 Jan 2023 08:48
Re: [bug#55474] [PATCH v2 17/17] gnu: Add python-wagtail-localize.
(address . control@debbugs.gnu.org)
Y7aA1dEHv4TqYx6s@noor.fritz.box
merge 55474 57094
thanks
N
N
Nicolas Graves wrote on 5 Sep 2023 16:46
close 55474
(address . control@debbugs.gnu.org)
877cp4n0er.fsf@ngraves.fr
close 55474

I'll submit a new patch series instead, so that it's properly evaluated
by Guix QA.

--
Best regards,
Nicolas Graves
?