Hi Morgan,
(+Cc: Raghav.)
Morgan.J.Smith@outlook.com skribis:
Toggle quote (13 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/messaging.scm (gajim)[inputs]: Add hicolor-icon-theme
> ---
>
> So on my system gajim crashes saying something like "icon not present in the
> theme Adwaita". I have installed Adwaita system wide. Looking in the gajim
> build dir at
> '/gnu/store/...-gajim-1.4.5/lib/python3.9/site-packages/gajim/data/icons/'
> shows that the icons are stored in a 'hicolor' directory. The proper solution
> is to either figure out how to install the icons in a theme independent way or
> to notify upstream
I can reproduce the problem with:
Toggle snippet (30 lines)
$ guix describe
Generation 221 Jul 03 2022 23:52:07 (current)
guix e069de4
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: e069de452a2c923868f5137421b4b6349c38d754
$ guix shell -CN -E DISPLAY gajim -- gajim
[…]
(org.gajim.Gajim:1): Gtk-WARNING **: 22:04:37.615: Could not find the icon 'org.gajim.Gajim-symbolic'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
http://icon-theme.freedesktop.org/releases
Traceback (most recent call last):
File "/gnu/store/b3c4lsfl0swzyk0ylkvbjz2lk28caxrl-gajim-1.4.5/lib/python3.9/site-packages/gajim/gtk/application.py", line 389, in _handle_local_options
self._startup()
File "/gnu/store/b3c4lsfl0swzyk0ylkvbjz2lk28caxrl-gajim-1.4.5/lib/python3.9/site-packages/gajim/gtk/application.py", line 278, in _startup
MainWindow()
File "/gnu/store/b3c4lsfl0swzyk0ylkvbjz2lk28caxrl-gajim-1.4.5/lib/python3.9/site-packages/gajim/gtk/main.py", line 85, in __init__
self._main_stack = MainStack()
File "/gnu/store/b3c4lsfl0swzyk0ylkvbjz2lk28caxrl-gajim-1.4.5/lib/python3.9/site-packages/gajim/gtk/main_stack.py", line 45, in __init__
self._chat_page = ChatPage()
File "/gnu/store/b3c4lsfl0swzyk0ylkvbjz2lk28caxrl-gajim-1.4.5/lib/python3.9/site-packages/gajim/gtk/chat_page.py", line 60, in __init__
self._chat_stack = ChatStack()
File "/gnu/store/b3c4lsfl0swzyk0ylkvbjz2lk28caxrl-gajim-1.4.5/lib/python3.9/site-packages/gajim/gtk/chat_stack.py", line 48, in __init__
self.add_named(ChatPlaceholderBox(), 'empty')
File "/gnu/store/b3c4lsfl0swzyk0ylkvbjz2lk28caxrl-gajim-1.4.5/lib/python3.9/site-packages/gajim/gtk/chat_stack.py", line 161, in __init__
pixbuf = Gtk.IconTheme.load_icon_for_scale(
gi.repository.GLib.GError: gtk-icon-theme-error-quark: Icon 'org.gajim.Gajim-symbolic' not present in theme Adwaita (0)
Does simply adding ‘hicolor-icon-theme’ to ‘inputs’ fix the issue?
Unfortunately, Gajim fails to build for me as described in
Raghav, what should we do about it? The issue above is closed, but are
we missing the fix?
Thanks,
Ludo’.