Add ghc-microspec

  • Open
  • quality assurance status badge
Details
2 participants
  • Lars-Dominik Braun
  • WinterHound
Owner
unassigned
Submitted by
WinterHound
Severity
normal
Merged with
W
W
WinterHound wrote on 30 Jun 2022 06:51
(address . guix-patches@gnu.org)(name . WinterHound)(address . winterhound@yandex.com)
20220630045109.17836-2-winterhound@yandex.com
---
gnu/packages/haskell-check.scm | 55 +++++++++++++++++++++++-----------
1 file changed, 37 insertions(+), 18 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 62433cdb15..06c11e2ccb 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -1214,31 +1214,31 @@ (define-public ghc-tasty-silver
(name "ghc-tasty-silver")
(version "3.2.3")
(source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://hackage.haskell.org/package/tasty-silver/tasty-silver-"
- version
- ".tar.gz"))
- (sha256
- (base32 "0nvh2k8iqqkanmp7lpwd3asimyarzisly8wavbdahcxryn0j4xb7"))))
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/tasty-silver/tasty-silver-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32 "0nvh2k8iqqkanmp7lpwd3asimyarzisly8wavbdahcxryn0j4xb7"))))
(build-system haskell-build-system)
(inputs
- (list ghc-ansi-terminal
- ghc-async
- ghc-optparse-applicative
- ghc-process-extras
- ghc-regex-tdfa
- ghc-semigroups
- ghc-tagged
- ghc-tasty
- ghc-temporary))
+ (list ghc-ansi-terminal
+ ghc-async
+ ghc-optparse-applicative
+ ghc-process-extras
+ ghc-regex-tdfa
+ ghc-semigroups
+ ghc-tagged
+ ghc-tasty
+ ghc-temporary))
(native-inputs
(list ghc-tasty-hunit ghc-silently))
(home-page "https://github.com/phile314/tasty-silver")
(synopsis "Fancy test runner, including support for golden tests")
(description
- "This package provides a fancy test runner and support for @dfn{golden
+ "This package provides a fancy test runner and support for @dfn{golden
testing}. A golden test is an IO action that writes its result to a file. To
pass the test, this output file should be identical to the corresponding
``golden'' file, which contains the correct result for the test. The test
@@ -1246,3 +1246,22 @@ (define-public ghc-tasty-silver
result of golden tests.")
(license license:expat)))
+(define-public ghc-microspec
+ (package
+ (name "ghc-microspec")
+ (version "0.2.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "microspec" version))
+ (sha256
+ (base32 "0615gdbsk7i3w71adjp69zabw4mli965wffm2h846hp6pjj31xcb"))))
+ (build-system haskell-build-system)
+ (inputs (list ghc-quickcheck))
+ (home-page "http://hackage.haskell.org/package/microspec")
+ (synopsis "Tiny QuickCheck test library with minimal dependencies")
+ (description
+ "This package provides a tiny (1 module, <500 lines) property-based
+(and unit) testing library with minimal dependencies.")
+ (license license:bsd-3)))
+
--
2.36.1
L
L
Lars-Dominik Braun wrote on 30 Jun 2022 09:45
Re: [bug#56310] Add tidal
(address . control@debbugs.gnu.org)
Yr1UmUXvaHB17eie@noor.fritz.box
merge 56310 56313 56315 56314
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 56315@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56315
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch