Add tidal

  • Open
  • quality assurance status badge
Details
3 participants
  • Lars-Dominik Braun
  • WinterHound
  • Winter Hound
Owner
unassigned
Submitted by
WinterHound
Severity
normal
Merged with
W
W
WinterHound wrote on 30 Jun 2022 06:09
(address . guix-patches@gnu.org)(name . WinterHound)(address . winterhound@yandex.com)
20220630040922.5425-1-winterhound@yandex.com
---
gnu/packages/haskell-apps.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 3591d9d67e..24a8b95073 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -972,3 +972,30 @@ (define-public stylish-haskell
default)
@end itemize")
(license license:bsd-3)))
+
+(define-public tidal
+ (package
+ (name "tidal")
+ (version "1.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "tidal" version))
+ (sha256
+ (base32 "19gh5l8hna9s4k5qw98qcr1s9wpqi6mf2kxd4kz6lzl3yxj56y6z"))))
+ (build-system haskell-build-system)
+ (inputs
+ (list ghc-colour
+ ghc-hosc
+ ghc-network
+ ghc-bifunctors
+ ghc-clock
+ ghc-primitive
+ ghc-random
+ ghc-hint
+ ghc-async))
+ (native-inputs (list ghc-microspec))
+ (home-page "http://tidalcycles.org/")
+ (synopsis "Pattern language for improvised music")
+ (description "Tidal is a domain specific language for live coding patterns.")
+ (license license:gpl3)))
--
2.36.1
L
L
Lars-Dominik Braun wrote on 30 Jun 2022 09:45
(address . control@debbugs.gnu.org)
Yr1UmUXvaHB17eie@noor.fritz.box
merge 56310 56313 56315 56314
W
W
Winter Hound wrote on 10 Jul 2022 13:30
Seems like somebody has already made this. But not committed yet.
(name . 56310@debbugs.gnu.org)(address . 56310@debbugs.gnu.org)
49841657452478@mail.yandex.com
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 56310@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56310
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch