(address . guix-patches@gnu.org)(name . WinterHound)(address . winterhound@yandex.com)
---
gnu/packages/haskell-apps.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 3591d9d67e..24a8b95073 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -972,3 +972,30 @@ (define-public stylish-haskell
default)
@end itemize")
(license license:bsd-3)))
+
+(define-public tidal
+ (package
+ (name "tidal")
+ (version "1.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "tidal" version))
+ (sha256
+ (base32 "19gh5l8hna9s4k5qw98qcr1s9wpqi6mf2kxd4kz6lzl3yxj56y6z"))))
+ (build-system haskell-build-system)
+ (inputs
+ (list ghc-colour
+ ghc-hosc
+ ghc-network
+ ghc-bifunctors
+ ghc-clock
+ ghc-primitive
+ ghc-random
+ ghc-hint
+ ghc-async))
+ (native-inputs (list ghc-microspec))
+ (home-page "http://tidalcycles.org/")
+ (synopsis "Pattern language for improvised music")
+ (description "Tidal is a domain specific language for live coding patterns.")
+ (license license:gpl3)))
--
2.36.1