(address . guix-patches@gnu.org)(name . WinterHound)(address . winterhound@yandex.com)
---
gnu/packages/haskell-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)
Toggle diff (28 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index eb1528b4a2..2198b3fa26 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16121,3 +16121,21 @@ (define-public ghc-singleton-bool
"This package provides Type-level booleans.")
(license license:bsd-3)))
+(define-public ghc-hosc
+ (package
+ (name "ghc-hosc")
+ (version "0.19.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "hosc" version))
+ (sha256
+ (base32 "08q218p1skqxwa7f55nsgmv9z8digf1c0f1wi6p562q6d4i044z7"))))
+ (build-system haskell-build-system)
+ (inputs (list ghc-blaze-builder
+ ghc-network
+ ghc-data-binary-ieee754))
+ (home-page "http://rohandrape.net/?t=hosc")
+ (synopsis "Haskell Open Sound Control")
+ (description "hosc implements a subset of the Open Sound Control byte protocol")
+ (license license:gpl3)))
--
2.36.1