(address . guix-patches@gnu.org)(name . luishgh)(address . 51053603+luishgh@users.noreply.github.com)
From: luishgh <51053603+luishgh@users.noreply.github.com>
* gnu/packages/emacs-xyz.scm (emacs-explain-pause-mode): Fix failing tests.
---
gnu/packages/emacs-xyz.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)
Toggle diff (29 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 590330ac4f..8fc1d38193 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4709,7 +4709,7 @@ (define-public emacs-explain-pause-mode
(revision "0"))
(package
(name "emacs-explain-pause-mode")
- (version (git-version "0.1" revision commit))
+ (version (git-version "0.2" revision commit))
(source
(origin
(method git-fetch)
@@ -4724,6 +4724,13 @@ (define-public emacs-explain-pause-mode
(list emacs-buttercup))
(arguments
'(#:tests? #t
+ #:phases
+ (modify-phases %standard-phases
+ ;; This causes the byte-compilation before unit-tests to fail
+ (add-after 'unpack 'remove-error-on-warn
+ (lambda _
+ (substitute* "Makefile"
+ (("--eval '\\(setq byte-compile-error-on-warn t\\)'") "")))))
;; Don't run case-tests as they will fail to create sockets because
;; the path is too long
#:test-command '("make" "byte-compile" "unit-tests")
--
2.36.0