[PATCH 0/2] Fix emacs packages failing to build

  • Done
  • quality assurance status badge
Details
3 participants
  • luishgh
  • Nicolas Goaziou
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
luishgh
Severity
normal
Merged with
L
L
luishgh wrote on 17 May 2022 01:45
(address . guix-patches@gnu.org)(name . luishgh)(address . luishenriquegh2701@gmail.com)
20220516234553.24531-1-luishenriquegh2701@gmail.com
Hi guix,

this patch series fix a couple of emacs packages that are currently failing to build.

luishgh (2):
gnu: emacs-racer: Update to 1e63e98.
gnu: emacs-explain-pause-mode: Fix failing tests.

gnu/packages/emacs-xyz.scm | 96 +++++++++++++++++++++-----------------
1 file changed, 52 insertions(+), 44 deletions(-)

--
2.36.0
L
L
luishgh wrote on 17 May 2022 01:49
[PATCH 1/2] gnu: emacs-racer: Update to 1e63e98.
(address . 55466@debbugs.gnu.org)(name . luishgh)(address . 51053603+luishgh@users.noreply.github.com)
20220516234912.25005-1-luishenriquegh2701@gmail.com
From: luishgh <51053603+luishgh@users.noreply.github.com>

* gnu/packages/emacs-xyz.scm (emacs-racer): Update to 1e63e98.
---
gnu/packages/emacs-xyz.scm | 87 +++++++++++++++++++-------------------
1 file changed, 44 insertions(+), 43 deletions(-)

Toggle diff (103 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8d66278b8f..590330ac4f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22487,52 +22487,53 @@ (define-public emacs-adoc-mode
(license license:gpl2+)))
(define-public emacs-racer
- (package
- (name "emacs-racer")
- (version "1.2")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/racer-rust/emacs-racer")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0xj5iki10cg8j8vvqjlw6lfx97k3agwirhchcjnzbnkry48x9qi6"))))
- (arguments
- `(#:tests? #t
- #:test-command '("make" "test")
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'fix-makefile
- (lambda _
- (substitute* "Makefile"
- (("\\$\\{CASK\\} exec ") ""))
- #t))
- ;; Two tests are failing with Emacs 27, as reported here:
- ;; <https://github.com/racer-rust/emacs-racer/issues/136>. Disable
- ;; them.
- (add-before 'check 'fix-failing-tests
- (lambda _
- (substitute* "test/racer-test.el"
- (("`Write`") "Write")
- (("^\\\\\\[`str\\]:.*") "")
- ((" \\[`str`\\]") " str"))
- #t)))))
- (native-inputs
- (list emacs-ert-runner emacs-undercover))
- (propagated-inputs
- (list emacs-dash emacs-f emacs-pos-tip emacs-rust-mode emacs-s))
- (build-system emacs-build-system)
- (home-page "https://github.com/racer-rust/emacs-racer")
- (synopsis "Racer support for Emacs")
- (description
- "This is the official Emacs package for Racer. It supports code
+ (let ((commit "1e63e98626737ea9b662d4a9b1ffd6842b1c648c")
+ (revision "0"))
+ (package
+ (name "emacs-racer")
+ (version (git-version "1.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/racer-rust/emacs-racer")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12a429lajk09qp1jxgig54p8z6wndfgr4jwdmgkc9s2df9sw02d3"))))
+ (arguments
+ `(#:tests? #t
+ #:test-command '("ert-runner")
+ #:phases
+ (modify-phases %standard-phases
+ ;; Two tests are failing with Emacs 27, as reported here:
+ ;; <https://github.com/racer-rust/emacs-racer/issues/136>. Disable
+ ;; them.
+ (add-before 'check 'fix-failing-tests
+ (lambda _
+ (substitute* "test/racer-test.el"
+ (("`Write`") "Write")
+ (("^\\\\\\[`str\\]:.*") "")
+ ((" \\[`str`\\]") " str"))
+ #t))
+ ;; Added to replicate original behavior of "make test"
+ (add-after 'build 'test-after-build
+ (lambda _
+ (invoke "ert-runner"))))))
+ (native-inputs
+ (list emacs-ert-runner emacs-undercover))
+ (propagated-inputs
+ (list emacs-dash emacs-f emacs-pos-tip emacs-rust-mode emacs-s))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/racer-rust/emacs-racer")
+ (synopsis "Racer support for Emacs")
+ (description
+ "This is the official Emacs package for Racer. It supports code
completion of variables, functions and modules. It can also jump to
definition of functions and types, and show a help buffer based on the
docstring of the thing at point.")
- (license license:expat)))
+ (license license:expat))))
(define-public emacs-rust-mode
(package
--
2.36.0
L
L
luishgh wrote on 17 May 2022 01:49
[PATCH 2/2] gnu: emacs-explain-pause-mode: Fix failing tests.
(address . 55466@debbugs.gnu.org)(name . luishgh)(address . 51053603+luishgh@users.noreply.github.com)
20220516234912.25005-2-luishenriquegh2701@gmail.com
From: luishgh <51053603+luishgh@users.noreply.github.com>

* gnu/packages/emacs-xyz.scm (emacs-explain-pause-mode): Fix failing tests.
---
gnu/packages/emacs-xyz.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 590330ac4f..8fc1d38193 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4709,7 +4709,7 @@ (define-public emacs-explain-pause-mode
(revision "0"))
(package
(name "emacs-explain-pause-mode")
- (version (git-version "0.1" revision commit))
+ (version (git-version "0.2" revision commit))
(source
(origin
(method git-fetch)
@@ -4724,6 +4724,13 @@ (define-public emacs-explain-pause-mode
(list emacs-buttercup))
(arguments
'(#:tests? #t
+ #:phases
+ (modify-phases %standard-phases
+ ;; This causes the byte-compilation before unit-tests to fail
+ (add-after 'unpack 'remove-error-on-warn
+ (lambda _
+ (substitute* "Makefile"
+ (("--eval '\\(setq byte-compile-error-on-warn t\\)'") "")))))
;; Don't run case-tests as they will fail to create sockets because
;; the path is too long
#:test-command '("make" "byte-compile" "unit-tests")
--
2.36.0
T
T
Tobias Geerinckx-Rice wrote on 17 May 2022 01:59
Re: Apologies
(address . control@debbugs.gnu.org)(name . Luis Henrique Gomes Higino)(address . luishenriquegh2701@gmail.com)
1A8465C6-B903-480F-BF15-21999AFC5A51@tobias.gr
merge 55466 55467 55468
thanks

No problem; easily fixed!

Kind regards,

T G-R

Sent on the go. Excuse or enjoy my brevity.
L
L
Luis Henrique Gomes Higino wrote on 17 May 2022 03:48
[PATCH v2 1/2] gnu: emacs-racer: Update to 1e63e98.
(address . 55466@debbugs.gnu.org)(name . luishgh)(address . 51053603+luishgh@users.noreply.github.com)
20220517014845.10441-1-luishenriquegh2701@gmail.com
From: luishgh <51053603+luishgh@users.noreply.github.com>

* gnu/packages/emacs-xyz.scm (emacs-racer): Update to 1e63e98.
---

I noticed that this comment above the `fix-failing-tests' build phase
suggests it is not necessary with Emacs 28, so I removed it and the
package built just fine.

gnu/packages/emacs-xyz.scm | 77 +++++++++++++++++---------------------
1 file changed, 34 insertions(+), 43 deletions(-)

Toggle diff (93 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8d66278b8f..c8a19e5e9e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22487,52 +22487,43 @@ (define-public emacs-adoc-mode
(license license:gpl2+)))
(define-public emacs-racer
- (package
- (name "emacs-racer")
- (version "1.2")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/racer-rust/emacs-racer")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0xj5iki10cg8j8vvqjlw6lfx97k3agwirhchcjnzbnkry48x9qi6"))))
- (arguments
- `(#:tests? #t
- #:test-command '("make" "test")
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'fix-makefile
- (lambda _
- (substitute* "Makefile"
- (("\\$\\{CASK\\} exec ") ""))
- #t))
- ;; Two tests are failing with Emacs 27, as reported here:
- ;; <https://github.com/racer-rust/emacs-racer/issues/136>. Disable
- ;; them.
- (add-before 'check 'fix-failing-tests
- (lambda _
- (substitute* "test/racer-test.el"
- (("`Write`") "Write")
- (("^\\\\\\[`str\\]:.*") "")
- ((" \\[`str`\\]") " str"))
- #t)))))
- (native-inputs
- (list emacs-ert-runner emacs-undercover))
- (propagated-inputs
- (list emacs-dash emacs-f emacs-pos-tip emacs-rust-mode emacs-s))
- (build-system emacs-build-system)
- (home-page "https://github.com/racer-rust/emacs-racer")
- (synopsis "Racer support for Emacs")
- (description
- "This is the official Emacs package for Racer. It supports code
+ (let ((commit "1e63e98626737ea9b662d4a9b1ffd6842b1c648c")
+ (revision "0"))
+ (package
+ (name "emacs-racer")
+ (version (git-version "1.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/racer-rust/emacs-racer")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12a429lajk09qp1jxgig54p8z6wndfgr4jwdmgkc9s2df9sw02d3"))))
+ (arguments
+ `(#:tests? #t
+ #:test-command '("ert-runner")
+ #:phases
+ (modify-phases %standard-phases
+ ;; Added to replicate original behavior of "make test"
+ (add-after 'build 'test-after-build
+ (lambda _
+ (invoke "ert-runner"))))))
+ (native-inputs
+ (list emacs-ert-runner emacs-undercover))
+ (propagated-inputs
+ (list emacs-dash emacs-f emacs-pos-tip emacs-rust-mode emacs-s))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/racer-rust/emacs-racer")
+ (synopsis "Racer support for Emacs")
+ (description
+ "This is the official Emacs package for Racer. It supports code
completion of variables, functions and modules. It can also jump to
definition of functions and types, and show a help buffer based on the
docstring of the thing at point.")
- (license license:expat)))
+ (license license:expat))))
(define-public emacs-rust-mode
(package
--
2.36.0
L
L
Luis Henrique Gomes Higino wrote on 17 May 2022 03:48
[PATCH v2 2/2] gnu: emacs-explain-pause-mode: Fix failing tests.
(address . 55466@debbugs.gnu.org)(name . luishgh)(address . 51053603+luishgh@users.noreply.github.com)
20220517014845.10441-2-luishenriquegh2701@gmail.com
From: luishgh <51053603+luishgh@users.noreply.github.com>

* gnu/packages/emacs-xyz.scm (emacs-explain-pause-mode): Fix failing tests.
---
gnu/packages/emacs-xyz.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c8a19e5e9e..6dfb1ea3a1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4709,7 +4709,7 @@ (define-public emacs-explain-pause-mode
(revision "0"))
(package
(name "emacs-explain-pause-mode")
- (version (git-version "0.1" revision commit))
+ (version (git-version "0.2" revision commit))
(source
(origin
(method git-fetch)
@@ -4724,6 +4724,13 @@ (define-public emacs-explain-pause-mode
(list emacs-buttercup))
(arguments
'(#:tests? #t
+ #:phases
+ (modify-phases %standard-phases
+ ;; This causes the byte-compilation before unit-tests to fail
+ (add-after 'unpack 'remove-error-on-warn
+ (lambda _
+ (substitute* "Makefile"
+ (("--eval '\\(setq byte-compile-error-on-warn t\\)'") "")))))
;; Don't run case-tests as they will fail to create sockets because
;; the path is too long
#:test-command '("make" "byte-compile" "unit-tests")
--
2.36.0
N
N
Nicolas Goaziou wrote on 17 May 2022 09:16
Re: [bug#55466] [PATCH v2 1/2] gnu: emacs-racer: Update to 1e63e98.
(name . Luis Henrique Gomes Higino)(address . luishenriquegh2701@gmail.com)
87sfp8ljct.fsf@nicolasgoaziou.fr
Hello,

Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-racer): Update to 1e63e98.

I added more information in the commit message (i.e., the phases being
removed).
Toggle quote (7 lines)
> + #:phases
> + (modify-phases %standard-phases
> + ;; Added to replicate original behavior of "make test"
> + (add-after 'build 'test-after-build
> + (lambda _
> + (invoke "ert-runner"))))))

I removed the phase above because it forces running tests and it is
a duplicate of #:test-command.

Regards,
--
Nicolas Goaziou
N
N
Nicolas Goaziou wrote on 17 May 2022 09:17
Re: [bug#55466] [PATCH v2 2/2] gnu: emacs-explain-pause-mode: Fix failing tests.
(name . Luis Henrique Gomes Higino)(address . luishenriquegh2701@gmail.com)
87mtfglja1.fsf@nicolasgoaziou.fr
Hello,

Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com> writes:

Toggle quote (5 lines)
> (package
> (name "emacs-explain-pause-mode")
> - (version (git-version "0.1" revision commit))
> + (version (git-version "0.2" revision commit))

I removed this ninja version bump. The main file still references "0.1".

Regards,
--
Nicolas Goaziou
N
N
Nicolas Goaziou wrote on 17 May 2022 09:18
Re: [bug#55466] [PATCH 0/2] Fix emacs packages failing to build
(name . luishgh)(address . luishenriquegh2701@gmail.com)(address . 55466-done@debbugs.gnu.org)
87ilq4lj98.fsf@nicolasgoaziou.fr
Hello,

luishgh <luishenriquegh2701@gmail.com> writes:

Toggle quote (3 lines)
> this patch series fix a couple of emacs packages that are currently
> failing to build.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
L
L
Luis Henrique Gomes Higino wrote on 17 May 2022 16:38
Re: [bug#55466] [PATCH v2 2/2] gnu: emacs-explain-pause-mode: Fix failing tests.
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 55466@debbugs.gnu.org)
87mtfgqknx.fsf@gmail.com
Hi Nicolas,

thanks for your feedback and for enhancing my patches before
applying them! I just have one question:

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (15 lines)
> Hello,
>
> Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
> writes:
>
>> (package
>> (name "emacs-explain-pause-mode")
>> - (version (git-version "0.1" revision commit))
>> + (version (git-version "0.2" revision commit))
>
> I removed this ninja version bump. The main file still
> references "0.1".
>
> Regards,

That's funny, because in the README [0] it says the development
version is 0.2, that's why I bumped it. Which should we use?

0:

Regards,
--
Luis H. Higino
N
N
Nicolas Goaziou wrote on 17 May 2022 22:02
(name . Luis Henrique Gomes Higino)(address . luishenriquegh2701@gmail.com)(address . 55466@debbugs.gnu.org)
87zgjgj5be.fsf@nicolasgoaziou.fr
Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com> writes:

Toggle quote (3 lines)
> That's funny, because in the README [0] it says the development
> version is 0.2, that's why I bumped it. Which should we use?

We usually refer to the Version keyword in main file when there is no
tag. Note that (git-version "0.2" revision commit) is actually a greater
version than "0.2", so it could be confusing when "0.2" is eventually
released.
L
L
Luis Henrique Gomes Higino wrote on 17 May 2022 22:24
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 55466@debbugs.gnu.org)
87ilq3rjmy.fsf@gmail.com
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (14 lines)
> Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
> writes:
>
>> That's funny, because in the README [0] it says the development
>> version is 0.2, that's why I bumped it. Which should we use?
>
> We usually refer to the Version keyword in main file when there
> is no
> tag. Note that (git-version "0.2" revision commit) is actually a
> greater
> version than "0.2", so it could be confusing when "0.2" is
> eventually
> released.

Makes sense, thanks again Nicolas!

Regards,
--
Luis H. Higino
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55466@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55466
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch