[PATCH 1/2] gnu: emacs-racer: Update to 1e63e98.

  • Done
  • quality assurance status badge
Details
3 participants
  • luishgh
  • Nicolas Goaziou
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
luishgh
Severity
normal
Merged with
L
L
luishgh wrote on 17 May 2022 01:45
(address . guix-patches@gnu.org)(name . luishgh)(address . 51053603+luishgh@users.noreply.github.com)
20220516234553.24531-2-luishenriquegh2701@gmail.com
From: luishgh <51053603+luishgh@users.noreply.github.com>

* gnu/packages/emacs-xyz.scm (emacs-racer): Update to 1e63e98.
---
gnu/packages/emacs-xyz.scm | 87 +++++++++++++++++++-------------------
1 file changed, 44 insertions(+), 43 deletions(-)

Toggle diff (103 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8d66278b8f..590330ac4f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22487,52 +22487,53 @@ (define-public emacs-adoc-mode
(license license:gpl2+)))
(define-public emacs-racer
- (package
- (name "emacs-racer")
- (version "1.2")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/racer-rust/emacs-racer")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0xj5iki10cg8j8vvqjlw6lfx97k3agwirhchcjnzbnkry48x9qi6"))))
- (arguments
- `(#:tests? #t
- #:test-command '("make" "test")
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'fix-makefile
- (lambda _
- (substitute* "Makefile"
- (("\\$\\{CASK\\} exec ") ""))
- #t))
- ;; Two tests are failing with Emacs 27, as reported here:
- ;; <https://github.com/racer-rust/emacs-racer/issues/136>. Disable
- ;; them.
- (add-before 'check 'fix-failing-tests
- (lambda _
- (substitute* "test/racer-test.el"
- (("`Write`") "Write")
- (("^\\\\\\[`str\\]:.*") "")
- ((" \\[`str`\\]") " str"))
- #t)))))
- (native-inputs
- (list emacs-ert-runner emacs-undercover))
- (propagated-inputs
- (list emacs-dash emacs-f emacs-pos-tip emacs-rust-mode emacs-s))
- (build-system emacs-build-system)
- (home-page "https://github.com/racer-rust/emacs-racer")
- (synopsis "Racer support for Emacs")
- (description
- "This is the official Emacs package for Racer. It supports code
+ (let ((commit "1e63e98626737ea9b662d4a9b1ffd6842b1c648c")
+ (revision "0"))
+ (package
+ (name "emacs-racer")
+ (version (git-version "1.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/racer-rust/emacs-racer")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12a429lajk09qp1jxgig54p8z6wndfgr4jwdmgkc9s2df9sw02d3"))))
+ (arguments
+ `(#:tests? #t
+ #:test-command '("ert-runner")
+ #:phases
+ (modify-phases %standard-phases
+ ;; Two tests are failing with Emacs 27, as reported here:
+ ;; <https://github.com/racer-rust/emacs-racer/issues/136>. Disable
+ ;; them.
+ (add-before 'check 'fix-failing-tests
+ (lambda _
+ (substitute* "test/racer-test.el"
+ (("`Write`") "Write")
+ (("^\\\\\\[`str\\]:.*") "")
+ ((" \\[`str`\\]") " str"))
+ #t))
+ ;; Added to replicate original behavior of "make test"
+ (add-after 'build 'test-after-build
+ (lambda _
+ (invoke "ert-runner"))))))
+ (native-inputs
+ (list emacs-ert-runner emacs-undercover))
+ (propagated-inputs
+ (list emacs-dash emacs-f emacs-pos-tip emacs-rust-mode emacs-s))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/racer-rust/emacs-racer")
+ (synopsis "Racer support for Emacs")
+ (description
+ "This is the official Emacs package for Racer. It supports code
completion of variables, functions and modules. It can also jump to
definition of functions and types, and show a help buffer based on the
docstring of the thing at point.")
- (license license:expat)))
+ (license license:expat))))
(define-public emacs-rust-mode
(package
--
2.36.0
L
L
Luis Henrique Gomes Higino wrote on 17 May 2022 01:50
Apologies
(address . 55467@debbugs.gnu.org)(address . 55468@debbugs.gnu.org)
87r14tqbjy.fsf@gmail.com
Hi guix,

sent the patches as separate issues :/. The right one is
https://issues.guix.gnu.org/55466.Sorry for the inconvenience.

Regards,
--
Luis H. Higino
T
T
Tobias Geerinckx-Rice wrote on 17 May 2022 01:59
(address . control@debbugs.gnu.org)(name . Luis Henrique Gomes Higino)(address . luishenriquegh2701@gmail.com)
1A8465C6-B903-480F-BF15-21999AFC5A51@tobias.gr
merge 55466 55467 55468
thanks

No problem; easily fixed!

Kind regards,

T G-R

Sent on the go. Excuse or enjoy my brevity.
N
N
Nicolas Goaziou wrote on 17 May 2022 09:19
Re: [bug#55467] [PATCH 1/2] gnu: emacs-racer: Update to 1e63e98.
(name . luishgh)(address . luishenriquegh2701@gmail.com)
87ee0slj7t.fsf@nicolasgoaziou.fr
luishgh <luishenriquegh2701@gmail.com> writes:

Toggle quote (4 lines)
> From: luishgh <51053603+luishgh@users.noreply.github.com>
>
> * gnu/packages/emacs-xyz.scm (emacs-racer): Update to 1e63e98.

Closing, as a duplicate of bug#55466
?
Your comment

This issue is archived.

To comment on this conversation send an email to 55467@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 55467
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch