[PATCH 3/5] gnu: python-vedo: Honor #:tests? flag.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Paul A. Patience
Owner
unassigned
Submitted by
Paul A. Patience
Severity
normal
Merged with
P
P
Paul A. Patience wrote on 12 Apr 2022 03:22
(address . guix-patches@gnu.org)(name . Paul A. Patience)(address . paul@apatience.com)
20220412012143.30573-4-paul@apatience.com
* gnu/packages/python-science.scm (python-vedo)[arguments]: Adjust
custom 'check phase to honor the #:tests? flag. Also remove its trailing
boolean.
---
gnu/packages/python-science.scm | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 07d713e013..4538904b68 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -876,15 +876,15 @@ (define-public python-vedo
(add-after 'build 'mpi-setup
,%openmpi-setup)
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (setenv "HOME" (getcwd))
- (add-installed-pythonpath inputs outputs)
- (with-directory-excursion "tests"
- (for-each (lambda (dir)
- (with-directory-excursion dir
- (invoke "./run_all.sh")))
- '("common" "dolfin")))
- #t)))))
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (setenv "HOME" (getcwd))
+ (add-installed-pythonpath inputs outputs)
+ (with-directory-excursion "tests"
+ (for-each (lambda (dir)
+ (with-directory-excursion dir
+ (invoke "./run_all.sh")))
+ '("common" "dolfin")))))))))
(inputs ; for the check phase
`(("dolfin" ,fenics)
("pkgconfig" ,python-pkgconfig)
--
2.35.1
L
L
Liliana Marie Prikler wrote on 12 Apr 2022 08:00
(address . control@debbugs.gnu.org)
dbe14dee126fadb922662ce8d2a6695ac1c4f901.camel@ist.tugraz.at
merge 54869 54870 54871 54872 54873 54874
thanks
?
Your comment

This issue is archived.

To comment on this conversation send an email to 54872@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 54872
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch