[PATCH 1/5] gnu: fenics-dolfin: Honor #:tests? flag.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Paul A. Patience
Owner
unassigned
Submitted by
Paul A. Patience
Severity
normal
Merged with
P
P
Paul A. Patience wrote on 12 Apr 2022 03:22
(address . guix-patches@gnu.org)(name . Paul A. Patience)(address . paul@apatience.com)
20220412012143.30573-2-paul@apatience.com
* gnu/packages/simulation.scm (fenics-dolfin)[arguments]: Adjust custom
'check phase to honor the #:tests? flag.
---
gnu/packages/simulation.scm | 13 +++++++------
1 file changed, 7 insertions(+), 6 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 3f2d8e136d..aebb6be15e 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -549,12 +549,13 @@ (define-public fenics-dolfin
")\n") port)))
#t))
(replace 'check
- (lambda _
- (and (invoke "make" "unittests")
- (invoke "make" "demos")
- (invoke "ctest" "-R" "unittests")
- (invoke "ctest" "-R" "demo" "-R" "serial")
- (invoke "ctest" "-R" "demo" "-R" "mpi")))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (and (invoke "make" "unittests")
+ (invoke "make" "demos")
+ (invoke "ctest" "-R" "unittests")
+ (invoke "ctest" "-R" "demo" "-R" "serial")
+ (invoke "ctest" "-R" "demo" "-R" "mpi"))))))))
(home-page "https://bitbucket.org/fenics-project/dolfin/")
(synopsis "Problem solving environment for differential equations")
(description
--
2.35.1
L
L
Liliana Marie Prikler wrote on 12 Apr 2022 08:00
(address . control@debbugs.gnu.org)
dbe14dee126fadb922662ce8d2a6695ac1c4f901.camel@ist.tugraz.at
merge 54869 54870 54871 54872 54873 54874
thanks
?