(address . guix-patches@gnu.org)
Hello Guixers,
this patch adds libtree[1] v3.0.0-rc6.
- avp
References:
From 98428689a669def9499cce2883ac33202fa3ac84 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Mon, 13 Dec 2021 23:34:29 +0300
Subject: [PATCH] gnu: Add libtree
* gnu/packages/linux.scm (libtree): New variable.
---
gnu/packages/linux.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)
Toggle diff (54 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1e51dd8d83..84e7042604 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -53,6 +53,7 @@
;;; Copyright © 2021 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;; Copyright © 2021 Olivier Dion <olivier.dion@polymtl.ca>
+;;; Copyright © 2021 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8690,3 +8691,39 @@ older system-wide @file{/sys} interface.")
(license (list license:lgpl2.1+ ;; libgpiod
license:gpl2+ ;; gpio-tools
license:lgpl3+)))) ;; C++ bindings
+
+(define-public libtree
+ (package
+ (name "libtree")
+ (version "3.0.0-rc6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/haampie/libtree")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1i2v70n0pn7aqa4k2pr049zwp1sf8m975pgpgmnr3d53806zchgs"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (delete 'configure)
+ (add-before 'build 'patch
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("\\$\\(DESTDIR\\)\\$\\(BINDIR\\)")
+ (format #f "~a/bin/" (assoc-ref outputs "out"))))))
+ (replace 'build
+ (lambda _
+ (setenv "CC" "gcc")
+ (setenv "LDFLAGS" "-static")
+ (invoke "make"))))))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/haampie/libtree")
+ (synopsis "@command{ldd} as a tree")
+ (description
+ "This tool turns @command{ldd} into a tree and explains how shared
+libraries are found or why they cannot be located.")
+ (license license:expat)))
--
2.25.1
--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
Home page: https://memory-heap.org/~avp/
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----
iQEzBAEBCgAdFiEE0MLqwTMQgi2Y3rV86cWi2QiYoC8FAmG3sDoACgkQ6cWi2QiY
oC/TgggAj0rwqgmypMH1VWiWH5opUiHWiV1VRfaFgwJHqbAKGsF3Zjlto1BHNQx9
Cn9W3xS+l1cffbpcKoFHqYZDHF6arjwWt1Yjtf+06KHEdw1O29cznrVl2W+0U83i
Zzp3D+YA9mOeemc6FyqzkGAenC3N0lUsLNkObzgFx2t+168taq99KdZ7HW3jfeRa
bRrXg0JX7wVrmEP/5ipBQU2JvPj/BDKuFqAY1j92NI/OmUBbdJATpbQ0xHhbGcNu
2td8cURNCv05BG0viBUOCShCg+M4XBHLvBif4qFBU/UyhtHA44OyJeL5h7hMhNTX
6/5CEVIME2dpBiKo1C5YKjaIE+iIxw==
=sVzF
-----END PGP SIGNATURE-----