[PATCH 0/2] gnu: Add sqlitebrowser.

  • Done
  • quality assurance status badge
Details
2 participants
  • Foo Chuan Wei
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
Foo Chuan Wei
Severity
normal
F
F
Foo Chuan Wei wrote on 20 Nov 2021 16:37
(address . guix-patches@gnu.org)
PU1PR01MB2155C908FC5C1D89628553048D9D9@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
This patch series adds sqlitebrowser. There have been two previous
patches [1] [2] that were not accepted into Guix because they did not
unbundle the third-party libraries bundled with sqlitebrowser. This
patch does not use the bundled libraries.


Foo Chuan Wei (2):
gnu: Add qhexedit.
gnu: Add sqlitebrowser.

gnu/packages/databases.scm | 91 ++++++++++++++++++++++++++++++++++++++
gnu/packages/qt.scm | 46 +++++++++++++++++++
2 files changed, 137 insertions(+)


base-commit: 5b96e9651029d68c17a05e9ca75b25a0f129ecca
--
2.25.1
F
F
Foo Chuan Wei wrote on 20 Nov 2021 16:40
[PATCH 1/2] gnu: Add qhexedit.
(address . 52000@debbugs.gnu.org)
PU1PR01MB2155AA252ED1AC903AAD39D48D9D9@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/qt.scm (qhexedit): New variable.
---
gnu/packages/qt.scm | 46 +++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (66 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 4625d2220d..a645875456 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3065,6 +3066,51 @@ being fully customizable and easy to extend.")
;; be used.
(license (list license:gpl2 license:gpl3))))
+(define-public qhexedit
+ (package
+ (name "qhexedit")
+ (version "0.8.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Simsys/qhexedit2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1j333kiwhbidphdx86yilkaivgl632spfh6fqx93bc80gk4is3xa"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "src/qhexedit.pro"
+ (("^unix:DESTDIR = /usr/lib")
+ (string-append "unix:DESTDIR = "
+ (assoc-ref outputs "out") "/lib")))))
+ (replace 'configure
+ (lambda _
+ (chdir "src")
+ (invoke "qmake" "qhexedit.pro")))
+ (add-after 'install 'install-headers
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (include-dir (string-append out "/include")))
+ (mkdir-p include-dir)
+ (for-each (lambda (file)
+ (install-file file include-dir))
+ (find-files "." "\\.h$"))))))))
+ (native-inputs
+ `(("qtbase" ,qtbase-5)
+ ("qttools" ,qttools)))
+ (home-page "https://simsys.github.io")
+ (synopsis "Binary editor widget for Qt")
+ (description
+ "@code{QHexEdit} is a hex editor widget for the Qt framework. It is a
+simple editor for binary data, just like @code{QPlainTextEdit} is for text
+data.")
+ (license license:lgpl2.1)))
(define-public soqt
(let ((commit-ref "fb8f655632bb9c9c60e0ff9fa69a5ba22d3ff99d")
--
2.25.1
F
F
Foo Chuan Wei wrote on 20 Nov 2021 16:44
[PATCH 2/2] gnu: Add sqlitebrowser.
(address . 52000@debbugs.gnu.org)
PU1PR01MB2155EDB08E52C857594B4B768D9D9@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
Attachment: file
F
F
Foo Chuan Wei wrote on 21 Nov 2021 11:36
[PATCH v2 1/2] gnu: Add qhexedit.
(address . 52000@debbugs.gnu.org)
PU1PR01MB21550DF2CFE06F9B9C519EA18D9E9@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/qt.scm (qhexedit): New variable.
---
Changes relative to PATCH v1:
* Move qtbase-5 from native-inputs to inputs.

gnu/packages/qt.scm | 47 +++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (69 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 4625d2220d..fb783d356e 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3065,6 +3066,52 @@ being fully customizable and easy to extend.")
;; be used.
(license (list license:gpl2 license:gpl3))))
+(define-public qhexedit
+ (package
+ (name "qhexedit")
+ (version "0.8.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Simsys/qhexedit2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1j333kiwhbidphdx86yilkaivgl632spfh6fqx93bc80gk4is3xa"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "src/qhexedit.pro"
+ (("^unix:DESTDIR = /usr/lib")
+ (string-append "unix:DESTDIR = "
+ (assoc-ref outputs "out") "/lib")))))
+ (replace 'configure
+ (lambda _
+ (chdir "src")
+ (invoke "qmake" "qhexedit.pro")))
+ (add-after 'install 'install-headers
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (include-dir (string-append out "/include")))
+ (mkdir-p include-dir)
+ (for-each (lambda (file)
+ (install-file file include-dir))
+ (find-files "." "\\.h$"))))))))
+ (inputs
+ `(("qtbase" ,qtbase-5)))
+ (native-inputs
+ `(("qttools" ,qttools)))
+ (home-page "https://simsys.github.io")
+ (synopsis "Binary editor widget for Qt")
+ (description
+ "@code{QHexEdit} is a hex editor widget for the Qt framework. It is a
+simple editor for binary data, just like @code{QPlainTextEdit} is for text
+data.")
+ (license license:lgpl2.1)))
(define-public soqt
(let ((commit-ref "fb8f655632bb9c9c60e0ff9fa69a5ba22d3ff99d")

base-commit: 9bfbba8af5b7efb952292c8b7d5e9ee57300c2bc
--
2.25.1
F
F
Foo Chuan Wei wrote on 21 Nov 2021 11:39
[PATCH v2 2/2] gnu: Add sqlitebrowser.
(address . 52000@debbugs.gnu.org)
PU1PR01MB21555CCD24D8047DB80EE7288D9E9@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
Attachment: file
F
F
Foo Chuan Wei wrote on 15 Jan 2022 05:22
[PATCH v3 1/2] gnu: Add qhexedit.
(address . 52000@debbugs.gnu.org)
PU1PR01MB2155031E94AF73CBBCAAA0ED8D559@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
* gnu/packages/qt.scm (qhexedit): New variable.
---
Changes relative to PATCH v2:
* Replace old-style inputs with new-style inputs.
* Update copyright year.

gnu/packages/qt.scm | 45 +++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (67 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 01bf961bbf..223304822a 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3004,6 +3005,50 @@ being fully customizable and easy to extend.")
;; be used.
(license (list license:gpl2 license:gpl3))))
+(define-public qhexedit
+ (package
+ (name "qhexedit")
+ (version "0.8.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Simsys/qhexedit2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1j333kiwhbidphdx86yilkaivgl632spfh6fqx93bc80gk4is3xa"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "src/qhexedit.pro"
+ (("^unix:DESTDIR = /usr/lib")
+ (string-append "unix:DESTDIR = "
+ (assoc-ref outputs "out") "/lib")))))
+ (replace 'configure
+ (lambda _
+ (chdir "src")
+ (invoke "qmake" "qhexedit.pro")))
+ (add-after 'install 'install-headers
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (include-dir (string-append out "/include")))
+ (mkdir-p include-dir)
+ (for-each (lambda (file)
+ (install-file file include-dir))
+ (find-files "." "\\.h$"))))))))
+ (inputs (list qtbase-5))
+ (native-inputs (list qttools))
+ (home-page "https://simsys.github.io")
+ (synopsis "Binary editor widget for Qt")
+ (description
+ "@code{QHexEdit} is a hex editor widget for the Qt framework. It is a
+simple editor for binary data, just like @code{QPlainTextEdit} is for text
+data.")
+ (license license:lgpl2.1)))
(define-public soqt
(let ((commit-ref "fb8f655632bb9c9c60e0ff9fa69a5ba22d3ff99d")

base-commit: 3c43f2b4f54dead73ce19427eb1e364581b7f2e0
--
2.25.1
F
F
Foo Chuan Wei wrote on 15 Jan 2022 05:24
[PATCH v3 2/2] gnu: Add sqlitebrowser.
(address . 52000@debbugs.gnu.org)
PU1PR01MB2155D7675224099B2A405AE58D559@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
Attachment: file
G
G
Guillaume Le Vaillant wrote on 21 Feb 2022 14:51
Re: [bug#52000] [PATCH v3 1/2] gnu: Add qhexedit.
(name . Foo Chuan Wei)(address . chuanwei.foo@hotmail.com)(address . 52000-done@debbugs.gnu.org)
87ee3ws4wf.fsf@kitej
Patch pushed as f2b841403921148eec4502ac23b55c1b75ab021e.
sqlitebrowser is already in Guix
(9183b8142b43082fee55a2730399243dea47ad0a).
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYhOZMA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/3lAD/Y0ITM9be0UoLzdmZpt3h/5Y/pdmRLgNy0N75
d/T3MrgA/2IT1bob45P2EtdtHkLPi1XHozNxVgk0PL1KdZOQ9paz
=emN6
-----END PGP SIGNATURE-----

Closed
?