Add sqlitebrowser

  • Done
  • quality assurance status badge
Details
3 participants
  • Guillaume Le Vaillant
  • pkill9
  • swedebugia
Owner
unassigned
Submitted by
pkill9
Severity
normal
P
P
pkill9 wrote on 22 Feb 2019 09:50
(name . guix-patches)(address . guix-patches@gnu.org)
E1gx6XL-0002Wv-I0@rmmprod05.runbox
Sqlitebrowser is a QT-based graphical browser for Sqlite databases. https://sqlitebrowser.org/

This is the license:


Toggle quote (1 lines)
> DB Browser for SQLite is bi-licensed under the Mozilla Public License
Version 2, as well as the GNU General Public License Version 3 or later.
From 289bb26320cfc64e16f62f8a50470f7bd66a9c14 Mon Sep 17 00:00:00 2001
From: Pkill -9 <pkill9@runbox.com>
Date: Fri, 22 Feb 2019 08:46:55 +0000
Subject: [PATCH] gnu: Add sqlitebrowser.

* gnu/packages/sqlite.scm (sqlitebrowser): New variable.
---
gnu/packages/sqlite.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/sqlite.scm b/gnu/packages/sqlite.scm
index 05d7ce6b9..1dd8ae004 100644
--- a/gnu/packages/sqlite.scm
+++ b/gnu/packages/sqlite.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,10 +31,13 @@
(define-module (gnu packages sqlite)
#:use-module (gnu packages)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages qt)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system cmake)
#:use-module (guix utils)
#:use-module (ice-9 match)
#:use-module (srfi srfi-26))
@@ -114,3 +118,31 @@ is in the public domain.")
"-DSQLITE_ENABLE_UNLOCK_NOTIFY "
"-DSQLITE_ENABLE_DBSTAT_VTAB "
"-DSQLITE_ENABLE_COLUMN_METADATA")))))))
+
+(define-public sqlitebrowser
+ (package
+ (name "sqlitebrowser")
+ (version "3.11.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sqlitebrowser/sqlitebrowser")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pfvq1gzbs6jqlc1w86zcrhf2s9261q56li8j9mbkcv0qgadlyn9"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests
+ (native-inputs
+ `(("qttools" ,qttools)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("sqlite" ,sqlite)))
+ (home-page "https://sqlitebrowser.org")
+ (synopsis "Graphical browser for sqlite databases")
+ (description "DB Browser for SQLite is a visual tool to create, design, and
+edit database files compatible with SQLite. It uses a familiar spreadsheet-like
+interface, and you don't need to learn complicated SQL commands.")
+ (license (list license:mpl2.0 license:gpl3+))))
--
2.20.1
S
S
swedebugia wrote on 23 Feb 2019 10:14
06F46BFC-2A60-468C-BFB0-B944610C0410@riseup.net
pkill9@runbox.com skrev: (22 februari 2019 09:50:27 CET)
Toggle quote (11 lines)
>Sqlitebrowser is a QT-based graphical browser for Sqlite databases.
>https://sqlitebrowser.org/
>
>This is the license:
>
>https://github.com/sqlitebrowser/sqlitebrowser/blob/master/LICENSE
>
>> DB Browser for SQLite is bi-licensed under the Mozilla Public License
>Version 2, as well as the GNU General Public License Version 3 or
>later.

I think the description sounds more like an editor. I suggest the following "Sqlitebrowser is an editor..." for the synopsis.
Replace the DB... name in the description with Sqlitebrowser.
--
Sent from my k-9 mail for Android.
Attachment: file
S
S
swedebugia wrote on 23 Feb 2019 07:00
f2411d82-5b32-9562-56c3-e39aa6ea4e57@riseup.net
On 2019-02-23 10:14, swedebugia wrote:
Toggle quote (20 lines)
> pkill9@runbox.com skrev: (22 februari 2019 09:50:27 CET)
>
> Sqlitebrowser is a QT-based graphical browser for Sqlite databases. https://sqlitebrowser.org/
>
> This is the license:
>
> https://github.com/sqlitebrowser/sqlitebrowser/blob/master/LICENSE
>
> DB Browser for SQLite is bi-licensed under the Mozilla Public
> License
>
> Version 2, as well as the GNU General Public License Version 3 or later.
>
>
> I think the description sounds more like an editor. I suggest the
> following "Sqlitebrowser is an editor..." for the synopsis.
> Replace the DB... name in the description with Sqlitebrowser.
> --
> Sent from my k-9 mail for Android.

I now tested building it and it seems to work fine.

I combed through the source and found this:

* libtiff
* webp

Is referenced in the cmake file but seems to be missing from inputs.

I found 4 bundled libraries:
in libs:
qscintilla (with 4 patches, could you investigate if our qscintilla has
these applied?)
antlr2 (seems equal to ours)

+2 small ones.

We have the 2 first in guix. Could you unbundle them if possible?

Please also document in the license field the various licenses of the
still bundled libs (qhexedit & qcustomplot) and add a comment in inputs
about them being bundled. (this helps us when somebody later on greppes
for them and find that they are bundled in x packages already and
decides to unbundle them all perhaps.

--
Cheers Swedebugia
Attachment: signature.asc
G
G
Guillaume Le Vaillant wrote on 21 Feb 2022 14:53
Re: Add sqlitebrowser
87a6eks4rj.fsf@kitej
sqlitebrowser is in Guix (9183b8142b43082fee55a2730399243dea47ad0a).
Closing.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYhOZ4A8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8CMwD+MB0FOejjiDXEoJHdpWHzApiTat4obcROCMZw
UYHzZ2YA/A20WCXjOQgr/+H508LOFr7rXfXObmhCkJb6pfoceNOe
=xs/5
-----END PGP SIGNATURE-----

Closed
?