(name . guix-patches)(address . guix-patches@gnu.org)
Sqlitebrowser is a QT-based graphical browser for Sqlite databases. https://sqlitebrowser.org/
This is the license:
Toggle quote (1 lines)
> DB Browser for SQLite is bi-licensed under the Mozilla Public License
Version 2, as well as the GNU General Public License Version 3 or later.
From 289bb26320cfc64e16f62f8a50470f7bd66a9c14 Mon Sep 17 00:00:00 2001
From: Pkill -9 <pkill9@runbox.com>
Date: Fri, 22 Feb 2019 08:46:55 +0000
Subject: [PATCH] gnu: Add sqlitebrowser.
* gnu/packages/sqlite.scm (sqlitebrowser): New variable.
---
gnu/packages/sqlite.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
Toggle diff (60 lines)
diff --git a/gnu/packages/sqlite.scm b/gnu/packages/sqlite.scm
index 05d7ce6b9..1dd8ae004 100644
--- a/gnu/packages/sqlite.scm
+++ b/gnu/packages/sqlite.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,10 +31,13 @@
(define-module (gnu packages sqlite)
#:use-module (gnu packages)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages qt)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system cmake)
#:use-module (guix utils)
#:use-module (ice-9 match)
#:use-module (srfi srfi-26))
@@ -114,3 +118,31 @@ is in the public domain.")
"-DSQLITE_ENABLE_UNLOCK_NOTIFY "
"-DSQLITE_ENABLE_DBSTAT_VTAB "
"-DSQLITE_ENABLE_COLUMN_METADATA")))))))
+
+(define-public sqlitebrowser
+ (package
+ (name "sqlitebrowser")
+ (version "3.11.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sqlitebrowser/sqlitebrowser")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pfvq1gzbs6jqlc1w86zcrhf2s9261q56li8j9mbkcv0qgadlyn9"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests
+ (native-inputs
+ `(("qttools" ,qttools)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("sqlite" ,sqlite)))
+ (home-page "https://sqlitebrowser.org")
+ (synopsis "Graphical browser for sqlite databases")
+ (description "DB Browser for SQLite is a visual tool to create, design, and
+edit database files compatible with SQLite. It uses a familiar spreadsheet-like
+interface, and you don't need to learn complicated SQL commands.")
+ (license (list license:mpl2.0 license:gpl3+))))
--
2.20.1