[PATCH v2] Add sqlitebrowser.

  • Done
  • quality assurance status badge
Details
3 participants
  • Allan Adair
  • Nicolò Balzarotti
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
Allan Adair
Severity
normal
A
A
Allan Adair wrote on 7 Apr 2021 13:09
(address . guix-patches@gnu.org)(name . Allan Adair)(address . allan@adair.no)
20210407110953.14809-1-allan@adair.no
---
gnu/packages/databases.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index ce7afa82d0..ca80099254 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2021 Allan Adair <allan@adair.no>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3829,3 +3830,30 @@ PostreSQL, SQLite, ODBC and MySQL.")
"FreeTDS is an implementation of the Tabular DataStream protocol, used for
connecting to MS SQL and Sybase servers over TCP/IP.")
(license license:lgpl2.0+)))
+
+(define-public sqlitebrowser
+ (package
+ (name "sqlitebrowser")
+ (version "3.12.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sqlitebrowser/sqlitebrowser")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ray6cscx2qil1dfi7hmpijmq3kba49wn430ih1q4fkz9psjvrz1"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qttools" ,qttools)
+ ("sqlite" ,sqlite)))
+ (arguments
+ `(#:configure-flags '("-DENABLE_TESTING=ON")))
+ (home-page "https://sqlitebrowser.org/")
+ (synopsis "DB Browser for SQLite (DB4S) is a high quality, visual, open source tool to create, design, and edit database files compatible with SQLite.")
+ (description
+ "DB4S is for users and developers who want to create, search, and edit databases. DB4S uses a familiar spreadsheet-like interface, and complicated SQL commands do not have to be learned.")
+ (license (list license:gpl3+ license:mpl2.0))))
--
2.31.1
N
N
Nicolò Balzarotti wrote on 7 Apr 2021 17:56
(name . Allan Adair)(address . allan@adair.no)
871rbmnl5a.fsf@guixSD.i-did-not-set--mail-host-address--so-tickle-me
Hi, thanks for the contribution!

A few comments below

Allan Adair <allan@adair.no> writes:

Toggle quote (2 lines)
> + (description
> + "DB4S is for users and developers who want to create, search, and edit databases. DB4S uses a familiar spreadsheet-like interface, and complicated SQL commands do not have to be learned.")
I think the linter here will complain about the single space after the
period, and for the really long line.

Did you run ./pre-inst-env guix lint sqlitebrowser ? This should tell
you if something is wrong

Toggle quote (1 lines)
> + (license (list license:gpl3+ license:mpl2.0))))
I see that there are bundled dependencies (under /libs), could you try
unbundle them (remove the lib folder with a source snippet) and build
using guix dependencies? There are only four of them, two of which
(nlohmann-json-cpp and qscintilla) are already in guix. Else it might
be needed to fix the licence.

There are the cmake flags FORCE_INTERNAL_QSCINTILLA,
FORCE_INTERNAL_QCUSTOMPLOT, FORCE_INTERNAL_QHEXEDIT which suggest this
should be possible.

Thanks, Nicolò
A
A
Allan Adair wrote on 9 Apr 2021 13:07
b8d4bbee-fd1c-a20c-4c07-c7f365860e9e@adair.no
Hi Nicolò.

On 4/7/21 5:56 PM, Nicolò Balzarotti wrote:

Toggle quote (3 lines)
> Did you run ./pre-inst-env guix lint sqlitebrowser ? This should tell
> you if something is wrong

Thanks! I really appreciate this guidance! It was an oversight on my part.

Toggle quote (7 lines)
>> + (license (list license:gpl3+ license:mpl2.0))))
> I see that there are bundled dependencies (under /libs), could you try
> unbundle them (remove the lib folder with a source snippet) and build
> using guix dependencies? There are only four of them, two of which
> (nlohmann-json-cpp and qscintilla) are already in guix. Else it might
> be needed to fix the licence.

I have been trying over the past couple of days with some difficulty. I
will continue with some more effort next week, but since I am not an
expert on the codebase (or cmake!) I may beg for fixing the licenses
instead.
G
G
Guillaume Le Vaillant wrote on 21 Feb 2022 14:53
Re: Add sqlitebrowser
87a6eks4rj.fsf@kitej
sqlitebrowser is in Guix (9183b8142b43082fee55a2730399243dea47ad0a).
Closing.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYhOZ4A8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8CMwD+MB0FOejjiDXEoJHdpWHzApiTat4obcROCMZw
UYHzZ2YA/A20WCXjOQgr/+H508LOFr7rXfXObmhCkJb6pfoceNOe
=xs/5
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 47640@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47640
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch